Elastic Search Mapping does not provide index_options and index fields


(Akash Sudhakar) #1

Hi,
When we fetch the mapping of a particular elastic search index, we are not able to view below fields
1 . index
2. index_option

For example we create a new index using -

PUT /testindex
{
"settings": {
"index": {
"analysis": {
"filter": {
"pattern_capture": {
"type": "pattern_capture",
"preserve_original": 1,
"patterns": [
"([^ -]+)"
]
}
},
"analyzer": {
"tokenized_string": {
"type": "custom",
"tokenizer": "standard",
"filter": [
"standard",
"pattern_capture",
"lowercase",
"asciifolding",
"stop"
],
"stopwords_path": "stopwords_en.txt"
}
}
}
}
},
"mappings": {
"test": {
"properties": {
"actions": {
"properties": {
"subject": {
"type": "string",
"index": "analyzed",
"analyzer": "tokenized_string",
"index_options": "positions"
}
}
}
}
}
}
}

Now when we try to view mapping of testindex -
{ESURL}/testindex/_mappings/test?pretty

Output -

{
"testindex" : {
"mappings" : {
"test" : {
"properties" : {
"actions" : {
"properties" : {
"subject" : {
"type" : "string",
"analyzer" : "tokenized_string"
}
}
}
}
}
}
}
}

Below 2 fields are missing -

          "index": "analyzed",
          "index_options": "positions"

Kindly provide your inputs on this ?


(Mark Walkom) #2

What version are you running?


(Akash Sudhakar) #3

Hi,

ES Version is 2.4.2.


(Akash Sudhakar) #4

Hi,

Any update on this ?


(Akash Sudhakar) #5

Another observation -
"mappings" : {
"something" : {
"_source": {"enabled":true},

Here _source does not come in the mapping view.


(system) #6

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.