Elastic Search not accessible using public IP

Hi,

I have installed Elastic Search on RHEL 6.9. I am facing a weird issue, I am running elastic on port 17000. when I am trying to access ElasticSearch through IP address it says Connection Refused, from internal as well as external network. However, when I am running a nodejs server on the same port, it is accessible through IP address from anywhere. Clearly it's not a firewall issue.

I even tried configuring network.publish_host and network.host, however with these fields configured the elasticsearch service didn't start.

I even tried updating /etc/hosts and restarted the network service still no luck. it still says connection refused.

Which network interfaces is Elasticsearch bound to? If you do not change those fields, Elasticsearch binds to localhost by default, which means it will not be reachable from the network.

If Elasticsearch does not start, please share logfiles.

Thanks!

Hi @Apurv_Jain welcome :slight_smile: .

i hope below link will help you to access Elastic search based on IP step by step-

Access Elastic search from remote

Thanks
HadoopHelp