Elastic search not working on 3g network

i am using a dongle to connect to the INTERNET which uses 3g technology .
I cannot connect to my elastic search which is on port 9200 .
Same server is working from my normal wired connection .

Thanking you in advance .

Can you access your host by ping command or tracert?

Thanks for reply .
yes ping is working
also i m able to open servers default page [http://server.name] which is on port 80 in browser .
but i cannot open http://server.name:9200 .

elasticsearch.yml

ElasticSearch, by default, binds itself to the 0.0.0.0 address, and listens

on port [9200-9300] for HTTP traffic and on port [9300-9400] for node-to-node

communication. (the range means that if the port is busy, it will automatically

try the next port).

Set the bind address specifically (IPv4 or IPv6):

network.bind_host: 192.168.0.1

Set the address other nodes will use to communicate with this node. If not

set, it is automatically derived. It must point to an actual IP address.

network.publish_host: 192.168.0.1

Set both 'bind_host' and 'publish_host':

network.host: 10.112.1.10

Set a custom port to listen for HTTP traffic:

http.port: 9200

Is addresses declared at your elasticsearch.yml are the same that you try to connect?

Can you access to your port by telnet?

like,
root@elastic0:/opt/prepare# telnet localhost 9200
Trying 127.0.0.1...
telnet: Unable to connect to remote host: Connection refused
root@elastic0:/opt/prepare# telnet 10.112.1.10 9200
Trying 10.112.1.10...
Connected to 10.112.1.10.
Escape character is '^]'.
^
Connection closed by foreign host.

" telnet localhost 9200 "
is working from same server where elastic search is hosted .
and "telnet server.ip 9200 "
is also working from any other machine .
but same command "telnet server.ip 9200 "
not working from my 3g network connected machine .

also we are using single node so "publish_host" and "bind_host" are not significant they pointing to accurate point .
that is the reason search works perfectly with all other network than 3g dongle network .

I'm not exactly sure but seems transport by 9200 port is closed, or filtered by your 3G operator, if telnet perfectly works on any other communications, and seems this is not problem of ES.

Maybe you can check it by using traceroute command from Linux:
traceroute -T -p 9200 your_ip

Try it using 3G and normal wired connection separately each other

Perhaps you can change your config and run ES on port 80 so it won't be blocked.

--
David :wink:
Twitter : @dadoonet / @elasticsearchfr / @scrutmydocs

Le 27 déc. 2012 à 12:45, ku3ia demesg@gmail.com a écrit :

I'm not exactly sure but seems transport by 9200 port is closed, or filtered
by your 3G operator, if telnet perfectly works on any other communications,
and seems this is not problem of ES.

Maybe you can check it by using traceroute command from Linux:
traceroute -T -p 9200 your_ip

Try it using 3G and normal wired connection separately each other

--
View this message in context: http://elasticsearch-users.115913.n3.nabble.com/elastic-search-not-working-on-3g-network-tp4027457p4027470.html
Sent from the ElasticSearch Users mailing list archive at Nabble.com.

--

--

Its can be done ONLY if port 80 is not busy

Perhaps you can change your config and run ES on port 80 so it won't be blocked.

--
David :wink:
Twitter : @dadoonet / @elasticsearchfr / @scrutmydocs

Le 27 déc. 2012 à 12:45, ku3ia <demesg@> a écrit :

I'm not exactly sure but seems transport by 9200 port is closed, or filtered
by your 3G operator, if telnet perfectly works on any other communications,
and seems this is not problem of ES.

Maybe you can check it by using traceroute command from Linux:
traceroute -T -p 9200 your_ip

Try it using 3G and normal wired connection separately each other

--
View this message in context: http://elasticsearch-users.115913.n3.nabble.com/elastic-search-not-working-on-3g-network-tp4027457p4027470.html
Sent from the ElasticSearch Users mailing list archive at Nabble.com.

--

--

dadoonet thanx for reply but as correctly pointed by ku3ia my port 80 is not free .

also ku3ia unfortunately my testing machine is windows so i cant use
traceroute
so i used tracert it again it working fine for port 80 .
i m figuring out how to pass port option for tracert ,
do you know any other solution .

Windows tracrt utility doesn't be able to make route on specified port.
Sorry, but I don't know, maybe you can find any system utilities under Windows to check it, but if telnet doesn't works seems port is closed/filtered.

thank you all for ur attention .
finally i routed my apache to different port and elastic to 80 .
so it start working .
but still i m in search of better solution .
so if you found any solution plz let me know
i read about varnish(didn't get what exactly it is ? ).