Elastic Search Upgrade


(Resmi) #1

Hi,

I was upgrading ES 1.3 to 1.4 .
I could upgrade to 1.4, but the index relocation is really very slow.
I followed the below steps for upgrade;
• Disabled Shard reallocation
• Shutdown the instance:
• Installed the new ElasticSearch version, removed the old ES windows service, installed and Started the new one.
And the installation process also still going on.
even after two days, not all indexes got upgraded.It still shows 'high disk watermark [10%] exceeded on [ZZ0ThBp9T4SRrX7d2qF1uw
John Sublime] free: 8.8gb[3.5%], shards will be relocated away from this node'

Thanks in advance


(David Pilato) #2

There are limits now about how many disk space is left.
You can change those settings if needed or add more nodes in your cluster.

Also consider upgrading to 1.7 at least.


(Resmi) #3

Hi,
Thanks for the reply.
I have updated to latest 2.1 and all working fine.
Now, ElasticSearch is accessible localhost only. You know what might be reason?

Thanks in advance


(David Pilato) #4

Change network.host
Read breaking changes i


(Resmi) #5

Hi,
I was able to access ElasticSearch like this before( http://web7.cloudapp.net:9200/) when our version was 1.3.0.
I tried to set this domain name to network.host in yaml
But it is not starting the ElasticSearch service even.

It is urgent for me.Please help me..

Regards


(David Pilato) #6

You should try one of those settings: https://www.elastic.co/guide/en/elasticsearch/reference/current/modules-network.html


(Resmi) #7

Thanks a lot...
I got it working.. :slight_smile:


(system) #8