Elasticsearch 0.90.5 as a service on Windows, memory crashes


(Josh Harrison) #1

Hi all,
I've installed Elasticsearch as a service on a Windows server 2012 system,
and have been having some odd problems that I don't see running on
linux/osx servers.
About every 24 hours, I would discover that ES had gotten extremely slow in
response time, on order of a minute. The only running indexing over this
time period was a twitter river. I looked, and memory consumption was over
32GB. Restart the service, and it's OK.
I set my ES_HEAP_SIZE to 20GB and everything seemed fine for a while, until
I started indexing some new stuff. Only about 800,000 records into the
indexing process, ES had the same runaway memory consumption and locked up
the same way.
There are never any explicit errors, just extremely slow response time that
cause the rest of my ingestion process to break.
Since then I've successfully indexed a couple million more records without
any obvious problem, but I'm concerned that this is going to happen again.
Any ideas?
Thanks,
Josh

--
You received this message because you are subscribed to the Google Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an email to elasticsearch+unsubscribe@googlegroups.com.
For more options, visit https://groups.google.com/groups/opt_out.


(Costin Leau) #2

What JDK/JRE version and Windows version are you using (32 vs 64, JDK or JRE, etc...)?

Cheers,

On 14/11/2013 8:44 PM, Josh Harrison wrote:

Hi all,
I've installed Elasticsearch as a service on a Windows server 2012 system, and have been having some odd problems that I
don't see running on linux/osx servers.
About every 24 hours, I would discover that ES had gotten extremely slow in response time, on order of a minute. The
only running indexing over this time period was a twitter river. I looked, and memory consumption was over 32GB. Restart
the service, and it's OK.
I set my ES_HEAP_SIZE to 20GB and everything seemed fine for a while, until I started indexing some new stuff. Only
about 800,000 records into the indexing process, ES had the same runaway memory consumption and locked up the same way.
There are never any explicit errors, just extremely slow response time that cause the rest of my ingestion process to break.
Since then I've successfully indexed a couple million more records without any obvious problem, but I'm concerned that
this is going to happen again.
Any ideas?
Thanks,
Josh

--
You received this message because you are subscribed to the Google Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an email to
elasticsearch+unsubscribe@googlegroups.com.
For more options, visit https://groups.google.com/groups/opt_out.

--
Costin

--
You received this message because you are subscribed to the Google Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an email to elasticsearch+unsubscribe@googlegroups.com.
For more options, visit https://groups.google.com/groups/opt_out.


(Josh Harrison) #3

Java version 1.7.0_40, 64 bit, 64 bit Windows 2012 Standard with 64GB of ram

On Thursday, November 14, 2013 11:00:29 AM UTC-8, Costin Leau wrote:

What JDK/JRE version and Windows version are you using (32 vs 64, JDK or
JRE, etc...)?

Cheers,

On 14/11/2013 8:44 PM, Josh Harrison wrote:

Hi all,
I've installed Elasticsearch as a service on a Windows server 2012
system, and have been having some odd problems that I
don't see running on linux/osx servers.
About every 24 hours, I would discover that ES had gotten extremely slow
in response time, on order of a minute. The
only running indexing over this time period was a twitter river. I
looked, and memory consumption was over 32GB. Restart
the service, and it's OK.
I set my ES_HEAP_SIZE to 20GB and everything seemed fine for a while,
until I started indexing some new stuff. Only
about 800,000 records into the indexing process, ES had the same runaway
memory consumption and locked up the same way.
There are never any explicit errors, just extremely slow response time
that cause the rest of my ingestion process to break.
Since then I've successfully indexed a couple million more records
without any obvious problem, but I'm concerned that
this is going to happen again.
Any ideas?
Thanks,
Josh

--
You received this message because you are subscribed to the Google
Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send
an email to
elasticsearc...@googlegroups.com <javascript:>.
For more options, visit https://groups.google.com/groups/opt_out.

--
Costin

--
You received this message because you are subscribed to the Google Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an email to elasticsearch+unsubscribe@googlegroups.com.
For more options, visit https://groups.google.com/groups/opt_out.


(Costin Leau) #4

Is it a JRE or JDK that you are using? Windows 2012 R2 or R1?

I recall JDK 1.7u45 fixed some issues related to memory or network sockets leaking (don't have the release notes at
hand) so I would advice upgrading the JDK. If you still encounter the issue try downgrading to the latest JDK 1.6 update 45.

I'm guessing the issue is OS/JDK related as it didn't occur on linux/osx.

P.S. Note that the twitter river might be the culprit here in the way in handles the network...

On 14/11/2013 9:18 PM, Josh Harrison wrote:

Java version 1.7.0_40, 64 bit, 64 bit Windows 2012 Standard with 64GB of ram

On Thursday, November 14, 2013 11:00:29 AM UTC-8, Costin Leau wrote:

What JDK/JRE version and Windows version are you using (32 vs 64, JDK or JRE, etc...)?

Cheers,

On 14/11/2013 8:44 PM, Josh Harrison wrote:
> Hi all,
> I've installed Elasticsearch as a service on a Windows server 2012 system, and have been having some odd problems that I
> don't see running on linux/osx servers.
> About every 24 hours, I would discover that ES had gotten extremely slow in response time, on order of a minute. The
> only running indexing over this time period was a twitter river. I looked, and memory consumption was over 32GB. Restart
> the service, and it's OK.
> I set my ES_HEAP_SIZE to 20GB and everything seemed fine for a while, until I started indexing some new stuff. Only
> about 800,000 records into the indexing process, ES had the same runaway memory consumption and locked up the same way.
> There are never any explicit errors, just extremely slow response time that cause the rest of my ingestion process to break.
> Since then I've successfully indexed a couple million more records without any obvious problem, but I'm concerned that
> this is going to happen again.
> Any ideas?
> Thanks,
> Josh
>
> --
> You received this message because you are subscribed to the Google Groups "elasticsearch" group.
> To unsubscribe from this group and stop receiving emails from it, send an email to
>elasticsearc...@googlegroups.com <javascript:>.
> For more options, visithttps://groups.google.com/groups/opt_out <https://groups.google.com/groups/opt_out>.

--
Costin

--
You received this message because you are subscribed to the Google Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an email to
elasticsearch+unsubscribe@googlegroups.com.
For more options, visit https://groups.google.com/groups/opt_out.

--
Costin

--
You received this message because you are subscribed to the Google Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an email to elasticsearch+unsubscribe@googlegroups.com.
For more options, visit https://groups.google.com/groups/opt_out.


(Josh Harrison) #5

Looks like plain jane RTM 2012, and it's JRE. I'll try installing JDK 7u45
later today when the system isn't in active use, thanks!

On Thursday, November 14, 2013 11:26:24 AM UTC-8, Costin Leau wrote:

Is it a JRE or JDK that you are using? Windows 2012 R2 or R1?

I recall JDK 1.7u45 fixed some issues related to memory or network sockets
leaking (don't have the release notes at
hand) so I would advice upgrading the JDK. If you still encounter the
issue try downgrading to the latest JDK 1.6 update 45.

I'm guessing the issue is OS/JDK related as it didn't occur on linux/osx.

P.S. Note that the twitter river might be the culprit here in the way in
handles the network...

On 14/11/2013 9:18 PM, Josh Harrison wrote:

Java version 1.7.0_40, 64 bit, 64 bit Windows 2012 Standard with 64GB of
ram

On Thursday, November 14, 2013 11:00:29 AM UTC-8, Costin Leau wrote:

What JDK/JRE version and Windows version are you using (32 vs 64, 

JDK or JRE, etc...)?

Cheers, 

On 14/11/2013 8:44 PM, Josh Harrison wrote: 
> Hi all, 
> I've installed Elasticsearch as a service on a Windows server 2012 

system, and have been having some odd problems that I

> don't see running on linux/osx servers. 
> About every 24 hours, I would discover that ES had gotten 

extremely slow in response time, on order of a minute. The

> only running indexing over this time period was a twitter river. I 

looked, and memory consumption was over 32GB. Restart

> the service, and it's OK. 
> I set my ES_HEAP_SIZE to 20GB and everything seemed fine for a 

while, until I started indexing some new stuff. Only

> about 800,000 records into the indexing process, ES had the same 

runaway memory consumption and locked up the same way.

> There are never any explicit errors, just extremely slow response 

time that cause the rest of my ingestion process to break.

> Since then I've successfully indexed a couple million more records 

without any obvious problem, but I'm concerned that

> this is going to happen again. 
> Any ideas? 
> Thanks, 
> Josh 
> 
> -- 
> You received this message because you are subscribed to the Google 

Groups "elasticsearch" group.

> To unsubscribe from this group and stop receiving emails from it, 

send an email to

>elasticsearc...@googlegroups.com <javascript:>. 
> For more options, visithttps://groups.google.com/groups/opt_out <

https://groups.google.com/groups/opt_out>.

-- 
Costin 

--
You received this message because you are subscribed to the Google
Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send
an email to
elasticsearc...@googlegroups.com <javascript:>.
For more options, visit https://groups.google.com/groups/opt_out.

--
Costin

--
You received this message because you are subscribed to the Google Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an email to elasticsearch+unsubscribe@googlegroups.com.
For more options, visit https://groups.google.com/groups/opt_out.


(Josh Harrison) #6

Unfortunately this still seems to be experiencing the runaway events, this
time the system was locked up so bad I had to reboot in order to get the
service restarted, this is with 1.7u45 JDK installed. Our security policies
prohibit me from rolling back to try 1.6, unfortunately.
I hope we can move to a linux host at some point, all those test systems
have been relatively stable.

On Thursday, November 14, 2013 11:57:25 AM UTC-8, Josh Harrison wrote:

Looks like plain jane RTM 2012, and it's JRE. I'll try installing JDK
7u45 later today when the system isn't in active use, thanks!

On Thursday, November 14, 2013 11:26:24 AM UTC-8, Costin Leau wrote:

Is it a JRE or JDK that you are using? Windows 2012 R2 or R1?

I recall JDK 1.7u45 fixed some issues related to memory or network
sockets leaking (don't have the release notes at
hand) so I would advice upgrading the JDK. If you still encounter the
issue try downgrading to the latest JDK 1.6 update 45.

I'm guessing the issue is OS/JDK related as it didn't occur on linux/osx.

P.S. Note that the twitter river might be the culprit here in the way in
handles the network...

On 14/11/2013 9:18 PM, Josh Harrison wrote:

Java version 1.7.0_40, 64 bit, 64 bit Windows 2012 Standard with 64GB
of ram

On Thursday, November 14, 2013 11:00:29 AM UTC-8, Costin Leau wrote:

What JDK/JRE version and Windows version are you using (32 vs 64, 

JDK or JRE, etc...)?

Cheers, 

On 14/11/2013 8:44 PM, Josh Harrison wrote: 
> Hi all, 
> I've installed Elasticsearch as a service on a Windows server 

2012 system, and have been having some odd problems that I

> don't see running on linux/osx servers. 
> About every 24 hours, I would discover that ES had gotten 

extremely slow in response time, on order of a minute. The

> only running indexing over this time period was a twitter river. 

I looked, and memory consumption was over 32GB. Restart

> the service, and it's OK. 
> I set my ES_HEAP_SIZE to 20GB and everything seemed fine for a 

while, until I started indexing some new stuff. Only

> about 800,000 records into the indexing process, ES had the same 

runaway memory consumption and locked up the same way.

> There are never any explicit errors, just extremely slow response 

time that cause the rest of my ingestion process to break.

> Since then I've successfully indexed a couple million more 

records without any obvious problem, but I'm concerned that

> this is going to happen again. 
> Any ideas? 
> Thanks, 
> Josh 
> 
> -- 
> You received this message because you are subscribed to the 

Google Groups "elasticsearch" group.

> To unsubscribe from this group and stop receiving emails from it, 

send an email to

>elasticsearc...@googlegroups.com <javascript:>. 
> For more options, visithttps://groups.google.com/groups/opt_out <

https://groups.google.com/groups/opt_out>.

-- 
Costin 

--
You received this message because you are subscribed to the Google
Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send
an email to
elasticsearc...@googlegroups.com.
For more options, visit https://groups.google.com/groups/opt_out.

--
Costin

--
You received this message because you are subscribed to the Google Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an email to elasticsearch+unsubscribe@googlegroups.com.
To view this discussion on the web visit https://groups.google.com/d/msgid/elasticsearch/0e32211d-17d4-4775-9d2c-497ecbfe5773%40googlegroups.com.
For more options, visit https://groups.google.com/groups/opt_out.


(John Arnold (GNS)) #7

Josh, I'm running JRE 7u45 on Windows 2012 R2 in Azure with a much bigger
workload and I don't see this problem. Can you pastebin your ES config?
Have you set index caching to soft?

On Monday, December 2, 2013 8:31:08 AM UTC-8, Josh Harrison wrote:

Unfortunately this still seems to be experiencing the runaway events, this
time the system was locked up so bad I had to reboot in order to get the
service restarted, this is with 1.7u45 JDK installed. Our security policies
prohibit me from rolling back to try 1.6, unfortunately.
I hope we can move to a linux host at some point, all those test systems
have been relatively stable.

On Thursday, November 14, 2013 11:57:25 AM UTC-8, Josh Harrison wrote:

Looks like plain jane RTM 2012, and it's JRE. I'll try installing JDK
7u45 later today when the system isn't in active use, thanks!

On Thursday, November 14, 2013 11:26:24 AM UTC-8, Costin Leau wrote:

Is it a JRE or JDK that you are using? Windows 2012 R2 or R1?

I recall JDK 1.7u45 fixed some issues related to memory or network
sockets leaking (don't have the release notes at
hand) so I would advice upgrading the JDK. If you still encounter the
issue try downgrading to the latest JDK 1.6 update 45.

I'm guessing the issue is OS/JDK related as it didn't occur on
linux/osx.

P.S. Note that the twitter river might be the culprit here in the way in
handles the network...

On 14/11/2013 9:18 PM, Josh Harrison wrote:

Java version 1.7.0_40, 64 bit, 64 bit Windows 2012 Standard with 64GB
of ram

On Thursday, November 14, 2013 11:00:29 AM UTC-8, Costin Leau wrote:

What JDK/JRE version and Windows version are you using (32 vs 64, 

JDK or JRE, etc...)?

Cheers, 

On 14/11/2013 8:44 PM, Josh Harrison wrote: 
> Hi all, 
> I've installed Elasticsearch as a service on a Windows server 

2012 system, and have been having some odd problems that I

> don't see running on linux/osx servers. 
> About every 24 hours, I would discover that ES had gotten 

extremely slow in response time, on order of a minute. The

> only running indexing over this time period was a twitter river. 

I looked, and memory consumption was over 32GB. Restart

> the service, and it's OK. 
> I set my ES_HEAP_SIZE to 20GB and everything seemed fine for a 

while, until I started indexing some new stuff. Only

> about 800,000 records into the indexing process, ES had the same 

runaway memory consumption and locked up the same way.

> There are never any explicit errors, just extremely slow 

response time that cause the rest of my ingestion process to break.

> Since then I've successfully indexed a couple million more 

records without any obvious problem, but I'm concerned that

> this is going to happen again. 
> Any ideas? 
> Thanks, 
> Josh 
> 
> -- 
> You received this message because you are subscribed to the 

Google Groups "elasticsearch" group.

> To unsubscribe from this group and stop receiving emails from 

it, send an email to

>elasticsearc...@googlegroups.com <javascript:>. 
> For more options, visithttps://groups.google.com/groups/opt_out<

https://groups.google.com/groups/opt_out>.

-- 
Costin 

--
You received this message because you are subscribed to the Google
Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send
an email to
elasticsearc...@googlegroups.com.
For more options, visit https://groups.google.com/groups/opt_out.

--
Costin

On Monday, December 2, 2013 8:31:08 AM UTC-8, Josh Harrison wrote:

Unfortunately this still seems to be experiencing the runaway events, this
time the system was locked up so bad I had to reboot in order to get the
service restarted, this is with 1.7u45 JDK installed. Our security policies
prohibit me from rolling back to try 1.6, unfortunately.
I hope we can move to a linux host at some point, all those test systems
have been relatively stable.

On Thursday, November 14, 2013 11:57:25 AM UTC-8, Josh Harrison wrote:

Looks like plain jane RTM 2012, and it's JRE. I'll try installing JDK
7u45 later today when the system isn't in active use, thanks!

On Thursday, November 14, 2013 11:26:24 AM UTC-8, Costin Leau wrote:

Is it a JRE or JDK that you are using? Windows 2012 R2 or R1?

I recall JDK 1.7u45 fixed some issues related to memory or network
sockets leaking (don't have the release notes at
hand) so I would advice upgrading the JDK. If you still encounter the
issue try downgrading to the latest JDK 1.6 update 45.

I'm guessing the issue is OS/JDK related as it didn't occur on
linux/osx.

P.S. Note that the twitter river might be the culprit here in the way in
handles the network...

On 14/11/2013 9:18 PM, Josh Harrison wrote:

Java version 1.7.0_40, 64 bit, 64 bit Windows 2012 Standard with 64GB
of ram

On Thursday, November 14, 2013 11:00:29 AM UTC-8, Costin Leau wrote:

What JDK/JRE version and Windows version are you using (32 vs 64, 

JDK or JRE, etc...)?

Cheers, 

On 14/11/2013 8:44 PM, Josh Harrison wrote: 
> Hi all, 
> I've installed Elasticsearch as a service on a Windows server 

2012 system, and have been having some odd problems that I

> don't see running on linux/osx servers. 
> About every 24 hours, I would discover that ES had gotten 

extremely slow in response time, on order of a minute. The

> only running indexing over this time period was a twitter river. 

I looked, and memory consumption was over 32GB. Restart

> the service, and it's OK. 
> I set my ES_HEAP_SIZE to 20GB and everything seemed fine for a 

while, until I started indexing some new stuff. Only

> about 800,000 records into the indexing process, ES had the same 

runaway memory consumption and locked up the same way.

> There are never any explicit errors, just extremely slow 

response time that cause the rest of my ingestion process to break.

> Since then I've successfully indexed a couple million more 

records without any obvious problem, but I'm concerned that

> this is going to happen again. 
> Any ideas? 
> Thanks, 
> Josh 
> 
> -- 
> You received this message because you are subscribed to the 

Google Groups "elasticsearch" group.

> To unsubscribe from this group and stop receiving emails from 

it, send an email to

>elasticsearc...@googlegroups.com <javascript:>. 
> For more options, visithttps://groups.google.com/groups/opt_out<

https://groups.google.com/groups/opt_out>.

-- 
Costin 

--
You received this message because you are subscribed to the Google
Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send
an email to
elasticsearc...@googlegroups.com.
For more options, visit https://groups.google.com/groups/opt_out.

--
Costin

--
You received this message because you are subscribed to the Google Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an email to elasticsearch+unsubscribe@googlegroups.com.
To view this discussion on the web visit https://groups.google.com/d/msgid/elasticsearch/457e14d1-3437-439f-875f-0a170795967c%40googlegroups.com.
For more options, visit https://groups.google.com/groups/opt_out.


(Josh Harrison) #8

It's a weird one, to be sure. A coworker had ES running fine on her Windows
7 system for quite a while and never encountered this, and I've had it
running on OSX and RHEL just fine for quite a while too.
Only after posting that yesterday did I discover that while I had installed
1.7u45, and u45 was the system default, ES was not actually using u45. I've
switched that, and we'll see if that sticks.
The only entries in my ES config are clustername, path.data and
index.mapper.default_mapping_location
It looks like there are parameters that don't work on Windows, like
mlockall and the ability to inspect file descriptor usage, so the decision
has been made to move to RHEL on the host in question. Our other RHEL hosts
are doing just fine, so hopefully that'll resolve this issue.
I haven't explicitly set anything regarding index caching, so it probably
isn't soft unless that's the default!
Thanks,
Josh
On Tuesday, December 3, 2013 12:29:39 PM UTC-8, joh...@microsoft.com wrote:

Josh, I'm running JRE 7u45 on Windows 2012 R2 in Azure with a much bigger
workload and I don't see this problem. Can you pastebin your ES config?
Have you set index caching to soft?

On Monday, December 2, 2013 8:31:08 AM UTC-8, Josh Harrison wrote:

Unfortunately this still seems to be experiencing the runaway events,
this time the system was locked up so bad I had to reboot in order to get
the service restarted, this is with 1.7u45 JDK installed. Our security
policies prohibit me from rolling back to try 1.6, unfortunately.
I hope we can move to a linux host at some point, all those test systems
have been relatively stable.

On Thursday, November 14, 2013 11:57:25 AM UTC-8, Josh Harrison wrote:

Looks like plain jane RTM 2012, and it's JRE. I'll try installing JDK
7u45 later today when the system isn't in active use, thanks!

On Thursday, November 14, 2013 11:26:24 AM UTC-8, Costin Leau wrote:

Is it a JRE or JDK that you are using? Windows 2012 R2 or R1?

I recall JDK 1.7u45 fixed some issues related to memory or network
sockets leaking (don't have the release notes at
hand) so I would advice upgrading the JDK. If you still encounter the
issue try downgrading to the latest JDK 1.6 update 45.

I'm guessing the issue is OS/JDK related as it didn't occur on
linux/osx.

P.S. Note that the twitter river might be the culprit here in the way
in handles the network...

On 14/11/2013 9:18 PM, Josh Harrison wrote:

Java version 1.7.0_40, 64 bit, 64 bit Windows 2012 Standard with 64GB
of ram

On Thursday, November 14, 2013 11:00:29 AM UTC-8, Costin Leau wrote:

What JDK/JRE version and Windows version are you using (32 vs 64, 

JDK or JRE, etc...)?

Cheers, 

On 14/11/2013 8:44 PM, Josh Harrison wrote: 
> Hi all, 
> I've installed Elasticsearch as a service on a Windows server 

2012 system, and have been having some odd problems that I

> don't see running on linux/osx servers. 
> About every 24 hours, I would discover that ES had gotten 

extremely slow in response time, on order of a minute. The

> only running indexing over this time period was a twitter 

river. I looked, and memory consumption was over 32GB. Restart

> the service, and it's OK. 
> I set my ES_HEAP_SIZE to 20GB and everything seemed fine for a 

while, until I started indexing some new stuff. Only

> about 800,000 records into the indexing process, ES had the 

same runaway memory consumption and locked up the same way.

> There are never any explicit errors, just extremely slow 

response time that cause the rest of my ingestion process to break.

> Since then I've successfully indexed a couple million more 

records without any obvious problem, but I'm concerned that

> this is going to happen again. 
> Any ideas? 
> Thanks, 
> Josh 
> 
> -- 
> You received this message because you are subscribed to the 

Google Groups "elasticsearch" group.

> To unsubscribe from this group and stop receiving emails from 

it, send an email to

>elasticsearc...@googlegroups.com <javascript:>. 
> For more options, visithttps://groups.google.com/groups/opt_out<

https://groups.google.com/groups/opt_out>.

-- 
Costin 

--
You received this message because you are subscribed to the Google
Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it,
send an email to
elasticsearc...@googlegroups.com.
For more options, visit https://groups.google.com/groups/opt_out.

--
Costin

On Monday, December 2, 2013 8:31:08 AM UTC-8, Josh Harrison wrote:

Unfortunately this still seems to be experiencing the runaway events,
this time the system was locked up so bad I had to reboot in order to get
the service restarted, this is with 1.7u45 JDK installed. Our security
policies prohibit me from rolling back to try 1.6, unfortunately.
I hope we can move to a linux host at some point, all those test systems
have been relatively stable.

On Thursday, November 14, 2013 11:57:25 AM UTC-8, Josh Harrison wrote:

Looks like plain jane RTM 2012, and it's JRE. I'll try installing JDK
7u45 later today when the system isn't in active use, thanks!

On Thursday, November 14, 2013 11:26:24 AM UTC-8, Costin Leau wrote:

Is it a JRE or JDK that you are using? Windows 2012 R2 or R1?

I recall JDK 1.7u45 fixed some issues related to memory or network
sockets leaking (don't have the release notes at
hand) so I would advice upgrading the JDK. If you still encounter the
issue try downgrading to the latest JDK 1.6 update 45.

I'm guessing the issue is OS/JDK related as it didn't occur on
linux/osx.

P.S. Note that the twitter river might be the culprit here in the way
in handles the network...

On 14/11/2013 9:18 PM, Josh Harrison wrote:

Java version 1.7.0_40, 64 bit, 64 bit Windows 2012 Standard with 64GB
of ram

On Thursday, November 14, 2013 11:00:29 AM UTC-8, Costin Leau wrote:

What JDK/JRE version and Windows version are you using (32 vs 64, 

JDK or JRE, etc...)?

Cheers, 

On 14/11/2013 8:44 PM, Josh Harrison wrote: 
> Hi all, 
> I've installed Elasticsearch as a service on a Windows server 

2012 system, and have been having some odd problems that I

> don't see running on linux/osx servers. 
> About every 24 hours, I would discover that ES had gotten 

extremely slow in response time, on order of a minute. The

> only running indexing over this time period was a twitter 

river. I looked, and memory consumption was over 32GB. Restart

> the service, and it's OK. 
> I set my ES_HEAP_SIZE to 20GB and everything seemed fine for a 

while, until I started indexing some new stuff. Only

> about 800,000 records into the indexing process, ES had the 

same runaway memory consumption and locked up the same way.

> There are never any explicit errors, just extremely slow 

response time that cause the rest of my ingestion process to break.

> Since then I've successfully indexed a couple million more 

records without any obvious problem, but I'm concerned that

> this is going to happen again. 
> Any ideas? 
> Thanks, 
> Josh 
> 
> -- 
> You received this message because you are subscribed to the 

Google Groups "elasticsearch" group.

> To unsubscribe from this group and stop receiving emails from 

it, send an email to

>elasticsearc...@googlegroups.com <javascript:>. 
> For more options, visithttps://groups.google.com/groups/opt_out<

https://groups.google.com/groups/opt_out>.

-- 
Costin 

--
You received this message because you are subscribed to the Google
Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it,
send an email to
elasticsearc...@googlegroups.com.
For more options, visit https://groups.google.com/groups/opt_out.

--
Costin

--
You received this message because you are subscribed to the Google Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an email to elasticsearch+unsubscribe@googlegroups.com.
To view this discussion on the web visit https://groups.google.com/d/msgid/elasticsearch/96052265-ede0-4faf-9f3f-96ae99d11410%40googlegroups.com.
For more options, visit https://groups.google.com/groups/opt_out.


(system) #9