Elasticsearch 1.0 RC 1 - strange issue with multi_fields faceting


(Guillermo Arias del Río) #1

Hi, all!

I am using multi fields in my application in order to be able to search
using different index analyzers and perform faceting on the "untouched"
version of the field. The untouched version is always called like the field
itself and marked as "not_analyzed". This enables me to use the name
directly on the facets. On the other hand, I have an "index_analyzer" for
my whole type. This wasn't a problem with ES 0.90, but it is with 1.0rc1.

A Gist is worth a thousand words:

Just removing the "index_analyzer" makes it work.

Do I miss something? I thought that this "index_analyzer" is only used when
no one is specified for an analyzed field, but the field is "not_analyzed".

Cheers,

Guillermo.

--
You received this message because you are subscribed to the Google Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an email to elasticsearch+unsubscribe@googlegroups.com.
To view this discussion on the web visit https://groups.google.com/d/msgid/elasticsearch/4e50b688-1a48-444c-8925-f4015a35129d%40googlegroups.com.
For more options, visit https://groups.google.com/groups/opt_out.


(David Pilato) #2

Not tested but I think you should do something like: https://gist.github.com/dadoonet/8842209

HTH

--
David Pilato | Technical Advocate | Elasticsearch.com
@dadoonet | @elasticsearchfr

Le 6 février 2014 at 12:05:25, Guillermo Arias del Río (ariasdelrio@gmail.com) a écrit:

Hi, all!

I am using multi fields in my application in order to be able to search using different index analyzers and perform faceting on the "untouched" version of the field. The untouched version is always called like the field itself and marked as "not_analyzed". This enables me to use the name directly on the facets. On the other hand, I have an "index_analyzer" for my whole type. This wasn't a problem with ES 0.90, but it is with 1.0rc1.

A Gist is worth a thousand words:

Just removing the "index_analyzer" makes it work.

Do I miss something? I thought that this "index_analyzer" is only used when no one is specified for an analyzed field, but the field is "not_analyzed".

Cheers,

Guillermo.

You received this message because you are subscribed to the Google Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an email to elasticsearch+unsubscribe@googlegroups.com.
To view this discussion on the web visit https://groups.google.com/d/msgid/elasticsearch/4e50b688-1a48-444c-8925-f4015a35129d%40googlegroups.com.
For more options, visit https://groups.google.com/groups/opt_out.

--
You received this message because you are subscribed to the Google Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an email to elasticsearch+unsubscribe@googlegroups.com.
To view this discussion on the web visit https://groups.google.com/d/msgid/elasticsearch/etPan.52f36cf9.2f305def.d955%40MacBook-Air-de-David.local.
For more options, visit https://groups.google.com/groups/opt_out.


(Guillermo Arias del Río) #3

Sorry, I forgot to write the responses:

With "index_analyzer" set:

{
...
"facets": {
"myfacet": {
"_type": "terms",
"missing": 0,
"other": 98,
"terms": [
{
"count": 3,
"term": "e"
},
{
"count": 1,
"term": "eo"
},
{
"count": 1,
"term": "eon"
},
...

Without "index_analyzer":

"facets": {
"myfacet": {
"_type": "terms",
"missing": 0,
"other": 0,
"terms": [
{
"count": 1,
"term": "someone"
},
{
"count": 2,
"term": "something"
}
],
...

--
You received this message because you are subscribed to the Google Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an email to elasticsearch+unsubscribe@googlegroups.com.
To view this discussion on the web visit https://groups.google.com/d/msgid/elasticsearch/2a7f9cc2-a22b-40ef-b860-8414208dd745%40googlegroups.com.
For more options, visit https://groups.google.com/groups/opt_out.


(Guillermo Arias del Río) #4

Hi, David,

Thanks for the tip about not having to repeat the field name... reading herehttp://www.elasticsearch.org/guide/en/elasticsearch/reference/master/_multi_fields.html,
I didn't notice that difference :slight_smile:

It works now.

El jueves, 6 de febrero de 2014 12:07:37 UTC+1, David Pilato escribió:

Not tested but I think you should do something like:
https://gist.github.com/dadoonet/8842209

HTH

--
David Pilato | Technical Advocate | Elasticsearch.com
@dadoonet https://twitter.com/dadoonet | @elasticsearchfrhttps://twitter.com/elasticsearchfr

Le 6 février 2014 at 12:05:25, Guillermo Arias del Río (arias...@gmail.com<javascript:>)
a écrit:

Hi, all!

I am using multi fields in my application in order to be able to search
using different index analyzers and perform faceting on the "untouched"
version of the field. The untouched version is always called like the field
itself and marked as "not_analyzed". This enables me to use the name
directly on the facets. On the other hand, I have an "index_analyzer" for
my whole type. This wasn't a problem with ES 0.90, but it is with 1.0rc1.

A Gist is worth a thousand words:

https://gist.github.com/ariasdelrio/8842138

Just removing the "index_analyzer" makes it work.

Do I miss something? I thought that this "index_analyzer" is only used
when no one is specified for an analyzed field, but the field is
"not_analyzed".

Cheers,

Guillermo.

You received this message because you are subscribed to the Google Groups
"elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an
email to elasticsearc...@googlegroups.com <javascript:>.
To view this discussion on the web visit
https://groups.google.com/d/msgid/elasticsearch/4e50b688-1a48-444c-8925-f4015a35129d%40googlegroups.com
.
For more options, visit https://groups.google.com/groups/opt_out.

--
You received this message because you are subscribed to the Google Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an email to elasticsearch+unsubscribe@googlegroups.com.
To view this discussion on the web visit https://groups.google.com/d/msgid/elasticsearch/a71c3a0f-2438-46bc-bd5e-ff2b9e60461a%40googlegroups.com.
For more options, visit https://groups.google.com/groups/opt_out.


(system) #5