Elasticsearch 1.3.2 process logging.yml as a json foramt when logging.yml is deployed from subversion repo

I deploy these files from svn repository. since logging.yml is under
subversion there is a .svn/text-base/logging.yml.text-base file. ES load
this file ends with text-base and assumes its a json format. a

org.elasticsearch.common.jackson.core.JsonParseException is raised. Is
there a way to tell es that my file is yml not jason?

This problem does not happen with 1.1.0.

--
You received this message because you are subscribed to the Google Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an email to elasticsearch+unsubscribe@googlegroups.com.
To view this discussion on the web visit https://groups.google.com/d/msgid/elasticsearch/4510928c-b0e9-47ad-8645-f01c23700d37%40googlegroups.com.
For more options, visit https://groups.google.com/d/optout.

We have the same problem is reading .svn/text-base/logging.yml.text-base
and fails to setup logging.
I think the loading logic should be a little more restrictive. Loading
everything that starts with "logging." including files in "hidden"
directories, is a little bit too much.

I fixed it with mounting an empty directory over the .svn directory. It's
no problem for us since we mount it over NFS and manage it on another host
(without the .svn empty directory). You could add that to the initscript
(mount before starting and umount after the start), if you need to use svn
on the host itself.
But imo that's a dirty hack and should be dealt with in elasticsearch (at
least ignoring "." directories).

Regards
Daniel

PS: See


(was not present in 1.2)

--
You received this message because you are subscribed to the Google Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an email to elasticsearch+unsubscribe@googlegroups.com.
To view this discussion on the web visit https://groups.google.com/d/msgid/elasticsearch/6679e635-5f23-4831-98d6-a34cb5997e66%40googlegroups.com.
For more options, visit https://groups.google.com/d/optout.

What i did is renamimg logging.yml to something else and then at startup
time I "copy" the contents to logging.yml
Thanks,
Jack

Jinyuan (Jack) Zhou

On Thu, Oct 9, 2014 at 2:28 AM, Daniel P. thetuxkeeper@gmail.com wrote:

We have the same problem is reading .svn/text-base/logging.yml.text-base
and fails to setup logging.
I think the loading logic should be a little more restrictive. Loading
everything that starts with "logging." including files in "hidden"
directories, is a little bit too much.

I fixed it with mounting an empty directory over the .svn directory. It's
no problem for us since we mount it over NFS and manage it on another host
(without the .svn empty directory). You could add that to the initscript
(mount before starting and umount after the start), if you need to use svn
on the host itself.
But imo that's a dirty hack and should be dealt with in elasticsearch (at
least ignoring "." directories).

Regards
Daniel

PS: See
https://github.com/elasticsearch/elasticsearch/blob/1.3/src/main/java/org/elasticsearch/common/logging/log4j/LogConfigurator.java#L107
(was not present in 1.2)

--
You received this message because you are subscribed to a topic in the
Google Groups "elasticsearch" group.
To unsubscribe from this topic, visit
https://groups.google.com/d/topic/elasticsearch/8zlwEj12DjI/unsubscribe.
To unsubscribe from this group and all its topics, send an email to
elasticsearch+unsubscribe@googlegroups.com.
To view this discussion on the web visit
https://groups.google.com/d/msgid/elasticsearch/6679e635-5f23-4831-98d6-a34cb5997e66%40googlegroups.com
https://groups.google.com/d/msgid/elasticsearch/6679e635-5f23-4831-98d6-a34cb5997e66%40googlegroups.com?utm_medium=email&utm_source=footer
.
For more options, visit https://groups.google.com/d/optout.

--
You received this message because you are subscribed to the Google Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an email to elasticsearch+unsubscribe@googlegroups.com.
To view this discussion on the web visit https://groups.google.com/d/msgid/elasticsearch/CANBTPCG56Q3kgzGD-1jrQqrX_FeQdgB6vj--v-Kh7ANzQ83SGw%40mail.gmail.com.
For more options, visit https://groups.google.com/d/optout.

Ok, moving/copying is also a way to solve it. But in my case it wouldn't
work since we have a readonly nfs mount.

I opened an issue:

Let's see what happens. :slight_smile:

On Thursday, October 9, 2014 5:08:19 PM UTC+2, Jinyuan Zhou wrote:

What i did is renamimg logging.yml to something else and then at startup
time I "copy" the contents to logging.yml
Thanks,
Jack

Jinyuan (Jack) Zhou

On Thu, Oct 9, 2014 at 2:28 AM, Daniel P. <thetux...@gmail.com
<javascript:>> wrote:

We have the same problem is reading .svn/text-base/logging.yml.text-base
and fails to setup logging.
I think the loading logic should be a little more restrictive. Loading
everything that starts with "logging." including files in "hidden"
directories, is a little bit too much.

I fixed it with mounting an empty directory over the .svn directory. It's
no problem for us since we mount it over NFS and manage it on another host
(without the .svn empty directory). You could add that to the initscript
(mount before starting and umount after the start), if you need to use svn
on the host itself.
But imo that's a dirty hack and should be dealt with in elasticsearch (at
least ignoring "." directories).

Regards
Daniel

PS: See
https://github.com/elasticsearch/elasticsearch/blob/1.3/src/main/java/org/elasticsearch/common/logging/log4j/LogConfigurator.java#L107
(was not present in 1.2)

--
You received this message because you are subscribed to a topic in the
Google Groups "elasticsearch" group.
To unsubscribe from this topic, visit
https://groups.google.com/d/topic/elasticsearch/8zlwEj12DjI/unsubscribe.
To unsubscribe from this group and all its topics, send an email to
elasticsearc...@googlegroups.com <javascript:>.
To view this discussion on the web visit
https://groups.google.com/d/msgid/elasticsearch/6679e635-5f23-4831-98d6-a34cb5997e66%40googlegroups.com
https://groups.google.com/d/msgid/elasticsearch/6679e635-5f23-4831-98d6-a34cb5997e66%40googlegroups.com?utm_medium=email&utm_source=footer
.
For more options, visit https://groups.google.com/d/optout.

--
You received this message because you are subscribed to the Google Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an email to elasticsearch+unsubscribe@googlegroups.com.
To view this discussion on the web visit https://groups.google.com/d/msgid/elasticsearch/43972cc8-2510-49f8-b85f-7189e501919a%40googlegroups.com.
For more options, visit https://groups.google.com/d/optout.

Thanks for open an issue.

Jinyuan (Jack) Zhou

On Thu, Oct 9, 2014 at 12:19 PM, Daniel P. thetuxkeeper@gmail.com wrote:

Ok, moving/copying is also a way to solve it. But in my case it wouldn't
work since we have a readonly nfs mount.

I opened an issue:
https://github.com/elasticsearch/elasticsearch/issues/8040

Let's see what happens. :slight_smile:

On Thursday, October 9, 2014 5:08:19 PM UTC+2, Jinyuan Zhou wrote:

What i did is renamimg logging.yml to something else and then at startup
time I "copy" the contents to logging.yml
Thanks,
Jack

Jinyuan (Jack) Zhou

On Thu, Oct 9, 2014 at 2:28 AM, Daniel P. thetux...@gmail.com wrote:

We have the same problem is reading .svn/text-base/logging.yml.text-base
and fails to setup logging.
I think the loading logic should be a little more restrictive. Loading
everything that starts with "logging." including files in "hidden"
directories, is a little bit too much.

I fixed it with mounting an empty directory over the .svn directory.
It's no problem for us since we mount it over NFS and manage it on another
host (without the .svn empty directory). You could add that to the
initscript (mount before starting and umount after the start), if you need
to use svn on the host itself.
But imo that's a dirty hack and should be dealt with in elasticsearch
(at least ignoring "." directories).

Regards
Daniel

PS: See https://github.com/elasticsearch/elasticsearch/
blob/1.3/src/main/java/org/elasticsearch/common/logging/
log4j/LogConfigurator.java#L107 (was not present in 1.2)

--
You received this message because you are subscribed to a topic in the
Google Groups "elasticsearch" group.
To unsubscribe from this topic, visit https://groups.google.com/d/
topic/elasticsearch/8zlwEj12DjI/unsubscribe.
To unsubscribe from this group and all its topics, send an email to
elasticsearc...@googlegroups.com.
To view this discussion on the web visit https://groups.google.com/d/
msgid/elasticsearch/6679e635-5f23-4831-98d6-a34cb5997e66%
40googlegroups.com
https://groups.google.com/d/msgid/elasticsearch/6679e635-5f23-4831-98d6-a34cb5997e66%40googlegroups.com?utm_medium=email&utm_source=footer
.
For more options, visit https://groups.google.com/d/optout.

--
You received this message because you are subscribed to a topic in the
Google Groups "elasticsearch" group.
To unsubscribe from this topic, visit
https://groups.google.com/d/topic/elasticsearch/8zlwEj12DjI/unsubscribe.
To unsubscribe from this group and all its topics, send an email to
elasticsearch+unsubscribe@googlegroups.com.
To view this discussion on the web visit
https://groups.google.com/d/msgid/elasticsearch/43972cc8-2510-49f8-b85f-7189e501919a%40googlegroups.com
https://groups.google.com/d/msgid/elasticsearch/43972cc8-2510-49f8-b85f-7189e501919a%40googlegroups.com?utm_medium=email&utm_source=footer
.

For more options, visit https://groups.google.com/d/optout.

--
You received this message because you are subscribed to the Google Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an email to elasticsearch+unsubscribe@googlegroups.com.
To view this discussion on the web visit https://groups.google.com/d/msgid/elasticsearch/CANBTPCGh%2BZdnBhZAmXvKb_gEZ5XjRBVFgYX9BV6FZXZbSmeNPA%40mail.gmail.com.
For more options, visit https://groups.google.com/d/optout.