Elasticsearch wont start on Ubuntu 14.04


(Steven Yue) #1

Hi, everyone

I'm trying to install elasticsearch 1.2.1 on a ubuntu 14.04 server.

I used the dpkg -i to install

When I run 'sudo /etc/init.d/elasticsearch start', it says: "Starting
Elasticsearch Server [ OK ]", but actually no process is ever started, and
I couldn't find any errors or any logs in the log folder(
/var/log/elasticsearch).

I tried to run 'sudo /usr/share/elasticsearch/bin/elasticsearch start'
directly, and it is able to start and i can get response when using curl,
although it gives me the following warnning:

log4j:WARN No appenders could be found for logger (node).
log4j:WARN Please initialize the log4j system properly.
log4j:WARN See http://logging.apache.org/log4j/1.2/faq.html#noconfig for
more info.

I tried to edit settings in /etc/default/elasticsearch, uncommented the
following lines:

ES_HEAP_SIZE=2g

MAX_LOCKED_MEMORY=unlimited

Elasticsearch log directory

LOG_DIR=/var/log/elasticsearch

Elasticsearch data directory

DATA_DIR=/home/data/elasticsearch

Elasticsearch work directory

WORK_DIR=/home/tmp/elasticsearch

Elasticsearch configuration directory

CONF_DIR=/etc/elasticsearch

Elasticsearch configuration file (elasticsearch.yml)

CONF_FILE=/etc/elasticsearch/elasticsearch.yml

When restart the service, I did see it created the folder, but still failed
to run, even thought it says 'OK'

Could anyone help me to figure out why and how to run it? Thanks

--
You received this message because you are subscribed to the Google Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an email to elasticsearch+unsubscribe@googlegroups.com.
To view this discussion on the web visit https://groups.google.com/d/msgid/elasticsearch/5c4e3f7c-57d6-4932-bbe6-57aa5014f7c6%40googlegroups.com.
For more options, visit https://groups.google.com/d/optout.


(sri) #2

Hi Steven,

Change the logging level to TRACE or DEBUG and check the logs , you should
be able to identify the problem.
Hope that helps

Thanks and Regards
Sri

On Friday, June 27, 2014 10:51:36 AM UTC-4, Steven Yue wrote:

Hi, everyone

I'm trying to install elasticsearch 1.2.1 on a ubuntu 14.04 server.

I used the dpkg -i to install

When I run 'sudo /etc/init.d/elasticsearch start', it says: "Starting
Elasticsearch Server [ OK ]", but actually no process is ever started, and
I couldn't find any errors or any logs in the log folder(
/var/log/elasticsearch).

I tried to run 'sudo /usr/share/elasticsearch/bin/elasticsearch start'
directly, and it is able to start and i can get response when using curl,
although it gives me the following warnning:

log4j:WARN No appenders could be found for logger (node).
log4j:WARN Please initialize the log4j system properly.
log4j:WARN See http://logging.apache.org/log4j/1.2/faq.html#noconfig for
more info.

I tried to edit settings in /etc/default/elasticsearch, uncommented the
following lines:

ES_HEAP_SIZE=2g

MAX_LOCKED_MEMORY=unlimited

Elasticsearch log directory

LOG_DIR=/var/log/elasticsearch

Elasticsearch data directory

DATA_DIR=/home/data/elasticsearch

Elasticsearch work directory

WORK_DIR=/home/tmp/elasticsearch

Elasticsearch configuration directory

CONF_DIR=/etc/elasticsearch

Elasticsearch configuration file (elasticsearch.yml)

CONF_FILE=/etc/elasticsearch/elasticsearch.yml

When restart the service, I did see it created the folder, but still
failed to run, even thought it says 'OK'

Could anyone help me to figure out why and how to run it? Thanks

--
You received this message because you are subscribed to the Google Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an email to elasticsearch+unsubscribe@googlegroups.com.
To view this discussion on the web visit https://groups.google.com/d/msgid/elasticsearch/a208926a-500b-4882-80f4-9e5678293fa6%40googlegroups.com.
For more options, visit https://groups.google.com/d/optout.


(Steven Yue) #3

Hi, Sri

I tried to change logging level to TRACE in logging.yml file, but still it
just did not create any logs.

I noticed it only read settings inside "/etc/default/elasticsearch", but
never read settings inside "/etc/elasticsearch/elasticsearch.yml", even
though I have 'CONF_FILE=/etc/elasticsearch/elasticsearch.yml'

So if I set 'LOG_DIR=/home/log/elasticsearch', 'DATA_DIR=/home/data/elasticsearch'
inside "/etc/default/elasticsearch", it will at least create those
directories accordingly when starting, but it will not if I set those
variables inside 'elasticsearch.yml' file using path.data, path.logs.

This also makes me believe the logging.yml file is never read.

On Friday, June 27, 2014 11:38:06 AM UTC-4, sri wrote:

Hi Steven,

Change the logging level to TRACE or DEBUG and check the logs , you should
be able to identify the problem.
Hope that helps

Thanks and Regards
Sri

On Friday, June 27, 2014 10:51:36 AM UTC-4, Steven Yue wrote:

Hi, everyone

I'm trying to install elasticsearch 1.2.1 on a ubuntu 14.04 server.

I used the dpkg -i to install

When I run 'sudo /etc/init.d/elasticsearch start', it says: "Starting
Elasticsearch Server [ OK ]", but actually no process is ever started, and
I couldn't find any errors or any logs in the log folder(
/var/log/elasticsearch).

I tried to run 'sudo /usr/share/elasticsearch/bin/elasticsearch start'
directly, and it is able to start and i can get response when using curl,
although it gives me the following warnning:

log4j:WARN No appenders could be found for logger (node).
log4j:WARN Please initialize the log4j system properly.
log4j:WARN See http://logging.apache.org/log4j/1.2/faq.html#noconfig for
more info.

I tried to edit settings in /etc/default/elasticsearch, uncommented the
following lines:

ES_HEAP_SIZE=2g

MAX_LOCKED_MEMORY=unlimited

Elasticsearch log directory

LOG_DIR=/var/log/elasticsearch

Elasticsearch data directory

DATA_DIR=/home/data/elasticsearch

Elasticsearch work directory

WORK_DIR=/home/tmp/elasticsearch

Elasticsearch configuration directory

CONF_DIR=/etc/elasticsearch

Elasticsearch configuration file (elasticsearch.yml)

CONF_FILE=/etc/elasticsearch/elasticsearch.yml

When restart the service, I did see it created the folder, but still
failed to run, even thought it says 'OK'

Could anyone help me to figure out why and how to run it? Thanks

--
You received this message because you are subscribed to the Google Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an email to elasticsearch+unsubscribe@googlegroups.com.
To view this discussion on the web visit https://groups.google.com/d/msgid/elasticsearch/b20ba5fe-0ffa-40fc-86ed-9a2c9013df92%40googlegroups.com.
For more options, visit https://groups.google.com/d/optout.


(sri) #4

Hi Steven,

your /home/data/elasticsearch and /home/log/elasticsearch folder should be
owned by elasticsearch and should have write permissions.
Could you confirm that for me.. pls..

Thanks and Regards
Sri

On Friday, June 27, 2014 3:32:10 PM UTC-4, Steven Yue wrote:

Hi, Sri

I tried to change logging level to TRACE in logging.yml file, but still it
just did not create any logs.

I noticed it only read settings inside "/etc/default/elasticsearch", but
never read settings inside "/etc/elasticsearch/elasticsearch.yml", even
though I have 'CONF_FILE=/etc/elasticsearch/elasticsearch.yml'

So if I set 'LOG_DIR=/home/log/elasticsearch', 'DATA_DIR=/home/data/elasticsearch'
inside "/etc/default/elasticsearch", it will at least create those
directories accordingly when starting, but it will not if I set those
variables inside 'elasticsearch.yml' file using path.data, path.logs.

This also makes me believe the logging.yml file is never read.

On Friday, June 27, 2014 11:38:06 AM UTC-4, sri wrote:

Hi Steven,

Change the logging level to TRACE or DEBUG and check the logs , you
should be able to identify the problem.
Hope that helps

Thanks and Regards
Sri

On Friday, June 27, 2014 10:51:36 AM UTC-4, Steven Yue wrote:

Hi, everyone

I'm trying to install elasticsearch 1.2.1 on a ubuntu 14.04 server.

I used the dpkg -i to install

When I run 'sudo /etc/init.d/elasticsearch start', it says: "Starting
Elasticsearch Server [ OK ]", but actually no process is ever started, and
I couldn't find any errors or any logs in the log folder(
/var/log/elasticsearch).

I tried to run 'sudo /usr/share/elasticsearch/bin/elasticsearch start'
directly, and it is able to start and i can get response when using curl,
although it gives me the following warnning:

log4j:WARN No appenders could be found for logger (node).
log4j:WARN Please initialize the log4j system properly.
log4j:WARN See http://logging.apache.org/log4j/1.2/faq.html#noconfig
for more info.

I tried to edit settings in /etc/default/elasticsearch, uncommented the
following lines:

ES_HEAP_SIZE=2g

MAX_LOCKED_MEMORY=unlimited

Elasticsearch log directory

LOG_DIR=/var/log/elasticsearch

Elasticsearch data directory

DATA_DIR=/home/data/elasticsearch

Elasticsearch work directory

WORK_DIR=/home/tmp/elasticsearch

Elasticsearch configuration directory

CONF_DIR=/etc/elasticsearch

Elasticsearch configuration file (elasticsearch.yml)

CONF_FILE=/etc/elasticsearch/elasticsearch.yml

When restart the service, I did see it created the folder, but still
failed to run, even thought it says 'OK'

Could anyone help me to figure out why and how to run it? Thanks

--
You received this message because you are subscribed to the Google Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an email to elasticsearch+unsubscribe@googlegroups.com.
To view this discussion on the web visit https://groups.google.com/d/msgid/elasticsearch/c2d6da45-aa36-4294-81a1-52ca908e5c2e%40googlegroups.com.
For more options, visit https://groups.google.com/d/optout.


(Steven Yue) #5

Hi, sri

Thanks for your reply. Yes, they all have permissions

'ls -lah' shows this:

drwxr-xr-x 2 elasticsearch elasticsearch

On Friday, June 27, 2014 3:42:51 PM UTC-4, sri wrote:

Hi Steven,

your /home/data/elasticsearch and /home/log/elasticsearch folder should be
owned by elasticsearch and should have write permissions.
Could you confirm that for me.. pls..

Thanks and Regards
Sri

On Friday, June 27, 2014 3:32:10 PM UTC-4, Steven Yue wrote:

Hi, Sri

I tried to change logging level to TRACE in logging.yml file, but still
it just did not create any logs.

I noticed it only read settings inside "/etc/default/elasticsearch", but
never read settings inside "/etc/elasticsearch/elasticsearch.yml", even
though I have 'CONF_FILE=/etc/elasticsearch/elasticsearch.yml'

So if I set 'LOG_DIR=/home/log/elasticsearch', 'DATA_DIR=/home/data/elasticsearch'
inside "/etc/default/elasticsearch", it will at least create those
directories accordingly when starting, but it will not if I set those
variables inside 'elasticsearch.yml' file using path.data, path.logs.

This also makes me believe the logging.yml file is never read.

On Friday, June 27, 2014 11:38:06 AM UTC-4, sri wrote:

Hi Steven,

Change the logging level to TRACE or DEBUG and check the logs , you
should be able to identify the problem.
Hope that helps

Thanks and Regards
Sri

On Friday, June 27, 2014 10:51:36 AM UTC-4, Steven Yue wrote:

Hi, everyone

I'm trying to install elasticsearch 1.2.1 on a ubuntu 14.04 server.

I used the dpkg -i to install

When I run 'sudo /etc/init.d/elasticsearch start', it says: "Starting
Elasticsearch Server [ OK ]", but actually no process is ever started, and
I couldn't find any errors or any logs in the log folder(
/var/log/elasticsearch).

I tried to run 'sudo /usr/share/elasticsearch/bin/elasticsearch start'
directly, and it is able to start and i can get response when using curl,
although it gives me the following warnning:

log4j:WARN No appenders could be found for logger (node).
log4j:WARN Please initialize the log4j system properly.
log4j:WARN See http://logging.apache.org/log4j/1.2/faq.html#noconfig
for more info.

I tried to edit settings in /etc/default/elasticsearch, uncommented
the following lines:

ES_HEAP_SIZE=2g

MAX_LOCKED_MEMORY=unlimited

Elasticsearch log directory

LOG_DIR=/var/log/elasticsearch

Elasticsearch data directory

DATA_DIR=/home/data/elasticsearch

Elasticsearch work directory

WORK_DIR=/home/tmp/elasticsearch

Elasticsearch configuration directory

CONF_DIR=/etc/elasticsearch

Elasticsearch configuration file (elasticsearch.yml)

CONF_FILE=/etc/elasticsearch/elasticsearch.yml

When restart the service, I did see it created the folder, but still
failed to run, even thought it says 'OK'

Could anyone help me to figure out why and how to run it? Thanks

--
You received this message because you are subscribed to the Google Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an email to elasticsearch+unsubscribe@googlegroups.com.
To view this discussion on the web visit https://groups.google.com/d/msgid/elasticsearch/b7be4308-634e-4833-a408-46bac2b7ace8%40googlegroups.com.
For more options, visit https://groups.google.com/d/optout.


(Alexander Reelsen) #6

Hey,

if you put something like 'set -x' into /etc/init.d/elasticsearch (not in
the first line, but somewhere below that), you can see, how elasticsearch
is started (and which parameters from the default file are used). Can you
paste that output here, so we can debug further? Cant say if it is a
configuration issue or a packaging bug now, but would love to.. and fix if
needed :slight_smile:

--Alex

On Fri, Jun 27, 2014 at 9:57 PM, Steven Yue jincheker@gmail.com wrote:

Hi, sri

Thanks for your reply. Yes, they all have permissions

'ls -lah' shows this:

drwxr-xr-x 2 elasticsearch elasticsearch

On Friday, June 27, 2014 3:42:51 PM UTC-4, sri wrote:

Hi Steven,

your /home/data/elasticsearch and /home/log/elasticsearch folder should
be owned by elasticsearch and should have write permissions.
Could you confirm that for me.. pls..

Thanks and Regards
Sri

On Friday, June 27, 2014 3:32:10 PM UTC-4, Steven Yue wrote:

Hi, Sri

I tried to change logging level to TRACE in logging.yml file, but still
it just did not create any logs.

I noticed it only read settings inside "/etc/default/elasticsearch",
but never read settings inside "/etc/elasticsearch/elasticsearch.yml",
even though I have 'CONF_FILE=/etc/elasticsearch/elasticsearch.yml'

So if I set 'LOG_DIR=/home/log/elasticsearch', 'DATA_DIR=/home/data/elasticsearch'
inside "/etc/default/elasticsearch", it will at least create those
directories accordingly when starting, but it will not if I set those
variables inside 'elasticsearch.yml' file using path.data, path.logs.

This also makes me believe the logging.yml file is never read.

On Friday, June 27, 2014 11:38:06 AM UTC-4, sri wrote:

Hi Steven,

Change the logging level to TRACE or DEBUG and check the logs , you
should be able to identify the problem.
Hope that helps

Thanks and Regards
Sri

On Friday, June 27, 2014 10:51:36 AM UTC-4, Steven Yue wrote:

Hi, everyone

I'm trying to install elasticsearch 1.2.1 on a ubuntu 14.04 server.

I used the dpkg -i to install

When I run 'sudo /etc/init.d/elasticsearch start', it says: "Starting
Elasticsearch Server [ OK ]", but actually no process is ever started, and
I couldn't find any errors or any logs in the log folder(
/var/log/elasticsearch).

I tried to run 'sudo /usr/share/elasticsearch/bin/elasticsearch start'
directly, and it is able to start and i can get response when using curl,
although it gives me the following warnning:

log4j:WARN No appenders could be found for logger (node).
log4j:WARN Please initialize the log4j system properly.
log4j:WARN See http://logging.apache.org/log4j/1.2/faq.html#noconfig
for more info.

I tried to edit settings in /etc/default/elasticsearch, uncommented
the following lines:

ES_HEAP_SIZE=2g

MAX_LOCKED_MEMORY=unlimited

Elasticsearch log directory

LOG_DIR=/var/log/elasticsearch

Elasticsearch data directory

DATA_DIR=/home/data/elasticsearch

Elasticsearch work directory

WORK_DIR=/home/tmp/elasticsearch

Elasticsearch configuration directory

CONF_DIR=/etc/elasticsearch

Elasticsearch configuration file (elasticsearch.yml)

CONF_FILE=/etc/elasticsearch/elasticsearch.yml

When restart the service, I did see it created the folder, but still
failed to run, even thought it says 'OK'

Could anyone help me to figure out why and how to run it? Thanks

--
You received this message because you are subscribed to the Google Groups
"elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an
email to elasticsearch+unsubscribe@googlegroups.com.
To view this discussion on the web visit
https://groups.google.com/d/msgid/elasticsearch/b7be4308-634e-4833-a408-46bac2b7ace8%40googlegroups.com
https://groups.google.com/d/msgid/elasticsearch/b7be4308-634e-4833-a408-46bac2b7ace8%40googlegroups.com?utm_medium=email&utm_source=footer
.

For more options, visit https://groups.google.com/d/optout.

--
You received this message because you are subscribed to the Google Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an email to elasticsearch+unsubscribe@googlegroups.com.
To view this discussion on the web visit https://groups.google.com/d/msgid/elasticsearch/CAGCwEM-R5VCutOPyWWhKdmxAakuX3O09JJGra5moTCgROwMmXg%40mail.gmail.com.
For more options, visit https://groups.google.com/d/optout.


(Steven Yue) #7

Hi, Alex

Below is the output:

++ id -u

  • '[' 0 -ne 0 ']'

  • . /lib/lsb/init-functions

+++ run-parts --lsbsysinit --list /lib/lsb/init-functions.d

++ for hook in '$(run-parts --lsbsysinit --list /lib/lsb/init-functions.d
2>/dev/null)'

++ '[' -r /lib/lsb/init-functions.d/20-left-info-blocks ']'

++ . /lib/lsb/init-functions.d/20-left-info-blocks

++ for hook in '$(run-parts --lsbsysinit --list /lib/lsb/init-functions.d
2>/dev/null)'

++ '[' -r /lib/lsb/init-functions.d/50-ubuntu-logging ']'

++ . /lib/lsb/init-functions.d/50-ubuntu-logging

+++ LOG_DAEMON_MSG=

++ FANCYTTY=

++ '[' -e /etc/lsb-base-logging.sh ']'

++ true

  • '[' -r /etc/default/rcS ']'

  • . /etc/default/rcS

++ UTC=yes

++ FSCKFIX=no

  • ES_USER=elasticsearch

  • ES_GROUP=elasticsearch

  • JDK_DIRS='/usr/lib/jvm/java-7-oracle /usr/lib/jvm/java-7-openjdk
    /usr/lib/jvm/java-7-openjdk-amd64/ /usr/lib/jvm/java-7-openjdk-armhf
    /usr/lib/jvm/java-7-openjdk-i386/ /usr/lib/jvm/java-6-sun
    /usr/lib/jvm/java-6-openjdk /usr/lib/jvm/java-6-openjdk-amd64
    /usr/lib/jvm/java-6-openjdk-armhf /usr/lib/jvm/java-6-openjdk-i386
    /usr/lib/jvm/default-java'

  • for jdir in '$JDK_DIRS'

  • '[' -r /usr/lib/jvm/java-7-oracle/bin/java -a -z '' ']'

  • for jdir in '$JDK_DIRS'

  • '[' -r /usr/lib/jvm/java-7-openjdk/bin/java -a -z '' ']'

  • for jdir in '$JDK_DIRS'

  • '[' -r /usr/lib/jvm/java-7-openjdk-amd64//bin/java -a -z '' ']'

  • for jdir in '$JDK_DIRS'

  • '[' -r /usr/lib/jvm/java-7-openjdk-armhf/bin/java -a -z '' ']'

  • for jdir in '$JDK_DIRS'

  • '[' -r /usr/lib/jvm/java-7-openjdk-i386//bin/java -a -z '' ']'

  • for jdir in '$JDK_DIRS'

  • '[' -r /usr/lib/jvm/java-6-sun/bin/java -a -z '' ']'

  • for jdir in '$JDK_DIRS'

  • '[' -r /usr/lib/jvm/java-6-openjdk/bin/java -a -z '' ']'

  • for jdir in '$JDK_DIRS'

  • '[' -r /usr/lib/jvm/java-6-openjdk-amd64/bin/java -a -z '' ']'

  • JAVA_HOME=/usr/lib/jvm/java-6-openjdk-amd64

  • for jdir in '$JDK_DIRS'

  • '[' -r /usr/lib/jvm/java-6-openjdk-armhf/bin/java -a -z
    /usr/lib/jvm/java-6-openjdk-amd64 ']'

  • for jdir in '$JDK_DIRS'

  • '[' -r /usr/lib/jvm/java-6-openjdk-i386/bin/java -a -z
    /usr/lib/jvm/java-6-openjdk-amd64 ']'

  • for jdir in '$JDK_DIRS'

  • '[' -r /usr/lib/jvm/default-java/bin/java -a -z
    /usr/lib/jvm/java-6-openjdk-amd64 ']'

  • export JAVA_HOME

  • ES_HOME=/usr/share/elasticsearch

  • MAX_OPEN_FILES=65535

  • LOG_DIR=/var/log/elasticsearch

  • DATA_DIR=/var/lib/elasticsearch

  • WORK_DIR=/tmp/elasticsearch

  • CONF_DIR=/etc/elasticsearch

  • CONF_FILE=/etc/elasticsearch/elasticsearch.yml

  • MAX_MAP_COUNT=262144

  • '[' -f /etc/default/elasticsearch ']'

  • . /etc/default/elasticsearch

++ ES_USER=elasticsearch

++ ES_GROUP=elasticsearch

++ ES_HEAP_SIZE=2g

++ MAX_LOCKED_MEMORY=unlimited

++ LOG_DIR=/home/log/elasticsearch

++ DATA_DIR=/home/data/elasticsearch

++ WORK_DIR=/home/tmp/elasticsearch

++ CONF_DIR=/etc/elasticsearch

++ CONF_FILE=/etc/elasticsearch/elasticsearch.yml

  • PID_FILE=/var/run/elasticsearch.pid

  • DAEMON=/usr/share/elasticsearch/bin/elasticsearch

  • DAEMON_OPTS='-d -p /var/run/elasticsearch.pid
    -Des.default.config=/etc/elasticsearch/elasticsearch.yml
    -Des.default.path.home=/usr/share/elasticsearch
    -Des.default.path.logs=/home/log/elasticsearch
    -Des.default.path.data=/home/data/elasticsearch
    -Des.default.path.work=/home/tmp/elasticsearch
    -Des.default.path.conf=/etc/elasticsearch'

  • export ES_HEAP_SIZE

  • export ES_HEAP_NEWSIZE

  • export ES_DIRECT_SIZE

  • export ES_JAVA_OPTS

  • test -x /usr/share/elasticsearch/bin/elasticsearch

  • case "$1" in

  • checkJava

  • '[' -x /usr/lib/jvm/java-6-openjdk-amd64/bin/java ']'

  • JAVA=/usr/lib/jvm/java-6-openjdk-amd64/bin/java

  • '[' '!' -x /usr/lib/jvm/java-6-openjdk-amd64/bin/java ']'

  • '[' -n unlimited -a -z 2g ']'

  • log_daemon_msg 'Starting Elasticsearch Server'

  • '[' -z 'Starting Elasticsearch Server' ']'

  • log_use_fancy_output

  • TPUT=/usr/bin/tput

  • EXPR=/usr/bin/expr

  • '[' -t 1 ']'

  • '[' xxterm-256color '!=' x ']'

  • '[' xxterm-256color '!=' xdumb ']'

  • '[' -x /usr/bin/tput ']'

  • '[' -x /usr/bin/expr ']'

  • /usr/bin/tput hpa 60

  • /usr/bin/tput setaf 1

  • '[' -z ']'

  • FANCYTTY=1

  • case "$FANCYTTY" in

  • true

  • /usr/bin/tput xenl

++ /usr/bin/tput cols

  • COLS=119

  • '[' 119 ']'

  • '[' 119 -gt 6 ']'

++ /usr/bin/expr 119 - 7

  • COL=112

  • log_use_plymouth

  • '[' n = y ']'

  • plymouth --ping

  • printf ' * Starting Elasticsearch Server '

  • Starting Elasticsearch Server ++ /usr/bin/expr 119 - 1
  • /usr/bin/tput hpa 118

                                        + printf ' '
    

++ pidofproc -p /var/run/elasticsearch.pid elasticsearch

++ local pidfile base status specified pid OPTIND

++ pidfile=

++ specified=

++ OPTIND=1

++ getopts p: opt

++ case "$opt" in

++ pidfile=/var/run/elasticsearch.pid

++ specified=specified

++ getopts p: opt

++ shift 2

++ '[' 1 -ne 1 ']'

++ base=elasticsearch

++ '[' '!' specified ']'

++ '[' -n /var/run/elasticsearch.pid -a -r /var/run/elasticsearch.pid ']'

++ read pid

++ '[' -n '' ']'

++ '[' -n specified ']'

++ '[' -e /var/run/elasticsearch.pid -a '!' -r /var/run/elasticsearch.pid
']'

++ return 3

  • pid=

  • '[' -n '' ']'

  • mkdir -p /home/log/elasticsearch /home/data/elasticsearch
    /home/tmp/elasticsearch

  • chown elasticsearch:elasticsearch /home/log/elasticsearch
    /home/data/elasticsearch /home/tmp/elasticsearch

  • touch /var/run/elasticsearch.pid

  • chown elasticsearch:elasticsearch /var/run/elasticsearch.pid

  • '[' -n 65535 ']'

  • ulimit -n 65535

  • '[' -n unlimited ']'

  • ulimit -l unlimited

  • '[' -n 262144 ']'

  • sysctl -q -w vm.max_map_count=262144

  • start-stop-daemon --start -b --user elasticsearch -c elasticsearch
    --pidfile /var/run/elasticsearch.pid --exec
    /usr/share/elasticsearch/bin/elasticsearch -- -d -p
    /var/run/elasticsearch.pid
    -Des.default.config=/etc/elasticsearch/elasticsearch.yml
    -Des.default.path.home=/usr/share/elasticsearch
    -Des.default.path.logs=/home/log/elasticsearch
    -Des.default.path.data=/home/data/elasticsearch
    -Des.default.path.work=/home/tmp/elasticsearch
    -Des.default.path.conf=/etc/elasticsearch

  • log_end_msg 0

  • '[' -z 0 ']'

  • '[' 112 ']'

  • '[' -x /usr/bin/tput ']'

  • log_use_plymouth

  • '[' n = y ']'

  • plymouth --ping

  • printf '\r'

  • /usr/bin/tput hpa 112

                                  + '[' 0 -eq 0 ']'
    
  • echo '[ OK ]'

[ OK ]

  • return 0

  • exit 0

On Monday, June 30, 2014 3:52:49 AM UTC-4, Alexander Reelsen wrote:

Hey,

if you put something like 'set -x' into /etc/init.d/elasticsearch (not in
the first line, but somewhere below that), you can see, how elasticsearch
is started (and which parameters from the default file are used). Can you
paste that output here, so we can debug further? Cant say if it is a
configuration issue or a packaging bug now, but would love to.. and fix if
needed :slight_smile:

--Alex

On Fri, Jun 27, 2014 at 9:57 PM, Steven Yue <jinc...@gmail.com
<javascript:>> wrote:

Hi, sri

Thanks for your reply. Yes, they all have permissions

'ls -lah' shows this:

drwxr-xr-x 2 elasticsearch elasticsearch

On Friday, June 27, 2014 3:42:51 PM UTC-4, sri wrote:

Hi Steven,

your /home/data/elasticsearch and /home/log/elasticsearch folder should
be owned by elasticsearch and should have write permissions.
Could you confirm that for me.. pls..

Thanks and Regards
Sri

On Friday, June 27, 2014 3:32:10 PM UTC-4, Steven Yue wrote:

Hi, Sri

I tried to change logging level to TRACE in logging.yml file, but still
it just did not create any logs.

I noticed it only read settings inside "/etc/default/elasticsearch",
but never read settings inside "/etc/elasticsearch/elasticsearch.yml",
even though I have 'CONF_FILE=/etc/elasticsearch/elasticsearch.yml'

So if I set 'LOG_DIR=/home/log/elasticsearch', 'DATA_DIR=/home/data/elasticsearch'
inside "/etc/default/elasticsearch", it will at least create those
directories accordingly when starting, but it will not if I set those
variables inside 'elasticsearch.yml' file using path.data, path.logs.

This also makes me believe the logging.yml file is never read.

On Friday, June 27, 2014 11:38:06 AM UTC-4, sri wrote:

Hi Steven,

Change the logging level to TRACE or DEBUG and check the logs , you
should be able to identify the problem.
Hope that helps

Thanks and Regards
Sri

On Friday, June 27, 2014 10:51:36 AM UTC-4, Steven Yue wrote:

Hi, everyone

I'm trying to install elasticsearch 1.2.1 on a ubuntu 14.04 server.

I used the dpkg -i to install

When I run 'sudo /etc/init.d/elasticsearch start', it says:
"Starting Elasticsearch Server [ OK ]", but actually no process is ever
started, and I couldn't find any errors or any logs in the log folder(
/var/log/elasticsearch).

I tried to run 'sudo /usr/share/elasticsearch/bin/elasticsearch start'
directly, and it is able to start and i can get response when using curl,
although it gives me the following warnning:

log4j:WARN No appenders could be found for logger (node).
log4j:WARN Please initialize the log4j system properly.
log4j:WARN See http://logging.apache.org/log4j/1.2/faq.html#noconfig
for more info.

I tried to edit settings in /etc/default/elasticsearch, uncommented
the following lines:

ES_HEAP_SIZE=2g

MAX_LOCKED_MEMORY=unlimited

Elasticsearch log directory

LOG_DIR=/var/log/elasticsearch

Elasticsearch data directory

DATA_DIR=/home/data/elasticsearch

Elasticsearch work directory

WORK_DIR=/home/tmp/elasticsearch

Elasticsearch configuration directory

CONF_DIR=/etc/elasticsearch

Elasticsearch configuration file (elasticsearch.yml)

CONF_FILE=/etc/elasticsearch/elasticsearch.yml

When restart the service, I did see it created the folder, but still
failed to run, even thought it says 'OK'

Could anyone help me to figure out why and how to run it? Thanks

--
You received this message because you are subscribed to the Google Groups
"elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an
email to elasticsearc...@googlegroups.com <javascript:>.
To view this discussion on the web visit
https://groups.google.com/d/msgid/elasticsearch/b7be4308-634e-4833-a408-46bac2b7ace8%40googlegroups.com
https://groups.google.com/d/msgid/elasticsearch/b7be4308-634e-4833-a408-46bac2b7ace8%40googlegroups.com?utm_medium=email&utm_source=footer
.

For more options, visit https://groups.google.com/d/optout.

--
You received this message because you are subscribed to the Google Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an email to elasticsearch+unsubscribe@googlegroups.com.
To view this discussion on the web visit https://groups.google.com/d/msgid/elasticsearch/2f2607df-bd67-4350-b94f-a720fbb56a37%40googlegroups.com.
For more options, visit https://groups.google.com/d/optout.


(Mark Walkom) #8

You're on Java 6 by the looks of it, ES won't run on anything less than 7.

Regards,
Mark Walkom

Infrastructure Engineer
Campaign Monitor
email: markw@campaignmonitor.com
web: www.campaignmonitor.com

On 1 July 2014 22:57, Steven Yue jincheker@gmail.com wrote:

Hi, Alex

Below is the output:

++ id -u

  • '[' 0 -ne 0 ']'

  • . /lib/lsb/init-functions

+++ run-parts --lsbsysinit --list /lib/lsb/init-functions.d

++ for hook in '$(run-parts --lsbsysinit --list /lib/lsb/init-functions.d
2>/dev/null)'

++ '[' -r /lib/lsb/init-functions.d/20-left-info-blocks ']'

++ . /lib/lsb/init-functions.d/20-left-info-blocks

++ for hook in '$(run-parts --lsbsysinit --list /lib/lsb/init-functions.d
2>/dev/null)'

++ '[' -r /lib/lsb/init-functions.d/50-ubuntu-logging ']'

++ . /lib/lsb/init-functions.d/50-ubuntu-logging

+++ LOG_DAEMON_MSG=

++ FANCYTTY=

++ '[' -e /etc/lsb-base-logging.sh ']'

++ true

  • '[' -r /etc/default/rcS ']'

  • . /etc/default/rcS

++ UTC=yes

++ FSCKFIX=no

  • ES_USER=elasticsearch

  • ES_GROUP=elasticsearch

  • JDK_DIRS='/usr/lib/jvm/java-7-oracle /usr/lib/jvm/java-7-openjdk
    /usr/lib/jvm/java-7-openjdk-amd64/ /usr/lib/jvm/java-7-openjdk-armhf
    /usr/lib/jvm/java-7-openjdk-i386/ /usr/lib/jvm/java-6-sun
    /usr/lib/jvm/java-6-openjdk /usr/lib/jvm/java-6-openjdk-amd64
    /usr/lib/jvm/java-6-openjdk-armhf /usr/lib/jvm/java-6-openjdk-i386
    /usr/lib/jvm/default-java'

  • for jdir in '$JDK_DIRS'

  • '[' -r /usr/lib/jvm/java-7-oracle/bin/java -a -z '' ']'

  • for jdir in '$JDK_DIRS'

  • '[' -r /usr/lib/jvm/java-7-openjdk/bin/java -a -z '' ']'

  • for jdir in '$JDK_DIRS'

  • '[' -r /usr/lib/jvm/java-7-openjdk-amd64//bin/java -a -z '' ']'

  • for jdir in '$JDK_DIRS'

  • '[' -r /usr/lib/jvm/java-7-openjdk-armhf/bin/java -a -z '' ']'

  • for jdir in '$JDK_DIRS'

  • '[' -r /usr/lib/jvm/java-7-openjdk-i386//bin/java -a -z '' ']'

  • for jdir in '$JDK_DIRS'

  • '[' -r /usr/lib/jvm/java-6-sun/bin/java -a -z '' ']'

  • for jdir in '$JDK_DIRS'

  • '[' -r /usr/lib/jvm/java-6-openjdk/bin/java -a -z '' ']'

  • for jdir in '$JDK_DIRS'

  • '[' -r /usr/lib/jvm/java-6-openjdk-amd64/bin/java -a -z '' ']'

  • JAVA_HOME=/usr/lib/jvm/java-6-openjdk-amd64

  • for jdir in '$JDK_DIRS'

  • '[' -r /usr/lib/jvm/java-6-openjdk-armhf/bin/java -a -z
    /usr/lib/jvm/java-6-openjdk-amd64 ']'

  • for jdir in '$JDK_DIRS'

  • '[' -r /usr/lib/jvm/java-6-openjdk-i386/bin/java -a -z
    /usr/lib/jvm/java-6-openjdk-amd64 ']'

  • for jdir in '$JDK_DIRS'

  • '[' -r /usr/lib/jvm/default-java/bin/java -a -z
    /usr/lib/jvm/java-6-openjdk-amd64 ']'

  • export JAVA_HOME

  • ES_HOME=/usr/share/elasticsearch

  • MAX_OPEN_FILES=65535

  • LOG_DIR=/var/log/elasticsearch

  • DATA_DIR=/var/lib/elasticsearch

  • WORK_DIR=/tmp/elasticsearch

  • CONF_DIR=/etc/elasticsearch

  • CONF_FILE=/etc/elasticsearch/elasticsearch.yml

  • MAX_MAP_COUNT=262144

  • '[' -f /etc/default/elasticsearch ']'

  • . /etc/default/elasticsearch

++ ES_USER=elasticsearch

++ ES_GROUP=elasticsearch

++ ES_HEAP_SIZE=2g

++ MAX_LOCKED_MEMORY=unlimited

++ LOG_DIR=/home/log/elasticsearch

++ DATA_DIR=/home/data/elasticsearch

++ WORK_DIR=/home/tmp/elasticsearch

++ CONF_DIR=/etc/elasticsearch

++ CONF_FILE=/etc/elasticsearch/elasticsearch.yml

  • PID_FILE=/var/run/elasticsearch.pid

  • DAEMON=/usr/share/elasticsearch/bin/elasticsearch

  • DAEMON_OPTS='-d -p /var/run/elasticsearch.pid
    -Des.default.config=/etc/elasticsearch/elasticsearch.yml
    -Des.default.path.home=/usr/share/elasticsearch
    -Des.default.path.logs=/home/log/elasticsearch
    -Des.default.path.data=/home/data/elasticsearch
    -Des.default.path.work=/home/tmp/elasticsearch
    -Des.default.path.conf=/etc/elasticsearch'

  • export ES_HEAP_SIZE

  • export ES_HEAP_NEWSIZE

  • export ES_DIRECT_SIZE

  • export ES_JAVA_OPTS

  • test -x /usr/share/elasticsearch/bin/elasticsearch

  • case "$1" in

  • checkJava

  • '[' -x /usr/lib/jvm/java-6-openjdk-amd64/bin/java ']'

  • JAVA=/usr/lib/jvm/java-6-openjdk-amd64/bin/java

  • '[' '!' -x /usr/lib/jvm/java-6-openjdk-amd64/bin/java ']'

  • '[' -n unlimited -a -z 2g ']'

  • log_daemon_msg 'Starting Elasticsearch Server'

  • '[' -z 'Starting Elasticsearch Server' ']'

  • log_use_fancy_output

  • TPUT=/usr/bin/tput

  • EXPR=/usr/bin/expr

  • '[' -t 1 ']'

  • '[' xxterm-256color '!=' x ']'

  • '[' xxterm-256color '!=' xdumb ']'

  • '[' -x /usr/bin/tput ']'

  • '[' -x /usr/bin/expr ']'

  • /usr/bin/tput hpa 60

  • /usr/bin/tput setaf 1

  • '[' -z ']'

  • FANCYTTY=1

  • case "$FANCYTTY" in

  • true

  • /usr/bin/tput xenl

++ /usr/bin/tput cols

  • COLS=119

  • '[' 119 ']'

  • '[' 119 -gt 6 ']'

++ /usr/bin/expr 119 - 7

  • COL=112

  • log_use_plymouth

  • '[' n = y ']'

  • plymouth --ping

  • printf ' * Starting Elasticsearch Server '

  • Starting Elasticsearch Server ++ /usr/bin/expr 119 - 1
  • /usr/bin/tput hpa 118

                                          + printf ' '
    

++ pidofproc -p /var/run/elasticsearch.pid elasticsearch

++ local pidfile base status specified pid OPTIND

++ pidfile=

++ specified=

++ OPTIND=1

++ getopts p: opt

++ case "$opt" in

++ pidfile=/var/run/elasticsearch.pid

++ specified=specified

++ getopts p: opt

++ shift 2

++ '[' 1 -ne 1 ']'

++ base=elasticsearch

++ '[' '!' specified ']'

++ '[' -n /var/run/elasticsearch.pid -a -r /var/run/elasticsearch.pid ']'

++ read pid

++ '[' -n '' ']'

++ '[' -n specified ']'

++ '[' -e /var/run/elasticsearch.pid -a '!' -r /var/run/elasticsearch.pid
']'

++ return 3

  • pid=

  • '[' -n '' ']'

  • mkdir -p /home/log/elasticsearch /home/data/elasticsearch
    /home/tmp/elasticsearch

  • chown elasticsearch:elasticsearch /home/log/elasticsearch
    /home/data/elasticsearch /home/tmp/elasticsearch

  • touch /var/run/elasticsearch.pid

  • chown elasticsearch:elasticsearch /var/run/elasticsearch.pid

  • '[' -n 65535 ']'

  • ulimit -n 65535

  • '[' -n unlimited ']'

  • ulimit -l unlimited

  • '[' -n 262144 ']'

  • sysctl -q -w vm.max_map_count=262144

  • start-stop-daemon --start -b --user elasticsearch -c elasticsearch
    --pidfile /var/run/elasticsearch.pid --exec
    /usr/share/elasticsearch/bin/elasticsearch -- -d -p
    /var/run/elasticsearch.pid
    -Des.default.config=/etc/elasticsearch/elasticsearch.yml
    -Des.default.path.home=/usr/share/elasticsearch
    -Des.default.path.logs=/home/log/elasticsearch
    -Des.default.path.data=/home/data/elasticsearch
    -Des.default.path.work=/home/tmp/elasticsearch
    -Des.default.path.conf=/etc/elasticsearch

  • log_end_msg 0

  • '[' -z 0 ']'

  • '[' 112 ']'

  • '[' -x /usr/bin/tput ']'

  • log_use_plymouth

  • '[' n = y ']'

  • plymouth --ping

  • printf '\r'

  • /usr/bin/tput hpa 112

                                    + '[' 0 -eq 0 ']'
    
  • echo '[ OK ]'

[ OK ]

  • return 0

  • exit 0

On Monday, June 30, 2014 3:52:49 AM UTC-4, Alexander Reelsen wrote:

Hey,

if you put something like 'set -x' into /etc/init.d/elasticsearch (not in
the first line, but somewhere below that), you can see, how elasticsearch
is started (and which parameters from the default file are used). Can you
paste that output here, so we can debug further? Cant say if it is a
configuration issue or a packaging bug now, but would love to.. and fix if
needed :slight_smile:

--Alex

On Fri, Jun 27, 2014 at 9:57 PM, Steven Yue jinc...@gmail.com wrote:

Hi, sri

Thanks for your reply. Yes, they all have permissions

'ls -lah' shows this:

drwxr-xr-x 2 elasticsearch elasticsearch

On Friday, June 27, 2014 3:42:51 PM UTC-4, sri wrote:

Hi Steven,

your /home/data/elasticsearch and /home/log/elasticsearch folder should
be owned by elasticsearch and should have write permissions.
Could you confirm that for me.. pls..

Thanks and Regards
Sri

On Friday, June 27, 2014 3:32:10 PM UTC-4, Steven Yue wrote:

Hi, Sri

I tried to change logging level to TRACE in logging.yml file, but
still it just did not create any logs.

I noticed it only read settings inside "/etc/default/elasticsearch",
but never read settings inside "/etc/elasticsearch/elasticsearch.yml",
even though I have 'CONF_FILE=/etc/elasticsearch/elasticsearch.yml'

So if I set 'LOG_DIR=/home/log/elasticsearch', 'DATA_DIR=/home/data/
elasticsearch' inside "/etc/default/elasticsearch", it will at least
create those directories accordingly when starting, but it will not if I
set those variables inside 'elasticsearch.yml' file using path.data,
path.logs.

This also makes me believe the logging.yml file is never read.

On Friday, June 27, 2014 11:38:06 AM UTC-4, sri wrote:

Hi Steven,

Change the logging level to TRACE or DEBUG and check the logs , you
should be able to identify the problem.
Hope that helps

Thanks and Regards
Sri

On Friday, June 27, 2014 10:51:36 AM UTC-4, Steven Yue wrote:

Hi, everyone

I'm trying to install elasticsearch 1.2.1 on a ubuntu 14.04 server.

I used the dpkg -i to install

When I run 'sudo /etc/init.d/elasticsearch start', it says:
"Starting Elasticsearch Server [ OK ]", but actually no process is ever
started, and I couldn't find any errors or any logs in the log folder(
/var/log/elasticsearch).

I tried to run 'sudo /usr/share/elasticsearch/bin/elasticsearch
start' directly, and it is able to start and i can get response
when using curl, although it gives me the following warnning:

log4j:WARN No appenders could be found for logger (node).
log4j:WARN Please initialize the log4j system properly.
log4j:WARN See http://logging.apache.org/log4j/1.2/faq.html#noconfig
for more info.

I tried to edit settings in /etc/default/elasticsearch, uncommented
the following lines:

ES_HEAP_SIZE=2g

MAX_LOCKED_MEMORY=unlimited

Elasticsearch log directory

LOG_DIR=/var/log/elasticsearch

Elasticsearch data directory

DATA_DIR=/home/data/elasticsearch

Elasticsearch work directory

WORK_DIR=/home/tmp/elasticsearch

Elasticsearch configuration directory

CONF_DIR=/etc/elasticsearch

Elasticsearch configuration file (elasticsearch.yml)

CONF_FILE=/etc/elasticsearch/elasticsearch.yml

When restart the service, I did see it created the folder, but still
failed to run, even thought it says 'OK'

Could anyone help me to figure out why and how to run it? Thanks

--
You received this message because you are subscribed to the Google
Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send
an email to elasticsearc...@googlegroups.com.
To view this discussion on the web visit https://groups.google.com/d/
msgid/elasticsearch/b7be4308-634e-4833-a408-46bac2b7ace8%
40googlegroups.com
https://groups.google.com/d/msgid/elasticsearch/b7be4308-634e-4833-a408-46bac2b7ace8%40googlegroups.com?utm_medium=email&utm_source=footer
.

For more options, visit https://groups.google.com/d/optout.

--
You received this message because you are subscribed to the Google Groups
"elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an
email to elasticsearch+unsubscribe@googlegroups.com.
To view this discussion on the web visit
https://groups.google.com/d/msgid/elasticsearch/2f2607df-bd67-4350-b94f-a720fbb56a37%40googlegroups.com
https://groups.google.com/d/msgid/elasticsearch/2f2607df-bd67-4350-b94f-a720fbb56a37%40googlegroups.com?utm_medium=email&utm_source=footer
.
For more options, visit https://groups.google.com/d/optout.

--
You received this message because you are subscribed to the Google Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an email to elasticsearch+unsubscribe@googlegroups.com.
To view this discussion on the web visit https://groups.google.com/d/msgid/elasticsearch/CAEM624ZVqi5gWzM1Y1czJmyaUkEcS_h%2BEsLT4ntM%2BuzyqZveuQ%40mail.gmail.com.
For more options, visit https://groups.google.com/d/optout.


(Steven Yue) #9

No, I have 7.

Run 'java -version' shows this:

java version "1.7.0_60"

Java(TM) SE Runtime Environment (build 1.7.0_60-b19)

Java HotSpot(TM) 64-Bit Server VM (build 24.60-b09, mixed mode)

On Tuesday, July 1, 2014 11:29:05 PM UTC-4, Mark Walkom wrote:

You're on Java 6 by the looks of it, ES won't run on anything less than 7.

Regards,
Mark Walkom

Infrastructure Engineer
Campaign Monitor
email: ma...@campaignmonitor.com <javascript:>
web: www.campaignmonitor.com

On 1 July 2014 22:57, Steven Yue <jinc...@gmail.com <javascript:>> wrote:

Hi, Alex

Below is the output:

++ id -u

  • '[' 0 -ne 0 ']'

  • . /lib/lsb/init-functions

+++ run-parts --lsbsysinit --list /lib/lsb/init-functions.d

++ for hook in '$(run-parts --lsbsysinit --list /lib/lsb/init-functions.d
2>/dev/null)'

++ '[' -r /lib/lsb/init-functions.d/20-left-info-blocks ']'

++ . /lib/lsb/init-functions.d/20-left-info-blocks

++ for hook in '$(run-parts --lsbsysinit --list /lib/lsb/init-functions.d
2>/dev/null)'

++ '[' -r /lib/lsb/init-functions.d/50-ubuntu-logging ']'

++ . /lib/lsb/init-functions.d/50-ubuntu-logging

+++ LOG_DAEMON_MSG=

++ FANCYTTY=

++ '[' -e /etc/lsb-base-logging.sh ']'

++ true

  • '[' -r /etc/default/rcS ']'

  • . /etc/default/rcS

++ UTC=yes

++ FSCKFIX=no

  • ES_USER=elasticsearch

  • ES_GROUP=elasticsearch

  • JDK_DIRS='/usr/lib/jvm/java-7-oracle /usr/lib/jvm/java-7-openjdk
    /usr/lib/jvm/java-7-openjdk-amd64/ /usr/lib/jvm/java-7-openjdk-armhf
    /usr/lib/jvm/java-7-openjdk-i386/ /usr/lib/jvm/java-6-sun
    /usr/lib/jvm/java-6-openjdk /usr/lib/jvm/java-6-openjdk-amd64
    /usr/lib/jvm/java-6-openjdk-armhf /usr/lib/jvm/java-6-openjdk-i386
    /usr/lib/jvm/default-java'

  • for jdir in '$JDK_DIRS'

  • '[' -r /usr/lib/jvm/java-7-oracle/bin/java -a -z '' ']'

  • for jdir in '$JDK_DIRS'

  • '[' -r /usr/lib/jvm/java-7-openjdk/bin/java -a -z '' ']'

  • for jdir in '$JDK_DIRS'

  • '[' -r /usr/lib/jvm/java-7-openjdk-amd64//bin/java -a -z '' ']'

  • for jdir in '$JDK_DIRS'

  • '[' -r /usr/lib/jvm/java-7-openjdk-armhf/bin/java -a -z '' ']'

  • for jdir in '$JDK_DIRS'

  • '[' -r /usr/lib/jvm/java-7-openjdk-i386//bin/java -a -z '' ']'

  • for jdir in '$JDK_DIRS'

  • '[' -r /usr/lib/jvm/java-6-sun/bin/java -a -z '' ']'

  • for jdir in '$JDK_DIRS'

  • '[' -r /usr/lib/jvm/java-6-openjdk/bin/java -a -z '' ']'

  • for jdir in '$JDK_DIRS'

  • '[' -r /usr/lib/jvm/java-6-openjdk-amd64/bin/java -a -z '' ']'

  • JAVA_HOME=/usr/lib/jvm/java-6-openjdk-amd64

  • for jdir in '$JDK_DIRS'

  • '[' -r /usr/lib/jvm/java-6-openjdk-armhf/bin/java -a -z
    /usr/lib/jvm/java-6-openjdk-amd64 ']'

  • for jdir in '$JDK_DIRS'

  • '[' -r /usr/lib/jvm/java-6-openjdk-i386/bin/java -a -z
    /usr/lib/jvm/java-6-openjdk-amd64 ']'

  • for jdir in '$JDK_DIRS'

  • '[' -r /usr/lib/jvm/default-java/bin/java -a -z
    /usr/lib/jvm/java-6-openjdk-amd64 ']'

  • export JAVA_HOME

  • ES_HOME=/usr/share/elasticsearch

  • MAX_OPEN_FILES=65535

  • LOG_DIR=/var/log/elasticsearch

  • DATA_DIR=/var/lib/elasticsearch

  • WORK_DIR=/tmp/elasticsearch

  • CONF_DIR=/etc/elasticsearch

  • CONF_FILE=/etc/elasticsearch/elasticsearch.yml

  • MAX_MAP_COUNT=262144

  • '[' -f /etc/default/elasticsearch ']'

  • . /etc/default/elasticsearch

++ ES_USER=elasticsearch

++ ES_GROUP=elasticsearch

++ ES_HEAP_SIZE=2g

++ MAX_LOCKED_MEMORY=unlimited

++ LOG_DIR=/home/log/elasticsearch

++ DATA_DIR=/home/data/elasticsearch

++ WORK_DIR=/home/tmp/elasticsearch

++ CONF_DIR=/etc/elasticsearch

++ CONF_FILE=/etc/elasticsearch/elasticsearch.yml

  • PID_FILE=/var/run/elasticsearch.pid

  • DAEMON=/usr/share/elasticsearch/bin/elasticsearch

  • DAEMON_OPTS='-d -p /var/run/elasticsearch.pid
    -Des.default.config=/etc/elasticsearch/elasticsearch.yml
    -Des.default.path.home=/usr/share/elasticsearch
    -Des.default.path.logs=/home/log/elasticsearch
    -Des.default.path.data=/home/data/elasticsearch
    -Des.default.path.work=/home/tmp/elasticsearch
    -Des.default.path.conf=/etc/elasticsearch'

  • export ES_HEAP_SIZE

  • export ES_HEAP_NEWSIZE

  • export ES_DIRECT_SIZE

  • export ES_JAVA_OPTS

  • test -x /usr/share/elasticsearch/bin/elasticsearch

  • case "$1" in

  • checkJava

  • '[' -x /usr/lib/jvm/java-6-openjdk-amd64/bin/java ']'

  • JAVA=/usr/lib/jvm/java-6-openjdk-amd64/bin/java

  • '[' '!' -x /usr/lib/jvm/java-6-openjdk-amd64/bin/java ']'

  • '[' -n unlimited -a -z 2g ']'

  • log_daemon_msg 'Starting Elasticsearch Server'

  • '[' -z 'Starting Elasticsearch Server' ']'

  • log_use_fancy_output

  • TPUT=/usr/bin/tput

  • EXPR=/usr/bin/expr

  • '[' -t 1 ']'

  • '[' xxterm-256color '!=' x ']'

  • '[' xxterm-256color '!=' xdumb ']'

  • '[' -x /usr/bin/tput ']'

  • '[' -x /usr/bin/expr ']'

  • /usr/bin/tput hpa 60

  • /usr/bin/tput setaf 1

  • '[' -z ']'

  • FANCYTTY=1

  • case "$FANCYTTY" in

  • true

  • /usr/bin/tput xenl

++ /usr/bin/tput cols

  • COLS=119

  • '[' 119 ']'

  • '[' 119 -gt 6 ']'

++ /usr/bin/expr 119 - 7

  • COL=112

  • log_use_plymouth

  • '[' n = y ']'

  • plymouth --ping

  • printf ' * Starting Elasticsearch Server '

  • Starting Elasticsearch Server ++ /usr/bin/expr 119 - 1
  • /usr/bin/tput hpa 118

                                          + printf ' '
    

++ pidofproc -p /var/run/elasticsearch.pid elasticsearch

++ local pidfile base status specified pid OPTIND

++ pidfile=

++ specified=

++ OPTIND=1

++ getopts p: opt

++ case "$opt" in

++ pidfile=/var/run/elasticsearch.pid

++ specified=specified

++ getopts p: opt

++ shift 2

++ '[' 1 -ne 1 ']'

++ base=elasticsearch

++ '[' '!' specified ']'

++ '[' -n /var/run/elasticsearch.pid -a -r /var/run/elasticsearch.pid ']'

++ read pid

++ '[' -n '' ']'

++ '[' -n specified ']'

++ '[' -e /var/run/elasticsearch.pid -a '!' -r /var/run/elasticsearch.pid
']'

++ return 3

  • pid=

  • '[' -n '' ']'

  • mkdir -p /home/log/elasticsearch /home/data/elasticsearch
    /home/tmp/elasticsearch

  • chown elasticsearch:elasticsearch /home/log/elasticsearch
    /home/data/elasticsearch /home/tmp/elasticsearch

  • touch /var/run/elasticsearch.pid

  • chown elasticsearch:elasticsearch /var/run/elasticsearch.pid

  • '[' -n 65535 ']'

  • ulimit -n 65535

  • '[' -n unlimited ']'

  • ulimit -l unlimited

  • '[' -n 262144 ']'

  • sysctl -q -w vm.max_map_count=262144

  • start-stop-daemon --start -b --user elasticsearch -c elasticsearch
    --pidfile /var/run/elasticsearch.pid --exec
    /usr/share/elasticsearch/bin/elasticsearch -- -d -p
    /var/run/elasticsearch.pid
    -Des.default.config=/etc/elasticsearch/elasticsearch.yml
    -Des.default.path.home=/usr/share/elasticsearch
    -Des.default.path.logs=/home/log/elasticsearch
    -Des.default.path.data=/home/data/elasticsearch
    -Des.default.path.work=/home/tmp/elasticsearch
    -Des.default.path.conf=/etc/elasticsearch

  • log_end_msg 0

  • '[' -z 0 ']'

  • '[' 112 ']'

  • '[' -x /usr/bin/tput ']'

  • log_use_plymouth

  • '[' n = y ']'

  • plymouth --ping

  • printf '\r'

  • /usr/bin/tput hpa 112

                                    + '[' 0 -eq 0 ']'
    
  • echo '[ OK ]'

[ OK ]

  • return 0

  • exit 0

On Monday, June 30, 2014 3:52:49 AM UTC-4, Alexander Reelsen wrote:

Hey,

if you put something like 'set -x' into /etc/init.d/elasticsearch (not
in the first line, but somewhere below that), you can see, how
elasticsearch is started (and which parameters from the default file are
used). Can you paste that output here, so we can debug further? Cant say if
it is a configuration issue or a packaging bug now, but would love to.. and
fix if needed :slight_smile:

--Alex

On Fri, Jun 27, 2014 at 9:57 PM, Steven Yue jinc...@gmail.com wrote:

Hi, sri

Thanks for your reply. Yes, they all have permissions

'ls -lah' shows this:

drwxr-xr-x 2 elasticsearch elasticsearch

On Friday, June 27, 2014 3:42:51 PM UTC-4, sri wrote:

Hi Steven,

your /home/data/elasticsearch and /home/log/elasticsearch folder
should be owned by elasticsearch and should have write permissions.
Could you confirm that for me.. pls..

Thanks and Regards
Sri

On Friday, June 27, 2014 3:32:10 PM UTC-4, Steven Yue wrote:

Hi, Sri

I tried to change logging level to TRACE in logging.yml file, but
still it just did not create any logs.

I noticed it only read settings inside "/etc/default/elasticsearch",
but never read settings inside "/etc/elasticsearch/elasticsearch.yml",
even though I have 'CONF_FILE=/etc/elasticsearch/elasticsearch.yml'

So if I set 'LOG_DIR=/home/log/elasticsearch', 'DATA_DIR=/home/data/
elasticsearch' inside "/etc/default/elasticsearch", it will at least
create those directories accordingly when starting, but it will not if I
set those variables inside 'elasticsearch.yml' file using path.data,
path.logs.

This also makes me believe the logging.yml file is never read.

On Friday, June 27, 2014 11:38:06 AM UTC-4, sri wrote:

Hi Steven,

Change the logging level to TRACE or DEBUG and check the logs , you
should be able to identify the problem.
Hope that helps

Thanks and Regards
Sri

On Friday, June 27, 2014 10:51:36 AM UTC-4, Steven Yue wrote:

Hi, everyone

I'm trying to install elasticsearch 1.2.1 on a ubuntu 14.04 server.

I used the dpkg -i to install

When I run 'sudo /etc/init.d/elasticsearch start', it says:
"Starting Elasticsearch Server [ OK ]", but actually no process is ever
started, and I couldn't find any errors or any logs in the log folder(
/var/log/elasticsearch).

I tried to run 'sudo /usr/share/elasticsearch/bin/elasticsearch
start' directly, and it is able to start and i can get response
when using curl, although it gives me the following warnning:

log4j:WARN No appenders could be found for logger (node).
log4j:WARN Please initialize the log4j system properly.
log4j:WARN See http://logging.apache.org/log4
j/1.2/faq.html#noconfig for more info.

I tried to edit settings in /etc/default/elasticsearch,
uncommented the following lines:

ES_HEAP_SIZE=2g

MAX_LOCKED_MEMORY=unlimited

Elasticsearch log directory

LOG_DIR=/var/log/elasticsearch

Elasticsearch data directory

DATA_DIR=/home/data/elasticsearch

Elasticsearch work directory

WORK_DIR=/home/tmp/elasticsearch

Elasticsearch configuration directory

CONF_DIR=/etc/elasticsearch

Elasticsearch configuration file (elasticsearch.yml)

CONF_FILE=/etc/elasticsearch/elasticsearch.yml

When restart the service, I did see it created the folder, but
still failed to run, even thought it says 'OK'

Could anyone help me to figure out why and how to run it? Thanks

--
You received this message because you are subscribed to the Google
Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send
an email to elasticsearc...@googlegroups.com.
To view this discussion on the web visit https://groups.google.com/d/
msgid/elasticsearch/b7be4308-634e-4833-a408-46bac2b7ace8%
40googlegroups.com
https://groups.google.com/d/msgid/elasticsearch/b7be4308-634e-4833-a408-46bac2b7ace8%40googlegroups.com?utm_medium=email&utm_source=footer
.

For more options, visit https://groups.google.com/d/optout.

--
You received this message because you are subscribed to the Google Groups
"elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an
email to elasticsearc...@googlegroups.com <javascript:>.
To view this discussion on the web visit
https://groups.google.com/d/msgid/elasticsearch/2f2607df-bd67-4350-b94f-a720fbb56a37%40googlegroups.com
https://groups.google.com/d/msgid/elasticsearch/2f2607df-bd67-4350-b94f-a720fbb56a37%40googlegroups.com?utm_medium=email&utm_source=footer
.
For more options, visit https://groups.google.com/d/optout.

--
You received this message because you are subscribed to the Google Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an email to elasticsearch+unsubscribe@googlegroups.com.
To view this discussion on the web visit https://groups.google.com/d/msgid/elasticsearch/678f081c-7b0f-44b9-8ed5-9eb8a5baf589%40googlegroups.com.
For more options, visit https://groups.google.com/d/optout.


(Mark Walkom) #10

Are you sure, unless I am misreading this, the OS is picking up v6;

  • for jdir in '$JDK_DIRS'
  • '[' -r /usr/lib/jvm/java-6-openjdk-amd64/bin/java -a -z '' ']'
  • JAVA_HOME=/usr/lib/jvm/java-6-openjdk-amd64

Regards,
Mark Walkom

Infrastructure Engineer
Campaign Monitor
email: markw@campaignmonitor.com
web: www.campaignmonitor.com

On 7 July 2014 12:47, Steven Yue jincheker@gmail.com wrote:

No, I have 7.

Run 'java -version' shows this:

java version "1.7.0_60"

Java(TM) SE Runtime Environment (build 1.7.0_60-b19)

Java HotSpot(TM) 64-Bit Server VM (build 24.60-b09, mixed mode)

On Tuesday, July 1, 2014 11:29:05 PM UTC-4, Mark Walkom wrote:

You're on Java 6 by the looks of it, ES won't run on anything less than 7.

Regards,
Mark Walkom

Infrastructure Engineer
Campaign Monitor
email: ma...@campaignmonitor.com
web: www.campaignmonitor.com

On 1 July 2014 22:57, Steven Yue jinc...@gmail.com wrote:

Hi, Alex

Below is the output:

++ id -u

  • '[' 0 -ne 0 ']'

  • . /lib/lsb/init-functions

+++ run-parts --lsbsysinit --list /lib/lsb/init-functions.d

++ for hook in '$(run-parts --lsbsysinit --list
/lib/lsb/init-functions.d 2>/dev/null)'

++ '[' -r /lib/lsb/init-functions.d/20-left-info-blocks ']'

++ . /lib/lsb/init-functions.d/20-left-info-blocks

++ for hook in '$(run-parts --lsbsysinit --list
/lib/lsb/init-functions.d 2>/dev/null)'

++ '[' -r /lib/lsb/init-functions.d/50-ubuntu-logging ']'

++ . /lib/lsb/init-functions.d/50-ubuntu-logging

+++ LOG_DAEMON_MSG=

++ FANCYTTY=

++ '[' -e /etc/lsb-base-logging.sh ']'

++ true

  • '[' -r /etc/default/rcS ']'

  • . /etc/default/rcS

++ UTC=yes

++ FSCKFIX=no

  • ES_USER=elasticsearch

  • ES_GROUP=elasticsearch

  • JDK_DIRS='/usr/lib/jvm/java-7-oracle /usr/lib/jvm/java-7-openjdk
    /usr/lib/jvm/java-7-openjdk-amd64/ /usr/lib/jvm/java-7-openjdk-armhf
    /usr/lib/jvm/java-7-openjdk-i386/ /usr/lib/jvm/java-6-sun
    /usr/lib/jvm/java-6-openjdk /usr/lib/jvm/java-6-openjdk-amd64
    /usr/lib/jvm/java-6-openjdk-armhf /usr/lib/jvm/java-6-openjdk-i386
    /usr/lib/jvm/default-java'

  • for jdir in '$JDK_DIRS'

  • '[' -r /usr/lib/jvm/java-7-oracle/bin/java -a -z '' ']'

  • for jdir in '$JDK_DIRS'

  • '[' -r /usr/lib/jvm/java-7-openjdk/bin/java -a -z '' ']'

  • for jdir in '$JDK_DIRS'

  • '[' -r /usr/lib/jvm/java-7-openjdk-amd64//bin/java -a -z '' ']'

  • for jdir in '$JDK_DIRS'

  • '[' -r /usr/lib/jvm/java-7-openjdk-armhf/bin/java -a -z '' ']'

  • for jdir in '$JDK_DIRS'

  • '[' -r /usr/lib/jvm/java-7-openjdk-i386//bin/java -a -z '' ']'

  • for jdir in '$JDK_DIRS'

  • '[' -r /usr/lib/jvm/java-6-sun/bin/java -a -z '' ']'

  • for jdir in '$JDK_DIRS'

  • '[' -r /usr/lib/jvm/java-6-openjdk/bin/java -a -z '' ']'

  • for jdir in '$JDK_DIRS'

  • '[' -r /usr/lib/jvm/java-6-openjdk-amd64/bin/java -a -z '' ']'

  • JAVA_HOME=/usr/lib/jvm/java-6-openjdk-amd64

  • for jdir in '$JDK_DIRS'

  • '[' -r /usr/lib/jvm/java-6-openjdk-armhf/bin/java -a -z
    /usr/lib/jvm/java-6-openjdk-amd64 ']'

  • for jdir in '$JDK_DIRS'

  • '[' -r /usr/lib/jvm/java-6-openjdk-i386/bin/java -a -z
    /usr/lib/jvm/java-6-openjdk-amd64 ']'

  • for jdir in '$JDK_DIRS'

  • '[' -r /usr/lib/jvm/default-java/bin/java -a -z
    /usr/lib/jvm/java-6-openjdk-amd64 ']'

  • export JAVA_HOME

  • ES_HOME=/usr/share/elasticsearch

  • MAX_OPEN_FILES=65535

  • LOG_DIR=/var/log/elasticsearch

  • DATA_DIR=/var/lib/elasticsearch

  • WORK_DIR=/tmp/elasticsearch

  • CONF_DIR=/etc/elasticsearch

  • CONF_FILE=/etc/elasticsearch/elasticsearch.yml

  • MAX_MAP_COUNT=262144

  • '[' -f /etc/default/elasticsearch ']'

  • . /etc/default/elasticsearch

++ ES_USER=elasticsearch

++ ES_GROUP=elasticsearch

++ ES_HEAP_SIZE=2g

++ MAX_LOCKED_MEMORY=unlimited

++ LOG_DIR=/home/log/elasticsearch

++ DATA_DIR=/home/data/elasticsearch

++ WORK_DIR=/home/tmp/elasticsearch

++ CONF_DIR=/etc/elasticsearch

++ CONF_FILE=/etc/elasticsearch/elasticsearch.yml

  • PID_FILE=/var/run/elasticsearch.pid

  • DAEMON=/usr/share/elasticsearch/bin/elasticsearch

  • DAEMON_OPTS='-d -p /var/run/elasticsearch.pid -Des.default.config=/etc/
    elasticsearch/elasticsearch.yml -Des.default.path.home=/usr/share/elasticsearch
    -Des.default.path.logs=/home/log/elasticsearch
    -Des.default.path.data=/home/data/elasticsearch
    -Des.default.path.work=/home/tmp/elasticsearch
    -Des.default.path.conf=/etc/elasticsearch'

  • export ES_HEAP_SIZE

  • export ES_HEAP_NEWSIZE

  • export ES_DIRECT_SIZE

  • export ES_JAVA_OPTS

  • test -x /usr/share/elasticsearch/bin/elasticsearch

  • case "$1" in

  • checkJava

  • '[' -x /usr/lib/jvm/java-6-openjdk-amd64/bin/java ']'

  • JAVA=/usr/lib/jvm/java-6-openjdk-amd64/bin/java

  • '[' '!' -x /usr/lib/jvm/java-6-openjdk-amd64/bin/java ']'

  • '[' -n unlimited -a -z 2g ']'

  • log_daemon_msg 'Starting Elasticsearch Server'

  • '[' -z 'Starting Elasticsearch Server' ']'

  • log_use_fancy_output

  • TPUT=/usr/bin/tput

  • EXPR=/usr/bin/expr

  • '[' -t 1 ']'

  • '[' xxterm-256color '!=' x ']'

  • '[' xxterm-256color '!=' xdumb ']'

  • '[' -x /usr/bin/tput ']'

  • '[' -x /usr/bin/expr ']'

  • /usr/bin/tput hpa 60

  • /usr/bin/tput setaf 1

  • '[' -z ']'

  • FANCYTTY=1

  • case "$FANCYTTY" in

  • true

  • /usr/bin/tput xenl

++ /usr/bin/tput cols

  • COLS=119

  • '[' 119 ']'

  • '[' 119 -gt 6 ']'

++ /usr/bin/expr 119 - 7

  • COL=112

  • log_use_plymouth

  • '[' n = y ']'

  • plymouth --ping

  • printf ' * Starting Elasticsearch Server '

  • Starting Elasticsearch Server ++ /usr/bin/expr 119 - 1
  • /usr/bin/tput hpa 118

                                            + printf ' '
    

++ pidofproc -p /var/run/elasticsearch.pid elasticsearch

++ local pidfile base status specified pid OPTIND

++ pidfile=

++ specified=

++ OPTIND=1

++ getopts p: opt

++ case "$opt" in

++ pidfile=/var/run/elasticsearch.pid

++ specified=specified

++ getopts p: opt

++ shift 2

++ '[' 1 -ne 1 ']'

++ base=elasticsearch

++ '[' '!' specified ']'

++ '[' -n /var/run/elasticsearch.pid -a -r /var/run/elasticsearch.pid ']'

++ read pid

++ '[' -n '' ']'

++ '[' -n specified ']'

++ '[' -e /var/run/elasticsearch.pid -a '!' -r
/var/run/elasticsearch.pid ']'

++ return 3

  • pid=

  • '[' -n '' ']'

  • mkdir -p /home/log/elasticsearch /home/data/elasticsearch
    /home/tmp/elasticsearch

  • chown elasticsearch:elasticsearch /home/log/elasticsearch
    /home/data/elasticsearch /home/tmp/elasticsearch

  • touch /var/run/elasticsearch.pid

  • chown elasticsearch:elasticsearch /var/run/elasticsearch.pid

  • '[' -n 65535 ']'

  • ulimit -n 65535

  • '[' -n unlimited ']'

  • ulimit -l unlimited

  • '[' -n 262144 ']'

  • sysctl -q -w vm.max_map_count=262144

  • start-stop-daemon --start -b --user elasticsearch -c elasticsearch
    --pidfile /var/run/elasticsearch.pid --exec /usr/share/elasticsearch/bin/elasticsearch
    -- -d -p /var/run/elasticsearch.pid -Des.default.config=/etc/
    elasticsearch/elasticsearch.yml -Des.default.path.home=/usr/share/elasticsearch
    -Des.default.path.logs=/home/log/elasticsearch
    -Des.default.path.data=/home/data/elasticsearch
    -Des.default.path.work=/home/tmp/elasticsearch
    -Des.default.path.conf=/etc/elasticsearch

  • log_end_msg 0

  • '[' -z 0 ']'

  • '[' 112 ']'

  • '[' -x /usr/bin/tput ']'

  • log_use_plymouth

  • '[' n = y ']'

  • plymouth --ping

  • printf '\r'

  • /usr/bin/tput hpa 112

                                      + '[' 0 -eq 0 ']'
    
  • echo '[ OK ]'

[ OK ]

  • return 0

  • exit 0

On Monday, June 30, 2014 3:52:49 AM UTC-4, Alexander Reelsen wrote:

Hey,

if you put something like 'set -x' into /etc/init.d/elasticsearch (not
in the first line, but somewhere below that), you can see, how
elasticsearch is started (and which parameters from the default file are
used). Can you paste that output here, so we can debug further? Cant say if
it is a configuration issue or a packaging bug now, but would love to.. and
fix if needed :slight_smile:

--Alex

On Fri, Jun 27, 2014 at 9:57 PM, Steven Yue jinc...@gmail.com wrote:

Hi, sri

Thanks for your reply. Yes, they all have permissions

'ls -lah' shows this:

drwxr-xr-x 2 elasticsearch elasticsearch

On Friday, June 27, 2014 3:42:51 PM UTC-4, sri wrote:

Hi Steven,

your /home/data/elasticsearch and /home/log/elasticsearch folder
should be owned by elasticsearch and should have write permissions.
Could you confirm that for me.. pls..

Thanks and Regards
Sri

On Friday, June 27, 2014 3:32:10 PM UTC-4, Steven Yue wrote:

Hi, Sri

I tried to change logging level to TRACE in logging.yml file, but
still it just did not create any logs.

I noticed it only read settings inside "/etc/default/elasticsearch",
but never read settings inside "/etc/elasticsearch/elasticsearch.yml",
even though I have 'CONF_FILE=/etc/elasticsearch/elasticsearch.yml'

So if I set 'LOG_DIR=/home/log/elasticsearch', 'DATA_DIR=/home/data/
elasticsearch' inside "/etc/default/elasticsearch", it will at
least create those directories accordingly when starting, but it will not
if I set those variables inside 'elasticsearch.yml' file using path.data,
path.logs.

This also makes me believe the logging.yml file is never read.

On Friday, June 27, 2014 11:38:06 AM UTC-4, sri wrote:

Hi Steven,

Change the logging level to TRACE or DEBUG and check the logs , you
should be able to identify the problem.
Hope that helps

Thanks and Regards
Sri

On Friday, June 27, 2014 10:51:36 AM UTC-4, Steven Yue wrote:

Hi, everyone

I'm trying to install elasticsearch 1.2.1 on a ubuntu 14.04
server.

I used the dpkg -i to install

When I run 'sudo /etc/init.d/elasticsearch start', it says:
"Starting Elasticsearch Server [ OK ]", but actually no process is ever
started, and I couldn't find any errors or any logs in the log folder(
/var/log/elasticsearch).

I tried to run 'sudo /usr/share/elasticsearch/bin/elasticsearch
start' directly, and it is able to start and i can get response
when using curl, although it gives me the following warnning:

log4j:WARN No appenders could be found for logger (node).
log4j:WARN Please initialize the log4j system properly.
log4j:WARN See http://logging.apache.org/log4
j/1.2/faq.html#noconfig for more info.

I tried to edit settings in /etc/default/elasticsearch,
uncommented the following lines:

ES_HEAP_SIZE=2g

MAX_LOCKED_MEMORY=unlimited

Elasticsearch log directory

LOG_DIR=/var/log/elasticsearch

Elasticsearch data directory

DATA_DIR=/home/data/elasticsearch

Elasticsearch work directory

WORK_DIR=/home/tmp/elasticsearch

Elasticsearch configuration directory

CONF_DIR=/etc/elasticsearch

Elasticsearch configuration file (elasticsearch.yml)

CONF_FILE=/etc/elasticsearch/elasticsearch.yml

When restart the service, I did see it created the folder, but
still failed to run, even thought it says 'OK'

Could anyone help me to figure out why and how to run it? Thanks

--
You received this message because you are subscribed to the Google
Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send
an email to elasticsearc...@googlegroups.com.
To view this discussion on the web visit https://groups.google.com/d/
msgid/elasticsearch/b7be4308-634e-4833-a408-46bac2b7ace8%40goo
glegroups.com
https://groups.google.com/d/msgid/elasticsearch/b7be4308-634e-4833-a408-46bac2b7ace8%40googlegroups.com?utm_medium=email&utm_source=footer
.

For more options, visit https://groups.google.com/d/optout.

--
You received this message because you are subscribed to the Google
Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send
an email to elasticsearc...@googlegroups.com.
To view this discussion on the web visit https://groups.google.com/d/
msgid/elasticsearch/2f2607df-bd67-4350-b94f-a720fbb56a37%
40googlegroups.com
https://groups.google.com/d/msgid/elasticsearch/2f2607df-bd67-4350-b94f-a720fbb56a37%40googlegroups.com?utm_medium=email&utm_source=footer
.
For more options, visit https://groups.google.com/d/optout.

--
You received this message because you are subscribed to the Google Groups
"elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an
email to elasticsearch+unsubscribe@googlegroups.com.
To view this discussion on the web visit
https://groups.google.com/d/msgid/elasticsearch/678f081c-7b0f-44b9-8ed5-9eb8a5baf589%40googlegroups.com
https://groups.google.com/d/msgid/elasticsearch/678f081c-7b0f-44b9-8ed5-9eb8a5baf589%40googlegroups.com?utm_medium=email&utm_source=footer
.
For more options, visit https://groups.google.com/d/optout.

--
You received this message because you are subscribed to the Google Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an email to elasticsearch+unsubscribe@googlegroups.com.
To view this discussion on the web visit https://groups.google.com/d/msgid/elasticsearch/CAEM624bWXwWKfxmBaDdtYnwy0zMNEz9P6rhXWMQ66NVc7pakMg%40mail.gmail.com.
For more options, visit https://groups.google.com/d/optout.


(system) #11