Problem starting elasticsearch 0.90.11


(Jim Adamson) #1

I am having a problem running elasticsearch-0.90.11.deb on Ubuntu 12.04.4
LTS (VMWare VM, Intel Xeon @ 2.3Ghz, 2GB RAM). The problem occurs after I
run /etc/init.d/elasticsearch start. Although ES appears to start
successfully, grepping for the process shows it is not running.

Issuing the following:

cd /usr/share/elasticsearch/bin
./elasticsearch -f

...gives:

log4j:WARN No appenders could be found for logger (node).
log4j:WARN Please initialize the log4j system properly.
log4j:WARN See http://logging.apache.org/log4j/1.2/faq.html#noconfig for
more info.

With help from a developer colleague I have managed to get it to run by
adding a suitable log4j.properties file to /usr/share/elasticsearch/bin,
cd-ing to that directory and running ./elasticsearch -f -Dlog4j.configuration=./log4j.properties. However, I'm not sure why this
would have been required in the first place and feel there must be
something misconfigured that's resulting in the init.d script failing to
start ES.

I have tried adding the following to /etc/elasticsearch/elasticsearch.yml
but it doesn't make a difference:

path.conf: /etc/elasticsearch
path.data: /var/lib/elasticsearch
path.work: /tmp/elasticsearch
path.logs: /var/log/elasticsearch

ES is one of the dependencies for some software we are running called atom,
which only support ES < v1. The install instructions are available at
https://www.accesstomemory.org/en/docs/2.0/admin-manual/installation/linux/#installation-linux.

The version of Java is Oracle’s JVM distributed by Web Upd8:

java -version
java version "1.8.0_11"
Java(TM) SE Runtime Environment (build 1.8.0_11-b12)
Java HotSpot(TM) 64-Bit Server VM (build 25.11-b03, mixed mode)

Thanks for any help you can provide.

Jim

--
You received this message because you are subscribed to the Google Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an email to elasticsearch+unsubscribe@googlegroups.com.
To view this discussion on the web visit https://groups.google.com/d/msgid/elasticsearch/7a29f981-232b-43c9-a60d-7306d1bfdf45%40googlegroups.com.
For more options, visit https://groups.google.com/d/optout.


(Mark Walkom) #2

I just tested this and didn't run into the same problem.

Have you changed something locally around your environment variables, or in
the service defaults?

Regards,
Mark Walkom

Infrastructure Engineer
Campaign Monitor
email: markw@campaignmonitor.com
web: www.campaignmonitor.com

On 8 August 2014 00:34, Jim Adamson jim.adamson@york.ac.uk wrote:

I am having a problem running elasticsearch-0.90.11.deb on Ubuntu 12.04.4
LTS (VMWare VM, Intel Xeon @ 2.3Ghz, 2GB RAM). The problem occurs after I
run /etc/init.d/elasticsearch start. Although ES appears to start
successfully, grepping for the process shows it is not running.

Issuing the following:

cd /usr/share/elasticsearch/bin
./elasticsearch -f

...gives:

log4j:WARN No appenders could be found for logger (node).
log4j:WARN Please initialize the log4j system properly.
log4j:WARN See http://logging.apache.org/log4j/1.2/faq.html#noconfig for
more info.

With help from a developer colleague I have managed to get it to run by
adding a suitable log4j.properties file to /usr/share/elasticsearch/bin,
cd-ing to that directory and running ./elasticsearch -f -Dlog4j.configuration=./log4j.properties. However, I'm not sure why this
would have been required in the first place and feel there must be
something misconfigured that's resulting in the init.d script failing to
start ES.

I have tried adding the following to /etc/elasticsearch/elasticsearch.yml
but it doesn't make a difference:

path.conf: /etc/elasticsearch
path.data: /var/lib/elasticsearch
path.work: /tmp/elasticsearch
path.logs: /var/log/elasticsearch

ES is one of the dependencies for some software we are running called
atom, which only support ES < v1. The install instructions are available at
https://www.accesstomemory.org/en/docs/2.0/admin-manual/installation/linux/#installation-linux
.

The version of Java is Oracle’s JVM distributed by Web Upd8:

java -version
java version "1.8.0_11"
Java(TM) SE Runtime Environment (build 1.8.0_11-b12)
Java HotSpot(TM) 64-Bit Server VM (build 25.11-b03, mixed mode)

Thanks for any help you can provide.

Jim

--
You received this message because you are subscribed to the Google Groups
"elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an
email to elasticsearch+unsubscribe@googlegroups.com.
To view this discussion on the web visit
https://groups.google.com/d/msgid/elasticsearch/7a29f981-232b-43c9-a60d-7306d1bfdf45%40googlegroups.com
https://groups.google.com/d/msgid/elasticsearch/7a29f981-232b-43c9-a60d-7306d1bfdf45%40googlegroups.com?utm_medium=email&utm_source=footer
.
For more options, visit https://groups.google.com/d/optout.

--
You received this message because you are subscribed to the Google Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an email to elasticsearch+unsubscribe@googlegroups.com.
To view this discussion on the web visit https://groups.google.com/d/msgid/elasticsearch/CAEM624YoNaXtdwCJXvxMcHRSWunaq6V7DtFks3Y%2BoYfQWEpLBQ%40mail.gmail.com.
For more options, visit https://groups.google.com/d/optout.


(Jörg Prante) #3

I do not use deb or rpm, but I remember this is an issue when running ES
under superuser privilege.

ES should never (never) run as root, instead a user with minimal privilege
should be created.

Jörg

On Fri, Aug 8, 2014 at 2:21 AM, Mark Walkom markw@campaignmonitor.com
wrote:

I just tested this and didn't run into the same problem.

Have you changed something locally around your environment variables, or
in the service defaults?

Regards,
Mark Walkom

Infrastructure Engineer
Campaign Monitor
email: markw@campaignmonitor.com
web: www.campaignmonitor.com

On 8 August 2014 00:34, Jim Adamson jim.adamson@york.ac.uk wrote:

I am having a problem running elasticsearch-0.90.11.deb on Ubuntu 12.04.4
LTS (VMWare VM, Intel Xeon @ 2.3Ghz, 2GB RAM). The problem occurs after I
run /etc/init.d/elasticsearch start. Although ES appears to start
successfully, grepping for the process shows it is not running.

Issuing the following:

cd /usr/share/elasticsearch/bin
./elasticsearch -f

...gives:

log4j:WARN No appenders could be found for logger (node).
log4j:WARN Please initialize the log4j system properly.
log4j:WARN See http://logging.apache.org/log4j/1.2/faq.html#noconfig for
more info.

With help from a developer colleague I have managed to get it to run by
adding a suitable log4j.properties file to /usr/share/elasticsearch/bin,
cd-ing to that directory and running ./elasticsearch -f -Dlog4j.configuration=./log4j.properties. However, I'm not sure why this
would have been required in the first place and feel there must be
something misconfigured that's resulting in the init.d script failing to
start ES.

I have tried adding the following to /etc/elasticsearch/elasticsearch.yml
but it doesn't make a difference:

path.conf: /etc/elasticsearch
path.data: /var/lib/elasticsearch
path.work: /tmp/elasticsearch
path.logs: /var/log/elasticsearch

ES is one of the dependencies for some software we are running called
atom, which only support ES < v1. The install instructions are available at
https://www.accesstomemory.org/en/docs/2.0/admin-manual/installation/linux/#installation-linux
.

The version of Java is Oracle’s JVM distributed by Web Upd8:

java -version
java version "1.8.0_11"
Java(TM) SE Runtime Environment (build 1.8.0_11-b12)
Java HotSpot(TM) 64-Bit Server VM (build 25.11-b03, mixed mode)

Thanks for any help you can provide.

Jim

--
You received this message because you are subscribed to the Google Groups
"elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an
email to elasticsearch+unsubscribe@googlegroups.com.
To view this discussion on the web visit
https://groups.google.com/d/msgid/elasticsearch/7a29f981-232b-43c9-a60d-7306d1bfdf45%40googlegroups.com
https://groups.google.com/d/msgid/elasticsearch/7a29f981-232b-43c9-a60d-7306d1bfdf45%40googlegroups.com?utm_medium=email&utm_source=footer
.
For more options, visit https://groups.google.com/d/optout.

--
You received this message because you are subscribed to the Google Groups
"elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an
email to elasticsearch+unsubscribe@googlegroups.com.
To view this discussion on the web visit
https://groups.google.com/d/msgid/elasticsearch/CAEM624YoNaXtdwCJXvxMcHRSWunaq6V7DtFks3Y%2BoYfQWEpLBQ%40mail.gmail.com
https://groups.google.com/d/msgid/elasticsearch/CAEM624YoNaXtdwCJXvxMcHRSWunaq6V7DtFks3Y%2BoYfQWEpLBQ%40mail.gmail.com?utm_medium=email&utm_source=footer
.

For more options, visit https://groups.google.com/d/optout.

--
You received this message because you are subscribed to the Google Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an email to elasticsearch+unsubscribe@googlegroups.com.
To view this discussion on the web visit https://groups.google.com/d/msgid/elasticsearch/CAKdsXoHRvGQ%3DyxTMCROCkcgxk5gEAK2UGcJtnqANPxjMzNyx-A%40mail.gmail.com.
For more options, visit https://groups.google.com/d/optout.


(ShayneThill02) #4

The activity of the animal beings has become acutely active everywhere on this earth. Bodies do not get time to booty a blow for a while. With the accretion use of altered gadgets of Gps Jammer, the possibilities of accepting the aboriginal of blow accept absolutely finished. The adaptable phones or the corpuscle phones are some of these accessories that accumulate the bodies consistently in blow with the alfresco world. The adaptable building are additionally accessible about everywhere these canicule and due to this the accessibility of the Cell Phone Jammer has become alike added quick and authentic. Today, you cannot break out of ability of these adaptable building as their signals can bolt your about anywhere. The bearings of bodies who accord to altered business professions has become actual analytical of car mobile phone blocker as their authorities bolt them anywhere any moment.


(Jim Adamson) #5

Hello Jörg!

Thanks for the reply. I was indeed trying to start ES as superuser. I will
try this in a week or so as I am off on leave at the moment.

Jim

On Friday, 8 August 2014 08:37:41 UTC+1, Jörg Prante wrote:

I do not use deb or rpm, but I remember this is an issue when running ES
under superuser privilege.

ES should never (never) run as root, instead a user with minimal privilege
should be created.

Jörg

On Fri, Aug 8, 2014 at 2:21 AM, Mark Walkom <ma...@campaignmonitor.com
<javascript:>> wrote:

I just tested this and didn't run into the same problem.

Have you changed something locally around your environment variables, or
in the service defaults?

Regards,
Mark Walkom

Infrastructure Engineer
Campaign Monitor
email: ma...@campaignmonitor.com <javascript:>
web: www.campaignmonitor.com

On 8 August 2014 00:34, Jim Adamson <jim.a...@york.ac.uk <javascript:>>
wrote:

I am having a problem running elasticsearch-0.90.11.deb on Ubuntu
12.04.4 LTS (VMWare VM, Intel Xeon @ 2.3Ghz, 2GB RAM). The problem occurs
after I run /etc/init.d/elasticsearch start. Although ES appears to start
successfully, grepping for the process shows it is not running.

Issuing the following:

cd /usr/share/elasticsearch/bin
./elasticsearch -f

...gives:

log4j:WARN No appenders could be found for logger (node).
log4j:WARN Please initialize the log4j system properly.
log4j:WARN See http://logging.apache.org/log4j/1.2/faq.html#noconfig
for more info.

With help from a developer colleague I have managed to get it to run by
adding a suitable log4j.properties file to /usr/share/elasticsearch/bin,
cd-ing to that directory and running ./elasticsearch -f -Dlog4j.configuration=./log4j.properties. However, I'm not sure why this
would have been required in the first place and feel there must be
something misconfigured that's resulting in the init.d script failing to
start ES.

I have tried adding the following to
/etc/elasticsearch/elasticsearch.yml but it doesn't make a difference:

path.conf: /etc/elasticsearch
path.data: /var/lib/elasticsearch
path.work: /tmp/elasticsearch
path.logs: /var/log/elasticsearch

ES is one of the dependencies for some software we are running called
atom, which only support ES < v1. The install instructions are available at
https://www.accesstomemory.org/en/docs/2.0/admin-manual/installation/linux/#installation-linux
.

The version of Java is Oracle’s JVM distributed by Web Upd8:

java -version
java version "1.8.0_11"
Java(TM) SE Runtime Environment (build 1.8.0_11-b12)
Java HotSpot(TM) 64-Bit Server VM (build 25.11-b03, mixed mode)

Thanks for any help you can provide.

Jim

--
You received this message because you are subscribed to the Google
Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send
an email to elasticsearc...@googlegroups.com <javascript:>.
To view this discussion on the web visit
https://groups.google.com/d/msgid/elasticsearch/7a29f981-232b-43c9-a60d-7306d1bfdf45%40googlegroups.com
https://groups.google.com/d/msgid/elasticsearch/7a29f981-232b-43c9-a60d-7306d1bfdf45%40googlegroups.com?utm_medium=email&utm_source=footer
.
For more options, visit https://groups.google.com/d/optout.

--
You received this message because you are subscribed to the Google Groups
"elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an
email to elasticsearc...@googlegroups.com <javascript:>.
To view this discussion on the web visit
https://groups.google.com/d/msgid/elasticsearch/CAEM624YoNaXtdwCJXvxMcHRSWunaq6V7DtFks3Y%2BoYfQWEpLBQ%40mail.gmail.com
https://groups.google.com/d/msgid/elasticsearch/CAEM624YoNaXtdwCJXvxMcHRSWunaq6V7DtFks3Y%2BoYfQWEpLBQ%40mail.gmail.com?utm_medium=email&utm_source=footer
.

For more options, visit https://groups.google.com/d/optout.

--
You received this message because you are subscribed to the Google Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an email to elasticsearch+unsubscribe@googlegroups.com.
To view this discussion on the web visit https://groups.google.com/d/msgid/elasticsearch/1f185399-ce40-44cc-90f3-aa47b62a856c%40googlegroups.com.
For more options, visit https://groups.google.com/d/optout.


(Jim Adamson) #6

Hello Mark,

Thanks for the reply. No I haven't but the VM was provisioned by our
central IT so there may be something particular about the VM's
configuration that's the cause of this. I'll try Jörg's suggestion and then
if that doesn't work I'll pursue this line.

Jim

On Friday, 8 August 2014 01:22:26 UTC+1, Mark Walkom wrote:

I just tested this and didn't run into the same problem.

Have you changed something locally around your environment variables, or
in the service defaults?

Regards,
Mark Walkom

Infrastructure Engineer
Campaign Monitor
email: ma...@campaignmonitor.com <javascript:>
web: www.campaignmonitor.com

On 8 August 2014 00:34, Jim Adamson <jim.a...@york.ac.uk <javascript:>>
wrote:

I am having a problem running elasticsearch-0.90.11.deb on Ubuntu 12.04.4
LTS (VMWare VM, Intel Xeon @ 2.3Ghz, 2GB RAM). The problem occurs after I
run /etc/init.d/elasticsearch start. Although ES appears to start
successfully, grepping for the process shows it is not running.

Issuing the following:

cd /usr/share/elasticsearch/bin
./elasticsearch -f

...gives:

log4j:WARN No appenders could be found for logger (node).
log4j:WARN Please initialize the log4j system properly.
log4j:WARN See http://logging.apache.org/log4j/1.2/faq.html#noconfig for
more info.

With help from a developer colleague I have managed to get it to run by
adding a suitable log4j.properties file to /usr/share/elasticsearch/bin,
cd-ing to that directory and running ./elasticsearch -f -Dlog4j.configuration=./log4j.properties. However, I'm not sure why this
would have been required in the first place and feel there must be
something misconfigured that's resulting in the init.d script failing to
start ES.

I have tried adding the following to /etc/elasticsearch/elasticsearch.yml
but it doesn't make a difference:

path.conf: /etc/elasticsearch
path.data: /var/lib/elasticsearch
path.work: /tmp/elasticsearch
path.logs: /var/log/elasticsearch

ES is one of the dependencies for some software we are running called
atom, which only support ES < v1. The install instructions are available at
https://www.accesstomemory.org/en/docs/2.0/admin-manual/installation/linux/#installation-linux
.

The version of Java is Oracle’s JVM distributed by Web Upd8:

java -version
java version "1.8.0_11"
Java(TM) SE Runtime Environment (build 1.8.0_11-b12)
Java HotSpot(TM) 64-Bit Server VM (build 25.11-b03, mixed mode)

Thanks for any help you can provide.

Jim

--
You received this message because you are subscribed to the Google Groups
"elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an
email to elasticsearc...@googlegroups.com <javascript:>.
To view this discussion on the web visit
https://groups.google.com/d/msgid/elasticsearch/7a29f981-232b-43c9-a60d-7306d1bfdf45%40googlegroups.com
https://groups.google.com/d/msgid/elasticsearch/7a29f981-232b-43c9-a60d-7306d1bfdf45%40googlegroups.com?utm_medium=email&utm_source=footer
.
For more options, visit https://groups.google.com/d/optout.

--
You received this message because you are subscribed to the Google Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an email to elasticsearch+unsubscribe@googlegroups.com.
To view this discussion on the web visit https://groups.google.com/d/msgid/elasticsearch/d27fc22a-df18-4c98-998a-033a82545f95%40googlegroups.com.
For more options, visit https://groups.google.com/d/optout.


(Jim Adamson) #7

Hello again Jörg,

I had a look at this and contrary to what I said in my previous
message /etc/init.d/elasticsearch is configured to run ES as an
unprivileged user:

ES_USER=elasticsearch
ES_GROUP=elasticsearch

That user exists and is a member of that group.

Any further suggestions?

thanks,
Jim

On Friday, 8 August 2014 17:38:03 UTC+1, Jim Adamson wrote:

Hello Jörg!

Thanks for the reply. I was indeed trying to start ES as superuser. I will
try this in a week or so as I am off on leave at the moment.

Jim

On Friday, 8 August 2014 08:37:41 UTC+1, Jörg Prante wrote:

I do not use deb or rpm, but I remember this is an issue when running ES
under superuser privilege.

ES should never (never) run as root, instead a user with minimal
privilege should be created.

Jörg

On Fri, Aug 8, 2014 at 2:21 AM, Mark Walkom ma...@campaignmonitor.com
wrote:

I just tested this and didn't run into the same problem.

Have you changed something locally around your environment variables, or
in the service defaults?

Regards,
Mark Walkom

Infrastructure Engineer
Campaign Monitor
email: ma...@campaignmonitor.com
web: www.campaignmonitor.com

On 8 August 2014 00:34, Jim Adamson jim.a...@york.ac.uk wrote:

I am having a problem running elasticsearch-0.90.11.deb on Ubuntu
12.04.4 LTS (VMWare VM, Intel Xeon @ 2.3Ghz, 2GB RAM). The problem occurs
after I run /etc/init.d/elasticsearch start. Although ES appears to start
successfully, grepping for the process shows it is not running.

Issuing the following:

cd /usr/share/elasticsearch/bin
./elasticsearch -f

...gives:

log4j:WARN No appenders could be found for logger (node).
log4j:WARN Please initialize the log4j system properly.
log4j:WARN See http://logging.apache.org/log4j/1.2/faq.html#noconfig
for more info.

With help from a developer colleague I have managed to get it to run by
adding a suitable log4j.properties file to /usr/share/elasticsearch/bin,
cd-ing to that directory and running ./elasticsearch -f -Dlog4j.configuration=./log4j.properties. However, I'm not sure why this
would have been required in the first place and feel there must be
something misconfigured that's resulting in the init.d script failing to
start ES.

I have tried adding the following to
/etc/elasticsearch/elasticsearch.yml but it doesn't make a difference:

path.conf: /etc/elasticsearch
path.data: /var/lib/elasticsearch
path.work: /tmp/elasticsearch
path.logs: /var/log/elasticsearch

ES is one of the dependencies for some software we are running called
atom, which only support ES < v1. The install instructions are available at
https://www.accesstomemory.org/en/docs/2.0/admin-manual/installation/linux/#installation-linux
.

The version of Java is Oracle’s JVM distributed by Web Upd8:

java -version
java version "1.8.0_11"
Java(TM) SE Runtime Environment (build 1.8.0_11-b12)
Java HotSpot(TM) 64-Bit Server VM (build 25.11-b03, mixed mode)

Thanks for any help you can provide.

Jim

--
You received this message because you are subscribed to the Google
Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send
an email to elasticsearc...@googlegroups.com.
To view this discussion on the web visit
https://groups.google.com/d/msgid/elasticsearch/7a29f981-232b-43c9-a60d-7306d1bfdf45%40googlegroups.com
https://groups.google.com/d/msgid/elasticsearch/7a29f981-232b-43c9-a60d-7306d1bfdf45%40googlegroups.com?utm_medium=email&utm_source=footer
.
For more options, visit https://groups.google.com/d/optout.

--
You received this message because you are subscribed to the Google
Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send
an email to elasticsearc...@googlegroups.com.
To view this discussion on the web visit
https://groups.google.com/d/msgid/elasticsearch/CAEM624YoNaXtdwCJXvxMcHRSWunaq6V7DtFks3Y%2BoYfQWEpLBQ%40mail.gmail.com
https://groups.google.com/d/msgid/elasticsearch/CAEM624YoNaXtdwCJXvxMcHRSWunaq6V7DtFks3Y%2BoYfQWEpLBQ%40mail.gmail.com?utm_medium=email&utm_source=footer
.

For more options, visit https://groups.google.com/d/optout.

--
You received this message because you are subscribed to the Google Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an email to elasticsearch+unsubscribe@googlegroups.com.
To view this discussion on the web visit https://groups.google.com/d/msgid/elasticsearch/c48aaf92-0592-4987-8e51-cca65e7c354a%40googlegroups.com.
For more options, visit https://groups.google.com/d/optout.


(Jörg Prante) #8

Check if the file permissions are set correctly. If logging system
complains, it can not access files.

Jörg

On Tue, Aug 19, 2014 at 1:28 PM, Jim Adamson jim.adamson@york.ac.uk wrote:

Hello again Jörg,

I had a look at this and contrary to what I said in my previous
message /etc/init.d/elasticsearch is configured to run ES as an
unprivileged user:

ES_USER=elasticsearch
ES_GROUP=elasticsearch

That user exists and is a member of that group.

Any further suggestions?

thanks,
Jim

On Friday, 8 August 2014 17:38:03 UTC+1, Jim Adamson wrote:

Hello Jörg!

Thanks for the reply. I was indeed trying to start ES as superuser. I
will try this in a week or so as I am off on leave at the moment.

Jim

On Friday, 8 August 2014 08:37:41 UTC+1, Jörg Prante wrote:

I do not use deb or rpm, but I remember this is an issue when running ES
under superuser privilege.

ES should never (never) run as root, instead a user with minimal
privilege should be created.

Jörg

On Fri, Aug 8, 2014 at 2:21 AM, Mark Walkom ma...@campaignmonitor.com
wrote:

I just tested this and didn't run into the same problem.

Have you changed something locally around your environment variables,
or in the service defaults?

Regards,
Mark Walkom

Infrastructure Engineer
Campaign Monitor
email: ma...@campaignmonitor.com
web: www.campaignmonitor.com

On 8 August 2014 00:34, Jim Adamson jim.a...@york.ac.uk wrote:

I am having a problem running elasticsearch-0.90.11.deb on Ubuntu
12.04.4 LTS (VMWare VM, Intel Xeon @ 2.3Ghz, 2GB RAM). The problem occurs
after I run /etc/init.d/elasticsearch start. Although ES appears to start
successfully, grepping for the process shows it is not running.

Issuing the following:

cd /usr/share/elasticsearch/bin
./elasticsearch -f

...gives:

log4j:WARN No appenders could be found for logger (node).
log4j:WARN Please initialize the log4j system properly.
log4j:WARN See http://logging.apache.org/log4j/1.2/faq.html#noconfig
for more info.

With help from a developer colleague I have managed to get it to run
by adding a suitable log4j.properties file to /usr/share/elasticsearch/bin,
cd-ing to that directory and running ./elasticsearch -f -Dlog4j.configuration=./log4j.properties. However, I'm not sure why
this would have been required in the first place and feel there must be
something misconfigured that's resulting in the init.d script failing to
start ES.

I have tried adding the following to /etc/elasticsearch/elasticsearch.yml
but it doesn't make a difference:

path.conf: /etc/elasticsearch
path.data: /var/lib/elasticsearch
path.work: /tmp/elasticsearch
path.logs: /var/log/elasticsearch

ES is one of the dependencies for some software we are running called
atom, which only support ES < v1. The install instructions are available at
https://www.accesstomemory.org/en/docs/2.0/admin-manual/
installation/linux/#installation-linux.

The version of Java is Oracle’s JVM distributed by Web Upd8:

java -version
java version "1.8.0_11"
Java(TM) SE Runtime Environment (build 1.8.0_11-b12)
Java HotSpot(TM) 64-Bit Server VM (build 25.11-b03, mixed mode)

Thanks for any help you can provide.

Jim

--
You received this message because you are subscribed to the Google
Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send
an email to elasticsearc...@googlegroups.com.
To view this discussion on the web visit https://groups.google.com/d/
msgid/elasticsearch/7a29f981-232b-43c9-a60d-7306d1bfdf45%
40googlegroups.com
https://groups.google.com/d/msgid/elasticsearch/7a29f981-232b-43c9-a60d-7306d1bfdf45%40googlegroups.com?utm_medium=email&utm_source=footer
.
For more options, visit https://groups.google.com/d/optout.

--
You received this message because you are subscribed to the Google
Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send
an email to elasticsearc...@googlegroups.com.
To view this discussion on the web visit https://groups.google.com/d/
msgid/elasticsearch/CAEM624YoNaXtdwCJXvxMcHRSWunaq
6V7DtFks3Y%2BoYfQWEpLBQ%40mail.gmail.com
https://groups.google.com/d/msgid/elasticsearch/CAEM624YoNaXtdwCJXvxMcHRSWunaq6V7DtFks3Y%2BoYfQWEpLBQ%40mail.gmail.com?utm_medium=email&utm_source=footer
.

For more options, visit https://groups.google.com/d/optout.

--
You received this message because you are subscribed to the Google Groups
"elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an
email to elasticsearch+unsubscribe@googlegroups.com.
To view this discussion on the web visit
https://groups.google.com/d/msgid/elasticsearch/c48aaf92-0592-4987-8e51-cca65e7c354a%40googlegroups.com
https://groups.google.com/d/msgid/elasticsearch/c48aaf92-0592-4987-8e51-cca65e7c354a%40googlegroups.com?utm_medium=email&utm_source=footer
.

For more options, visit https://groups.google.com/d/optout.

--
You received this message because you are subscribed to the Google Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an email to elasticsearch+unsubscribe@googlegroups.com.
To view this discussion on the web visit https://groups.google.com/d/msgid/elasticsearch/CAKdsXoE9ujQsLw%3DT_oKd3KJL6zWjzSGfHbaJjFo5gAF%2B861zpg%40mail.gmail.com.
For more options, visit https://groups.google.com/d/optout.


(Jim Adamson) #9

Permissions on the log directory /var/log/elasticsearch look okay:

drwxr-xr-x 2 elasticsearch elasticsearch 4096 Aug 19 12:50 elasticsearch

Jim

On Tuesday, 19 August 2014 12:41:42 UTC+1, Jörg Prante wrote:

Check if the file permissions are set correctly. If logging system
complains, it can not access files.

Jörg

On Tue, Aug 19, 2014 at 1:28 PM, Jim Adamson <jim.a...@york.ac.uk
<javascript:>> wrote:

Hello again Jörg,

I had a look at this and contrary to what I said in my previous
message /etc/init.d/elasticsearch is configured to run ES as an
unprivileged user:

ES_USER=elasticsearch
ES_GROUP=elasticsearch

That user exists and is a member of that group.

Any further suggestions?

thanks,
Jim

On Friday, 8 August 2014 17:38:03 UTC+1, Jim Adamson wrote:

Hello Jörg!

Thanks for the reply. I was indeed trying to start ES as superuser. I
will try this in a week or so as I am off on leave at the moment.

Jim

On Friday, 8 August 2014 08:37:41 UTC+1, Jörg Prante wrote:

I do not use deb or rpm, but I remember this is an issue when running
ES under superuser privilege.

ES should never (never) run as root, instead a user with minimal
privilege should be created.

Jörg

On Fri, Aug 8, 2014 at 2:21 AM, Mark Walkom ma...@campaignmonitor.com
wrote:

I just tested this and didn't run into the same problem.

Have you changed something locally around your environment variables,
or in the service defaults?

Regards,
Mark Walkom

Infrastructure Engineer
Campaign Monitor
email: ma...@campaignmonitor.com
web: www.campaignmonitor.com

On 8 August 2014 00:34, Jim Adamson jim.a...@york.ac.uk wrote:

I am having a problem running elasticsearch-0.90.11.deb on Ubuntu
12.04.4 LTS (VMWare VM, Intel Xeon @ 2.3Ghz, 2GB RAM). The problem occurs
after I run /etc/init.d/elasticsearch start. Although ES appears to start
successfully, grepping for the process shows it is not running.

Issuing the following:

cd /usr/share/elasticsearch/bin
./elasticsearch -f

...gives:

log4j:WARN No appenders could be found for logger (node).
log4j:WARN Please initialize the log4j system properly.
log4j:WARN See http://logging.apache.org/log4j/1.2/faq.html#noconfig
for more info.

With help from a developer colleague I have managed to get it to run
by adding a suitable log4j.properties file to /usr/share/elasticsearch/bin,
cd-ing to that directory and running ./elasticsearch -f -Dlog4j.configuration=./log4j.properties. However, I'm not sure why
this would have been required in the first place and feel there must be
something misconfigured that's resulting in the init.d script failing to
start ES.

I have tried adding the following to /etc/elasticsearch/elasticsearch.yml
but it doesn't make a difference:

path.conf: /etc/elasticsearch
path.data: /var/lib/elasticsearch
path.work: /tmp/elasticsearch
path.logs: /var/log/elasticsearch

ES is one of the dependencies for some software we are running called
atom, which only support ES < v1. The install instructions are available at
https://www.accesstomemory.org/en/docs/2.0/admin-manual/
installation/linux/#installation-linux.

The version of Java is Oracle’s JVM distributed by Web Upd8:

java -version
java version "1.8.0_11"
Java(TM) SE Runtime Environment (build 1.8.0_11-b12)
Java HotSpot(TM) 64-Bit Server VM (build 25.11-b03, mixed mode)

Thanks for any help you can provide.

Jim

--
You received this message because you are subscribed to the Google
Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it,
send an email to elasticsearc...@googlegroups.com.
To view this discussion on the web visit https://groups.google.com/d/
msgid/elasticsearch/7a29f981-232b-43c9-a60d-7306d1bfdf45%
40googlegroups.com
https://groups.google.com/d/msgid/elasticsearch/7a29f981-232b-43c9-a60d-7306d1bfdf45%40googlegroups.com?utm_medium=email&utm_source=footer
.
For more options, visit https://groups.google.com/d/optout.

--
You received this message because you are subscribed to the Google
Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send
an email to elasticsearc...@googlegroups.com.
To view this discussion on the web visit https://groups.google.com/d/
msgid/elasticsearch/CAEM624YoNaXtdwCJXvxMcHRSWunaq
6V7DtFks3Y%2BoYfQWEpLBQ%40mail.gmail.com
https://groups.google.com/d/msgid/elasticsearch/CAEM624YoNaXtdwCJXvxMcHRSWunaq6V7DtFks3Y%2BoYfQWEpLBQ%40mail.gmail.com?utm_medium=email&utm_source=footer
.

For more options, visit https://groups.google.com/d/optout.

--
You received this message because you are subscribed to the Google Groups
"elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an
email to elasticsearc...@googlegroups.com <javascript:>.
To view this discussion on the web visit
https://groups.google.com/d/msgid/elasticsearch/c48aaf92-0592-4987-8e51-cca65e7c354a%40googlegroups.com
https://groups.google.com/d/msgid/elasticsearch/c48aaf92-0592-4987-8e51-cca65e7c354a%40googlegroups.com?utm_medium=email&utm_source=footer
.

For more options, visit https://groups.google.com/d/optout.

--
You received this message because you are subscribed to the Google Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an email to elasticsearch+unsubscribe@googlegroups.com.
To view this discussion on the web visit https://groups.google.com/d/msgid/elasticsearch/7c0b1818-2323-497b-8a5f-21112bc0ce5f%40googlegroups.com.
For more options, visit https://groups.google.com/d/optout.


(Jim Adamson) #10

Just to say it's all working now :slight_smile: The problem was a directive that was
missing a space after the colon:

script.disable_dynamic:true

Jim

On Tuesday, 19 August 2014 12:53:05 UTC+1, Jim Adamson wrote:

Permissions on the log directory /var/log/elasticsearch look okay:

drwxr-xr-x 2 elasticsearch elasticsearch 4096 Aug 19 12:50
elasticsearch

Jim

On Tuesday, 19 August 2014 12:41:42 UTC+1, Jörg Prante wrote:

Check if the file permissions are set correctly. If logging system
complains, it can not access files.

Jörg

On Tue, Aug 19, 2014 at 1:28 PM, Jim Adamson jim.a...@york.ac.uk wrote:

Hello again Jörg,

I had a look at this and contrary to what I said in my previous
message /etc/init.d/elasticsearch is configured to run ES as an
unprivileged user:

ES_USER=elasticsearch
ES_GROUP=elasticsearch

That user exists and is a member of that group.

Any further suggestions?

thanks,
Jim

On Friday, 8 August 2014 17:38:03 UTC+1, Jim Adamson wrote:

Hello Jörg!

Thanks for the reply. I was indeed trying to start ES as superuser. I
will try this in a week or so as I am off on leave at the moment.

Jim

On Friday, 8 August 2014 08:37:41 UTC+1, Jörg Prante wrote:

I do not use deb or rpm, but I remember this is an issue when running
ES under superuser privilege.

ES should never (never) run as root, instead a user with minimal
privilege should be created.

Jörg

On Fri, Aug 8, 2014 at 2:21 AM, Mark Walkom <ma...@campaignmonitor.com

wrote:

I just tested this and didn't run into the same problem.

Have you changed something locally around your environment variables,
or in the service defaults?

Regards,
Mark Walkom

Infrastructure Engineer
Campaign Monitor
email: ma...@campaignmonitor.com
web: www.campaignmonitor.com

On 8 August 2014 00:34, Jim Adamson jim.a...@york.ac.uk wrote:

I am having a problem running elasticsearch-0.90.11.deb on Ubuntu
12.04.4 LTS (VMWare VM, Intel Xeon @ 2.3Ghz, 2GB RAM). The problem occurs
after I run /etc/init.d/elasticsearch start. Although ES appears to start
successfully, grepping for the process shows it is not running.

Issuing the following:

cd /usr/share/elasticsearch/bin
./elasticsearch -f

...gives:

log4j:WARN No appenders could be found for logger (node).
log4j:WARN Please initialize the log4j system properly.
log4j:WARN See http://logging.apache.org/log4j/1.2/faq.html#noconfig
for more info.

With help from a developer colleague I have managed to get it to run
by adding a suitable log4j.properties file to /usr/share/elasticsearch/bin,
cd-ing to that directory and running ./elasticsearch -f -Dlog4j.configuration=./log4j.properties. However, I'm not sure
why this would have been required in the first place and feel there must be
something misconfigured that's resulting in the init.d script failing to
start ES.

I have tried adding the following to /etc/elasticsearch/elasticsearch.yml
but it doesn't make a difference:

path.conf: /etc/elasticsearch
path.data: /var/lib/elasticsearch
path.work: /tmp/elasticsearch
path.logs: /var/log/elasticsearch

ES is one of the dependencies for some software we are running
called atom, which only support ES < v1. The install instructions are
available at https://www.accesstomemory.
org/en/docs/2.0/admin-manual/installation/linux/#installation-linux.

The version of Java is Oracle’s JVM distributed by Web Upd8:

java -version
java version "1.8.0_11"
Java(TM) SE Runtime Environment (build 1.8.0_11-b12)
Java HotSpot(TM) 64-Bit Server VM (build 25.11-b03, mixed mode)

Thanks for any help you can provide.

Jim

--
You received this message because you are subscribed to the Google
Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it,
send an email to elasticsearc...@googlegroups.com.
To view this discussion on the web visit
https://groups.google.com/d/msgid/elasticsearch/7a29f981-
232b-43c9-a60d-7306d1bfdf45%40googlegroups.com
https://groups.google.com/d/msgid/elasticsearch/7a29f981-232b-43c9-a60d-7306d1bfdf45%40googlegroups.com?utm_medium=email&utm_source=footer
.
For more options, visit https://groups.google.com/d/optout.

--
You received this message because you are subscribed to the Google
Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it,
send an email to elasticsearc...@googlegroups.com.
To view this discussion on the web visit https://groups.google.com/d/
msgid/elasticsearch/CAEM624YoNaXtdwCJXvxMcHRSWunaq
6V7DtFks3Y%2BoYfQWEpLBQ%40mail.gmail.com
https://groups.google.com/d/msgid/elasticsearch/CAEM624YoNaXtdwCJXvxMcHRSWunaq6V7DtFks3Y%2BoYfQWEpLBQ%40mail.gmail.com?utm_medium=email&utm_source=footer
.

For more options, visit https://groups.google.com/d/optout.

--
You received this message because you are subscribed to the Google
Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send
an email to elasticsearc...@googlegroups.com.
To view this discussion on the web visit
https://groups.google.com/d/msgid/elasticsearch/c48aaf92-0592-4987-8e51-cca65e7c354a%40googlegroups.com
https://groups.google.com/d/msgid/elasticsearch/c48aaf92-0592-4987-8e51-cca65e7c354a%40googlegroups.com?utm_medium=email&utm_source=footer
.

For more options, visit https://groups.google.com/d/optout.

--
You received this message because you are subscribed to the Google Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an email to elasticsearch+unsubscribe@googlegroups.com.
To view this discussion on the web visit https://groups.google.com/d/msgid/elasticsearch/438b266f-5d35-49bc-8963-ffc8984f884e%40googlegroups.com.
For more options, visit https://groups.google.com/d/optout.


(system) #11