Elasticsearch-1.7.0 installation in window7


(Aniefiok Stephen Essiet) #1

cant install elasticsearch-1.7.0 in window 7. am having the error in the command prompt: "JAVA_HOME point to an invalid java installation(no java.exe found in C:\program files\java\jdk1.8.0_45\bin)". please i need some help, how can it be solve


(Magnus Bäck) #2

Your JAVA_HOME environment variable points to a path where there is no Java runtime. Make sure you have a Java runtime installed and adjust the JAVA_HOME variable accordingly.


(Aniefiok Stephen Essiet) #3

please, am still having the same error. i have install a java runtime jdk latest version and also jre. may be the steps iam following is not correct.
please, can you give me the step by step procedure to follow and install? it has really stress me for the past 3days. please help me.


(David Pilato) #4

Make sure your JAVA_HOME is set for the user running Elasticsearch or for all users.

printenv (or set) should print all variables. If you don't see the JAVA_HOME fix it.

(JAVA_HOME)\java -version should display the right version.

When this is fixed, if you still have troubles running Elasticsearch, feel free to update this thread.


(Aniefiok Stephen Essiet) #5

i have set the JAVA_HOME properly and when i type in set in the command prompt, it print out all the variables and JAVA_HOME was included.
However, when i type "(JAVA_HOME)\java-version" in the command prompt, i got the response: "\java-version was unexpected at this time".
Then, the error has not change, it's still giving me: "JAVA_HOME point to an invalid java installation(no java.exe found in C:\program files\java\jdk1.8.0_51\bin)". Hence, i can't still install it.


(David Pilato) #6

if you do:

Cd program files\java\jdk1.8.0_51\bin
Java -version

What is happening ?

If it works, might be a recent issue in Elasticsearch.bat

May be you could install java in a dir with no blank or use progra~1 or something (I don't remember what is the short name)


(Aniefiok Stephen Essiet) #7

when i type :"cd Program Files\Java\jdk1.8.0_51\bin ".
its take me into the path properly, but on typing "Java-version", the response is: "Java-version is not recognized as an internal or external command, operable program or batch file"
please what could be the problem?


(Magnus Bäck) #8

The command is java -version, not java-version.


(Aniefiok Stephen Essiet) #9

That has work. the java version is display, java runtime and java hotspot, all d information is display properly.
so, could it be d recent issue in elasticsearch.bat?
Is there any other way to go about it? it's so so important that i install elasticsearch and solve the present problem.
please help me out.
Thank you so very much, so far, i appreciate you.


(Aniefiok Stephen Essiet) #10

i've downloaded a lower version: 1.4.0 and try to install. it when smoothly, but i got stuck at the last part.
These is the procedure, i used:
In the command prompt, i type:
cd
cd program files\elasticsearch-1.4.0\bin
service
service install
but, as it was installing service, it pop up an error: 'C:\program' is not recognized as an internal or external command, operable program or batch file'
failed installing 'elasticsearch-service-x86' service.
Please what can i do?


(Manish R) #11

Hi ,

I am trying to install elastic search on my windows (x64) , i have installed the latest java jdk version in my system and the java -version command shows the latest java version and its details. I have even set the JAVA_HOME system variable . But if i try to install the service using "service install" command. I am getting this exception.

C:\elasticsearch-1.4.4\bin>service install
JAVA_HOME points to an invalid Java installation (no java.exe found in "C:\Progr
am Files\Java\jdk1.8.0_92\bin"). Exiting...

Can anyone help me regarding this? Thanks in advance.


(David Pilato) #12

May be your JAVA_HOME is only set for the current user and not on a system level?
Also, I'd definitely avoid installing JAVA in a dir with space in its name like Program Files.


(Manish R) #13

Hi ,

We have set the JAVA_HOME variable as a System variable only . Would the folder name be an issue in this scenario ? Should we place it in another folder structure without such spaces?


(David Pilato) #14

Oh? You are using a very old version, right?

I know that there have been issues like this in old versions.

May I suggest that you first update to 1.7?


(Manish R) #15

Hi ,

I tried using elastic 5.0.0 from the link
https://www.elastic.co/downloads/elasticsearch

Installed the java (java version "1.8.0_92") and began the process .

I am obtaining the following error in cmd ==>

my java latest version installed
C:\elasticsearch-5.0.0-alpha4\bin>java -version
java version "1.8.0_92"
Java(TM) SE Runtime Environment (build 1.8.0_92-b14)
Java HotSpot(TM) 64-Bit Server VM (build 25.92-b14, mixed mode)

*path value is set
C:\elasticsearch-5.0.0-alpha4\bin>echo %path%
"C:\Java\jdk1.8.0_92\bin"

*JAVA_HOME value is set
C:\elasticsearch-5.0.0-alpha4\bin>echo %JAVA_HOME%
"C:\Java\jdk1.8.0_92\bin"

On trying to install the service
C:\elasticsearch-5.0.0-alpha4\bin>service install
Could not find any executable java binary. Please install java in your PATH or s
et JAVA_HOME

Am I making any mistake? If there is a latest version than this can you provide the link? Thanks.


(David Pilato) #16

JAVA_HOME should not contain bin dir


(Subodh Karwa) #17

I am also facing the same issue while installing ESS 5.2.2

C:\elasticsearch-5.2.2>.\bin\elasticsearch
Could not find any executable java binary. Please install java in your PATH
set JAVA_HOME
Press any key to continue . . .

While, If i type java -version and JAVA_HOME, they just seem to be fine

C:\elasticsearch-5.2.2>java -version
java version "1.8.0_121"
Java(TM) SE Runtime Environment (build 1.8.0_121-b13)
Java HotSpot(TM) 64-Bit Server VM (build 25.121-b13, mixed mode)

C:\elasticsearch-5.2.2>echo %JAVA_HOME%
C:\Program Files\Java\jdk1.8.0_121;


(Subodh Karwa) #18

I modified the elasticsearch.in.bat file as a workaround.

  1. Removed the following lines from the file :slight_smile:

IF NOT EXIST %JAVA% (
ECHO Could not find any executable java binary. Please install java in your PATH or set JAVA_HOME 1>&2
EXIT /B 1
)

  1. Updated " set JAVA="%JAVA_HOME%\bin\java.exe" to exact path

E.g: set JAVA="C:\Program Files\Java\jdk1.8.0_121\bin\java.exe"


(Christian Dahlqvist) #19

Please open a new thread for your issue as it is not related to Elasticsearch 1.7.0 on Windows 7.


(system) #20