Elasticsearch 2.2.4, issue with reindexing

I'm very new to elasticsearch and I just started working on some very old legacy code and the component I'm working on randomly stopped being able to reindex the indexes a couple of weeks ago.

It used to be able to do all the indexes in batches but something changed and now whenever a method is called to fetch all indexes based on a prefix the elasticsearch instance just stalls and nothing happens at all. No error messages or anything.

Before reindexing when I'm ssh'd into the server I can do curl requests towards localhost without any issues but when the reindexing starts any curl requests just stalls just like the reindexing job seems to do. This is before any data is fetched.

This code is where it stops, at .actionGet()

Iterator<String> indicesIt = node.client().admin().indices().prepareGetAliases(getWriteAlias())

Also tried to fetch it by doing a get request to _cat/indexes?h=i&index=name* or something similar with the exact same result of it just stalling.

To me it sounds like a resource problem for the elastic instance, because the server is totally fine resource wise as far as I can tell. The setup is 2 nodes and there should only be 3 indexes (It fails when only reindexing the smallest one too). The 3 indexes consist of userdata for around 60k-100k employees.

Anyone have any ideas? :smiley:


2.2.4 is very very old. It's really urgent that you invest your time in upgrading to 8.9 IMO. You need to upgrade the server and move from the TransportClient to the RestClient.

Do you have a lot of aliases?
It might be the problem here.

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.