Elasticsearch-5.0.0-beta1 be killed


(ugiwgh) #1

[wugh@centos7 elasticsearch-5.0.0-beta1]$ bin/elasticsearch

.......................

[2016-09-23T11:43:54,909][INFO ][o.e.p.PluginsService ] [E6rF1V1] loaded module [aggs-matrix-stats]
[2016-09-23T11:43:54,909][INFO ][o.e.p.PluginsService ] [E6rF1V1] loaded module [ingest-common]
[2016-09-23T11:43:54,909][INFO ][o.e.p.PluginsService ] [E6rF1V1] loaded module [lang-expression]
[2016-09-23T11:43:54,909][INFO ][o.e.p.PluginsService ] [E6rF1V1] loaded module [lang-groovy]
[2016-09-23T11:43:54,910][INFO ][o.e.p.PluginsService ] [E6rF1V1] loaded module [lang-mustache]
[2016-09-23T11:43:54,910][INFO ][o.e.p.PluginsService ] [E6rF1V1] loaded module [lang-painless]
[2016-09-23T11:43:54,910][INFO ][o.e.p.PluginsService ] [E6rF1V1] loaded module [percolator]
[2016-09-23T11:43:54,910][INFO ][o.e.p.PluginsService ] [E6rF1V1] loaded module [reindex]
[2016-09-23T11:43:54,910][INFO ][o.e.p.PluginsService ] [E6rF1V1] loaded module [transport-netty3]
[2016-09-23T11:43:54,910][INFO ][o.e.p.PluginsService ] [E6rF1V1] loaded module [transport-netty4]
[2016-09-23T11:43:54,910][INFO ][o.e.p.PluginsService ] [E6rF1V1] loaded plugin [x-pack]
[2016-09-23T11:44:01,073][INFO ][o.e.n.Node ] [E6rF1V1] initialized
[2016-09-23T11:44:01,073][INFO ][o.e.n.Node ] [E6rF1V1] starting ...
[2016-09-23T11:44:01,688][INFO ][o.e.t.TransportService ] [E6rF1V1] publish_address {127.0.0.1:9300}, bound_addresses {[::1]:9300}, {127.0.0.1:9300}
[2016-09-23T11:44:01,694][WARN ][o.e.b.BootstrapCheck ] [E6rF1V1] max file descriptors [4096] for elasticsearch process likely too low, increase to at least [65536]
[2016-09-23T11:44:01,694][WARN ][o.e.b.BootstrapCheck ] [E6rF1V1] max virtual memory areas vm.max_map_count [65530] likely too low, increase to at least [262144]
[2016-09-23T11:44:04,977][INFO ][o.e.c.s.ClusterService ] [E6rF1V1] new_master {E6rF1V1}{E6rF1V1xQICG4DDWMzJ91g}{CxW8xWBvTaGb3w0JLxiL4g}{127.0.0.1}{127.0.0.1:9300}, reason: zen-disco-elected-as-master ([0] nodes joined)
[2016-09-23T11:44:05,134][INFO ][o.e.h.HttpServer ] [E6rF1V1] publish_address {127.0.0.1:9200}, bound_addresses {[::1]:9200}, {127.0.0.1:9200}
[2016-09-23T11:44:05,134][INFO ][o.e.n.Node ] [E6rF1V1] started
[2016-09-23T11:44:05,671][INFO ][o.e.g.GatewayService ] [E6rF1V1] recovered [1] indices into cluster_state
[2016-09-23T11:44:08,834][INFO ][o.e.c.r.a.AllocationService] [E6rF1V1] Cluster health status changed from [RED] to [YELLOW] (reason: [shards started [[.kibana][0]] ...]).
[2016-09-23T11:44:11,509][INFO ][o.e.c.m.MetaDataCreateIndexService] [E6rF1V1] [.monitoring-es-2-2016.09.23] creating index, cause [auto(bulk api)], templates [.monitoring-es-2], shards [1]/[1], mappings [node, shards, default, index_stats, index_recovery, cluster_state, cluster_stats, indices_stats, node_stats]
[2016-09-23T11:44:11,666][INFO ][o.e.c.m.MetaDataCreateIndexService] [E6rF1V1] [.monitoring-data-2] creating index, cause [auto(bulk api)], templates [.monitoring-data-2], shards [1]/[1], mappings [node, kibana, cluster_info]
[2016-09-23T11:44:12,055][INFO ][o.e.c.m.MetaDataMappingService] [E6rF1V1] [.monitoring-es-2-2016.09.23/k9zJGEinTeyj3IvDBZr_ew] update_mapping [index_stats]
[2016-09-23T11:44:12,158][INFO ][o.e.c.m.MetaDataMappingService] [E6rF1V1] [.monitoring-es-2-2016.09.23/k9zJGEinTeyj3IvDBZr_ew] update_mapping [cluster_stats]
[2016-09-23T11:44:12,304][INFO ][o.e.c.m.MetaDataMappingService] [E6rF1V1] [.monitoring-es-2-2016.09.23/k9zJGEinTeyj3IvDBZr_ew] update_mapping [indices_stats]
[2016-09-23T11:44:12,360][INFO ][o.e.c.m.MetaDataMappingService] [E6rF1V1] [.monitoring-es-2-2016.09.23/k9zJGEinTeyj3IvDBZr_ew] update_mapping [node_stats]
[2016-09-23T11:45:09,386][INFO ][o.e.c.m.MetaDataCreateIndexService] [E6rF1V1] [.monitoring-kibana-2-2016.09.23] creating index, cause [auto(bulk api)], templates [.monitoring-kibana-2], shards [1]/[1], mappings [default, kibana_stats]
Killed


(ugiwgh) #2

[wugh@centos7 elasticsearch-5.0.0-beta1]$ bin/elasticsearch
[2016-09-23T11:43:50,404][INFO ][o.e.n.Node ] [] initializing ...
[2016-09-23T11:43:50,594][INFO ][o.e.e.NodeEnvironment ] [E6rF1V1] using [1] data paths, mounts [[/ (rootfs)]], net usable_space [89.5gb], net total_space [97.4gb], spins? [unknown], types [rootfs]
[2016-09-23T11:43:50,594][INFO ][o.e.e.NodeEnvironment ] [E6rF1V1] heap size [1.9gb], compressed ordinary object pointers [true]
[2016-09-23T11:43:50,601][INFO ][o.e.n.Node ] [E6rF1V1] node name [E6rF1V1] derived from node ID; set [node.name] to override
[2016-09-23T11:43:50,618][INFO ][o.e.n.Node ] [E6rF1V1] version[5.0.0-beta1], pid[10801], build[7eb6260/2016-09-20T23:10:37.942Z], OS[Linux/3.10.0-327.22.2.el7.x86_64/amd64], JVM[Oracle Corporation/OpenJDK 64-Bit Server VM/1.8.0_101/25.101-b13]
[2016-09-23T11:43:54,632][ERROR][o.e.x.s.SSLService ] [E6rF1V1] unsupported ciphers [[TLS_ECDHE_RSA_WITH_AES_128_CBC_SHA256, TLS_ECDHE_ECDSA_WITH_AES_128_CBC_SHA256, TLS_ECDHE_ECDSA_WITH_AES_128_CBC_SHA, TLS_ECDHE_RSA_WITH_AES_128_CBC_SHA]] were requested but cannot be used in this JVM, however there are supported ciphers that will be used [[TLS_RSA_WITH_AES_128_CBC_SHA256, TLS_RSA_WITH_AES_128_CBC_SHA]]. If you are trying to use ciphers with a key length greater than 128 bits on an Oracle JVM, you will need to install the unlimited strength JCE policy files.
[2016-09-23T11:43:54,898][INFO ][o.e.x.s.c.CryptoService ] [E6rF1V1] system key [/opt/elasticsearch-5.0.0-beta1/config/x-pack/system_key] has been loaded

...................


(Daniel Mitterdorfer) #3

Hi @ugiwgh,

hard to tell what's the problem based on these logs. The only thing that jumps out is:

[2016-09-23T11:43:54,632][ERROR][o.e.x.s.SSLService       ] [E6rF1V1] 
unsupported ciphers [[TLS_ECDHE_RSA_WITH_AES_128_CBC_SHA256, 
TLS_ECDHE_ECDSA_WITH_AES_128_CBC_SHA256, 
TLS_ECDHE_ECDSA_WITH_AES_128_CBC_SHA, 
TLS_ECDHE_RSA_WITH_AES_128_CBC_SHA]] were requested but cannot be used 
in this JVM, however there are supported ciphers that will be used 
[[TLS_RSA_WITH_AES_128_CBC_SHA256, TLS_RSA_WITH_AES_128_CBC_SHA]]. If 
you are trying to use ciphers with a key length greater than 128 bits on
 an Oracle JVM, you will need to install the unlimited strength JCE 
policy files.

See http://www.oracle.com/technetwork/java/javase/downloads/jce8-download-2133166.html for more details.

Daniel


(system) #4