Elasticsearch 6.3.1 xpack password enabling shows error


(Rijin) #1

My ELK 6.3.1 working well logs indexed to elasticsearch and these logs are vailable in kibana.

Then i am added this line in elasticsearch.yml as last line

xpack.security.enabled: true

Then tried to create passwords for ELK

./bin/elasticsearch-setup-passwords interactive

Then error message showing

[elastic@localhost elasticsearch-6.3.1]$ ./bin/elasticsearch-setup-passwords interactive

Unexpected response code [403] from calling GET http://192.168.1.15:9200/_xpack/security/_authenticate?pretty
It doesn't look like the X-Pack security feature is available on this Elasticsearch node.
Please check if you have installed a license that allows access to X-Pack Security feature.


(Rijin) #2

Hi It is solved.

In kibana Management-> License Management -> Trail licence selected and enabled.

After that tried this command : ./bin/elasticsearch-setup-passwords interactive

Then its worked and created passwords for ELK

:slight_smile:


(system) #3

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.