Elasticsearch 6.4 xpack password enabling shows error

Path to directory where to store the data (separate multiple locations by comma):

#path.data: /path/to/data

Path to log files:

#path.logs: /path/to/logs

----------------------------------- Memory -----------------------------------

Lock the memory on startup:

#bootstrap.memory_lock: true

Make sure that the heap size is set to about half the memory available

on the system and that the owner of the process is allowed to use this


Elasticsearch performs poorly when the system is swapping the memory.

---------------------------------- Network -----------------------------------

Set the bind address to a specific IP (IPv4 or IPv6):


transport.host: localhost

transport.tcp.port: 9300


Set a custom port for HTTP:

#http.port: 9200

For more information, consult the network module documentation.

--------------------------------- Discovery ----------------------------------

Pass an initial list of hosts to perform discovery when new node is started:

The default list of hosts is ["", "[::1]"]

#discovery.zen.ping.unicast.hosts: ["host1", "host2"]

Prevent the "split brain" by configuring the majority of nodes (total number of master-eligible nodes / 2 + 1):


For more information, consult the zen discovery module documentation.

---------------------------------- Gateway -----------------------------------

Block initial recovery after a full cluster restart until N nodes are started:

#gateway.recover_after_nodes: 3

For more information, consult the gateway module documentation.

---------------------------------- Various -----------------------------------

Require explicit names when deleting indices:

#action.destructive_requires_name: true

xpack.security.enabled: true

Please don't post unformatted code, logs, or configuration as it's very hard to read.

Instead, paste the text and format it with </> icon or pairs of triple backticks (```), and check the preview window to make sure it's properly formatted before posting it. This makes it more likely that your question will receive a useful answer.

It would be great if you could update your post to solve this.

Also, you need to be more clear with regards to what the problem actually is. You just pasted your elasticsearch.yml file with no other information.

What do you intend to do ?
What did you expect would happen ?
What happened instead?
If there is an error, what exactly is the error ?

Sorry for bad way asking the question.
The question is in ES 6.4 , if i tried to run the password set command i.e,
elasticsearch-setup-passwords interactive
I am getting error saying xpack security is not able to call in ES even though i haved enable xpack pack security in config file.

Later I found the problem is I have started ES and kibana both So because of this I got error. only ES should be started and So once I closed the kibana and I ran above command to set password, later it start working.

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.