Elasticsearch 6.6.0 geo_shape query on old documents not working after upgrade

Hi, I just tried to upgrade from elasticsearch 6.2.3 to elasticsearch 6.6.0.

After upgrade i find that i get no hits of older documents when using geo_shape query.

I get a match for documents created after upgrade.

The index is still version 6.2.3. And the shape is mapped with:
"shape" : {
"type" : "geo_shape",
"tree_levels" : 9,
"points_only" : true

I've tried many different geo_shape queries but no one seems to get a hit. And there's no error in my elasticsearch log.

I realize that one solution would be to reindex all indices but can't afford the downtime it would require in production.

Looks like a bug to me.


1 Like

Exact same issue for me after upgrading from 6.5.4 to 6.6.0 on ES Cloud.

Moreover, it is not clear from the 6.6 breaking changes what needs to be done to make pre-6.6. shapes compatible with 6.6.

Please advise.

1 Like

I've asked someone to look at this, but it might also be worth raising an issue on GtitHub as well :slight_smile:

1 Like

Thank you Mark, much appreciated.

The issue is here: https://github.com/elastic/elasticsearch/issues/38494


This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.