Elasticsearch 7.1.0 crash with bootstrap checks failed

I tried to run elasticsearch docker image from private repository, but its getting crash with ERROR: [1] bootstrap checks failed.

I found "bootstrap check should be enabled "Des.enforce.bootstrap.checks=true" in elastic website. but i'm not clear how to enable it where to enable it.

Can i get any examples to enable it ?

You are not sharing the logs so I can't tell exactly what you have to fix, but at least just read https://www.elastic.co/guide/en/elasticsearch/reference/current/bootstrap-checks.html

Thanks.

I saw same already, but I'm not clear where i have to edit .

i used " docker run -p 9200:9200 -p 9300:9300 --name=app_name -d --network=mynetwork image_repo"

Log :
{"type": "server", "timestamp": "2019-07-12T06:28:09,486+0000", "level": "INFO", "component": "o.e.b.BootstrapChecks", "cluster.name": "docker-cluster", "node.name": "830a46f1111", "message": "bound or publishing to a non-loopback address, enforcing bootstrap checks" }
ERROR: [1] bootstrap checks failed

The important log lines are the next ones.

Please format your code, logs or configuration files using </> icon as explained in this guide and not the citation button. It will make your post more readable.

Or use markdown style like:

```
CODE
```

This is the icon to use if you are not using markdown format:

There's a live preview panel for exactly this reasons.

Lots of people read these forums, and many of them will simply skip over a post that is difficult to read, because it's just too large an investment of their time to try and follow a wall of badly formatted text.
If your goal is to get an answer to your questions, it's in your interest to make it as easy to read and understand as possible.

log:

{"type": "server", "timestamp": "2019-07-12T06:28:09,486+0000", "level": "INFO", "component": "o.e.b.BootstrapChecks", "cluster.name": "docker-cluster", "node.name": "830a46f1cbd4",  "message": "bound or publishing to a non-loopback address, enforcing bootstrap checks"  }
ERROR: [1] bootstrap checks failed
[1]: the default discovery settings are unsuitable for production use; at least one of [discovery.seed_hosts, discovery.seed_providers, cluster.initial_master_nodes] must be configured
{"type": "server", "timestamp": "2019-07-12T06:28:09,505+0000", "level": "INFO", "component": "o.e.n.Node", "cluster.name": "docker-cluster", "node.name": "830a46f1cbd4",  "message": "stopping ..."  }

Please read https://www.elastic.co/guide/en/elasticsearch/reference/current/bootstrap-checks.html

Thanks,
It works after adding "discovery.seed_hosts : 127.0.0.1:9300" in eleasticsearch.yml file.