Elasticsearch 7.8.1 not writing to ilm-history-*


Elasticsearch is not writing to ilm-history-* in v. 7.8.1, but indices rolling over as expected.


I'm using ILM in Elasticsearch 7.8.1. Indices are rolling over, as expected, but Elasticsearch isn't writing to the ilm-history-* indices, as expected. I've specifically set indices.lifecycle.history_index_enabled: true, but haven't had any luck. I'm not seeing any issues in the log (i.e., no references to the ilm-history-* indices in the log at all, such as "unable to create").

The last entry written to the ilm-history-* indices was on June 30, which would be right around the time I upgraded to 7.8.0.


Aug. 25, 2020, 11:07 +05:00

In a follow-up to the previous update, in my test environment, I updated the settings on the ilm-history-2-* indices to hidden: false, and also updated the template settings to hidden: false. I'm now able to view the indices using the kibana index pattern ilm-history-*.

My updated question is now: Is this likely to create any issues? Is there a good reason why ilm-history-* is or should be hidden, and therefore not viewable with Kibana index pattern?

Aug. 25, 2020, 10:52 +05:00

I found this issue, which prompted me to do some further searching. It appears that the ILM indices are there under ilm-history-2-*, rather than ilm-history-1-*. However, the indices are now marked as hidden: true, and I don't seem to be able to view them from Kibana.

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.