ElasticSearch 7 APT repository - hash sum mismatch


Since 31th March 2020, install from https://artifacts.elastic.co/packages/7.x/apt stable/main amd64 elasticsearch amd64 7.6.2 doesn't work because of hash sum mismatch.
Problem is for multiple DEB packets. I tested 'elasticsearch' and 'kibana' on fresh Debian 10 install.

Example for 'elasticsearch' :
Hashes of expected file:

  • SHA512:5a86d49bc184bea4f73380bc95633d60439af6d4152605c12f5b1edb251593e1fe22af91595498708bc66890b4b6dcd283397736a2ecfce32ccbbbb3ee38ce19
  • SHA256:6ef2b0ed7844ed70d739216570b9479642b962c0e042ce24a02af0e3f5f6ced8
  • SHA1:af0d8f036640c12faad0f1b99a9c36fee22b2e78 [weak]
  • MD5Sum:91eac9aa06272ab6a6cfbf2e14ccea6c [weak]
  • Filesize:296520940 [weak]
    Hashes of received file:
  • SHA512:83c90f3bacb4e4961c7c5f2fa95f6733b510bd7da3141ed5c71c5a2ff0bb533e2e5eb4b2e8772638c25d32dda0b30b13515ba961959bd8dd91333e88b71e75bd
  • SHA256:97ba4c1ec3936e9b55203e52ed711c2764641cf69893d40d41e4c8d42a0fe44c
  • SHA1:c80efc831cc361c551b76480c14891c385123b3d [weak]
  • MD5Sum:dd0b38cf6fe7f1e99864cf4f23fba577 [weak]
  • Filesize:296520940 [weak]
    Last modification reported: Tue, 31 Mar 2020 15:29:22 +0000

I tried multiple update from apt but hash are always the same.
Is there a problem with repository ?

Thanks in advance for your help.


I just tested under a debian 10/buster VM and it worked for me. Can you give me any more tips for debugging?

I just followed the manual download steps at https://www.elastic.co/guide/en/elasticsearch/reference/7.6/deb.html#install-deb

and comparing the checksums turned out fine.

Can you do that on your local system as well?




Thanks for your answer. I can't test for now but I will as soon as possible.
I can't give you more tips because, to be honest, I don't understand why I had sum mismatch. I followed every steps (from repository or manual install) but nothing worked.

Thanks again.

I'm having the same issue. Currently trying to download elasticsearch on Ubuntu inside a VirtualBox VM.

When I try the apt-get standard process (https://www.elastic.co/guide/en/elasticsearch/reference/current/deb.html) it always returns the hash mismatch error, for which I tried clearing the content from the lists directory:
apt-get clear
sudo rm -rf /var/lib/apt/lists/*
apt-get clear
apt-get update
apt-get upgrade
-retried -> same error
Also tried re-installing my VM from scratch: same issue.
Also tried disabling firewall both on my PC and on the VM: same issue.
Manual deb install ((https://www.elastic.co/guide/en/elasticsearch/reference/7.6/deb.html#install-deb) returns the following:
dpkg: error processing archive elasticsearch-7.5.2-amd64.deb (--install):
corrupted filesystem tarfile - corrupted package archive
dpkg-deb: error: paste subprocess was killed by signal

I saw somewhere that this may be a java issue; so I installed default java package ... retried ... same issue.

I've also tried using gdebi, I get dpkg: error processing archive elasticsearch-7.6.2-amd64.deb (--install):
dpkg-deb --fsys-tarfile subprocess returned error exit status 2


I tried again and still facing same issue (Debian 10 VirtualBox 6.1 VM).
Same problem described by fredyfredburger.

Impossible to install elasticsearch or kibana for me.

1 Like

I am having the same issue when trying to follow along with the video course on Manning Publications Elasticsearch 7 and Elastic Stack by Frank Kane

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.