Elasticsearch adds one more shard when on index creation

Hi,
I have a problem with one node cluster. When i create index with 10 shards,
it adds one more active shard. First i thought that it is replica shard,
but than i read that there is no replica on single node cluster. Is this
some problem in settings or it is normal?

Thanks

--
You received this message because you are subscribed to the Google Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an email to elasticsearch+unsubscribe@googlegroups.com.
To view this discussion on the web visit https://groups.google.com/d/msgid/elasticsearch/e2493064-3113-41c9-8c89-9eb3509c2ff1%40googlegroups.com.
For more options, visit https://groups.google.com/d/optout.

Did you specify the replica count as well as the shard count? By default ES
will add a replica unless you specifically tell it not to.
You can check this using the _cat APIs
http://www.elasticsearch.org/guide/en/elasticsearch/reference/current/cat.html#cat

Also 10 shards is a bit of overkill for a single node, unless you are
intending on extending the cluster to more nodes of course.

On 5 December 2014 at 10:42, Marko Krstic markokrstic90@gmail.com wrote:

Hi,
I have a problem with one node cluster. When i create index with 10
shards, it adds one more active shard. First i thought that it is replica
shard, but than i read that there is no replica on single node cluster. Is
this some problem in settings or it is normal?

Thanks

--
You received this message because you are subscribed to the Google Groups
"elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an
email to elasticsearch+unsubscribe@googlegroups.com.
To view this discussion on the web visit
https://groups.google.com/d/msgid/elasticsearch/e2493064-3113-41c9-8c89-9eb3509c2ff1%40googlegroups.com
https://groups.google.com/d/msgid/elasticsearch/e2493064-3113-41c9-8c89-9eb3509c2ff1%40googlegroups.com?utm_medium=email&utm_source=footer
.
For more options, visit https://groups.google.com/d/optout.

--
You received this message because you are subscribed to the Google Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an email to elasticsearch+unsubscribe@googlegroups.com.
To view this discussion on the web visit https://groups.google.com/d/msgid/elasticsearch/CAEYi1X9BYb3SmPJ%3Duh8u3s%2B-Pmz1zrJ%2BKmbDAjp74iJAJbNm_A%40mail.gmail.com.
For more options, visit https://groups.google.com/d/optout.