ElasticSearch and Firewall for dataless nodes


(Carofe) #1

Hi,

I see that dataless nodes they not only connect to data nodes on port 9300
but also they are listening on port 9300 on their machine too.
Should I configure the firewall to allow incoming traffic to dataless nodes
on port 9300? Is that a requirement to make the cluster work correctly?

Thanks,
C.

--
You received this message because you are subscribed to the Google Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an email to elasticsearch+unsubscribe@googlegroups.com.
For more options, visit https://groups.google.com/groups/opt_out.


(Alexander Reelsen) #2

Hey,

all nodes must be able to communicate via port 9300 - which is the port
used for internal cluster communication.
Can you elaborate a bit on your setup? Just wondering, if your dataless
nodes (client nodes I guess?) are not in the same network?

--Alex

On Thu, Sep 26, 2013 at 12:51 AM, Carofe carlosrodrifernandez@gmail.comwrote:

Hi,

I see that dataless nodes they not only connect to data nodes on port 9300
but also they are listening on port 9300 on their machine too.
Should I configure the firewall to allow incoming traffic to dataless
nodes on port 9300? Is that a requirement to make the cluster work
correctly?

Thanks,
C.

--
You received this message because you are subscribed to the Google Groups
"elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an
email to elasticsearch+unsubscribe@googlegroups.com.
For more options, visit https://groups.google.com/groups/opt_out.

--
You received this message because you are subscribed to the Google Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an email to elasticsearch+unsubscribe@googlegroups.com.
For more options, visit https://groups.google.com/groups/opt_out.


(Carofe) #3

Thanks alexander!

On Thursday, October 3, 2013 9:19:45 AM UTC-7, Alexander Reelsen wrote:

Hey,

all nodes must be able to communicate via port 9300 - which is the port
used for internal cluster communication.
Can you elaborate a bit on your setup? Just wondering, if your dataless
nodes (client nodes I guess?) are not in the same network?

--Alex

On Thu, Sep 26, 2013 at 12:51 AM, Carofe <carlosrodr...@gmail.com<javascript:>

wrote:

Hi,

I see that dataless nodes they not only connect to data nodes on port
9300 but also they are listening on port 9300 on their machine too.
Should I configure the firewall to allow incoming traffic to dataless
nodes on port 9300? Is that a requirement to make the cluster work
correctly?

Thanks,
C.

--
You received this message because you are subscribed to the Google Groups
"elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an
email to elasticsearc...@googlegroups.com <javascript:>.
For more options, visit https://groups.google.com/groups/opt_out.

--
You received this message because you are subscribed to the Google Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an email to elasticsearch+unsubscribe@googlegroups.com.
For more options, visit https://groups.google.com/groups/opt_out.


(system) #4