TransportClient accessing Cluster via single port


(FFA) #1

Multinode ES cluster is behind the firewall. I am using Java API
TransportClient to query the ES.

I have a simple question:
Do I have to open all ports 9300-9400 on firewall to be able to access ES
with TC? Is there ES settings that would allow me to open only let's say
port 9300 on firewall and reliably get the query results back?

Thanks,

Fred.

--
You received this message because you are subscribed to the Google Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an email to elasticsearch+unsubscribe@googlegroups.com.
To view this discussion on the web visit https://groups.google.com/d/msgid/elasticsearch/043d3612-e774-4bff-b6b9-1162f12b2b42%40googlegroups.com.
For more options, visit https://groups.google.com/groups/opt_out.


(David Pilato) #2

Just set transport port in elasticsearch.yml.
But you can stay with defaults. As long as you start only one node, only 9300 needs to be opened.

--
David :wink:
Twitter : @dadoonet / @elasticsearchfr / @scrutmydocs

Le 21 févr. 2014 à 23:10, FFA ffaliev@gmail.com a écrit :

Multinode ES cluster is behind the firewall. I am using Java API TransportClient to query the ES.

I have a simple question:
Do I have to open all ports 9300-9400 on firewall to be able to access ES with TC? Is there ES settings that would allow me to open only let's say port 9300 on firewall and reliably get the query results back?

Thanks,

Fred.

You received this message because you are subscribed to the Google Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an email to elasticsearch+unsubscribe@googlegroups.com.
To view this discussion on the web visit https://groups.google.com/d/msgid/elasticsearch/043d3612-e774-4bff-b6b9-1162f12b2b42%40googlegroups.com.
For more options, visit https://groups.google.com/groups/opt_out.

--
You received this message because you are subscribed to the Google Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an email to elasticsearch+unsubscribe@googlegroups.com.
To view this discussion on the web visit https://groups.google.com/d/msgid/elasticsearch/BBA70142-441A-45EA-86AA-F47451BD4010%40pilato.fr.
For more options, visit https://groups.google.com/groups/opt_out.


(FFA) #3

Thank you. But what if multiple nodes have to be started to balance the
load?

Regards,

FFA

On Friday, February 21, 2014 8:50:19 PM UTC-6, David Pilato wrote:

Just set transport port in elasticsearch.yml.
But you can stay with defaults. As long as you start only one node, only
9300 needs to be opened.

--
David :wink:
Twitter : @dadoonet / @elasticsearchfr / @scrutmydocs

Le 21 févr. 2014 à 23:10, FFA <ffa...@gmail.com <javascript:>> a écrit :

Multinode ES cluster is behind the firewall. I am using Java API
TransportClient to query the ES.

I have a simple question:
Do I have to open all ports 9300-9400 on firewall to be able to access ES
with TC? Is there ES settings that would allow me to open only let's say
port 9300 on firewall and reliably get the query results back?

Thanks,

Fred.

--
You received this message because you are subscribed to the Google Groups
"elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an
email to elasticsearc...@googlegroups.com <javascript:>.
To view this discussion on the web visit
https://groups.google.com/d/msgid/elasticsearch/043d3612-e774-4bff-b6b9-1162f12b2b42%40googlegroups.com
.
For more options, visit https://groups.google.com/groups/opt_out.

--
You received this message because you are subscribed to the Google Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an email to elasticsearch+unsubscribe@googlegroups.com.
To view this discussion on the web visit https://groups.google.com/d/msgid/elasticsearch/670ea0ce-237b-40d2-a6c3-68070a2171e5%40googlegroups.com.
For more options, visit https://groups.google.com/groups/opt_out.


(hari) #4

you define your custom ports for additional nodes by
setting transport.tcp.port and http.port in elasticsearch.yml
and accordingly punch firewall rules only for those ports.

On Monday, February 24, 2014 8:56:31 AM UTC-6, FFA wrote:

Thank you. But what if multiple nodes have to be started to balance the
load?

Regards,

FFA

On Friday, February 21, 2014 8:50:19 PM UTC-6, David Pilato wrote:

Just set transport port in elasticsearch.yml.
But you can stay with defaults. As long as you start only one node, only
9300 needs to be opened.

--
David :wink:
Twitter : @dadoonet / @elasticsearchfr / @scrutmydocs

Le 21 févr. 2014 à 23:10, FFA ffa...@gmail.com a écrit :

Multinode ES cluster is behind the firewall. I am using Java API
TransportClient to query the ES.

I have a simple question:
Do I have to open all ports 9300-9400 on firewall to be able to access
ES with TC? Is there ES settings that would allow me to open only let's say
port 9300 on firewall and reliably get the query results back?

Thanks,

Fred.

--
You received this message because you are subscribed to the Google Groups
"elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an
email to elasticsearc...@googlegroups.com.
To view this discussion on the web visit
https://groups.google.com/d/msgid/elasticsearch/043d3612-e774-4bff-b6b9-1162f12b2b42%40googlegroups.com
.
For more options, visit https://groups.google.com/groups/opt_out.

--
You received this message because you are subscribed to the Google Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an email to elasticsearch+unsubscribe@googlegroups.com.
To view this discussion on the web visit https://groups.google.com/d/msgid/elasticsearch/2084b089-9f49-490d-8326-a50d161e42bf%40googlegroups.com.
For more options, visit https://groups.google.com/groups/opt_out.


(system) #5