Elasticsearch asking to authenticate with no security on a basic licence

Hi, I've downloaded an elasticsearch zip, have no licence setup and have explicitly set xpack.security.enabled: false

When I startup elasticsearch on a localhost, it is asking for me to login, I try to use the default elastic user and changeme password but it's not accepting it.

Some output from the startup shows a few things, it's asking me to set security to false, which it is, and it's saying that xpath security is installed, which it isn't.

[2019-07-31T10:15:30,332][INFO ][o.e.p.PluginsService     ] [MYSERVER] no plugins loaded
[2019-07-31T10:15:33,715][INFO ][o.e.x.s.a.s.FileRolesStore] [MYSERVER] parsed [0] roles from file [C:\ProgramData\Elastic\Elasticsearch\config\roles.yml]
[2019-07-31T10:15:34,400][INFO ][o.e.x.m.p.l.CppLogMessageHandler] [MYSERVER] [controller/1652] [Main.cc@110] controller (64 bit): Version 7.2.1 (Build 4ad685337be7fd) Copyright (c) 2019 Elasticsearch BV
[2019-07-31T10:15:34,832][DEBUG][o.e.a.ActionModule       ] [MYSERVER] Using REST wrapper from plugin org.elasticsearch.xpack.security.Security
[2019-07-31T10:15:35,090][INFO ][o.e.d.DiscoveryModule    ] [MYSERVER] using discovery type [zen] and seed hosts providers [settings]
[2019-07-31T10:15:35,766][INFO ][o.e.n.Node               ] [MYSERVER] initialized
[2019-07-31T10:15:35,766][INFO ][o.e.n.Node               ] [MYSERVER] starting ...
[2019-07-31T10:15:35,967][INFO ][o.e.t.TransportService   ] [MYSERVER] publish_address {127.0.0.1:9300}, bound_addresses {127.0.0.1:9300}, {[::1]:9300}
[2019-07-31T10:15:35,992][WARN ][o.e.b.BootstrapChecks    ] [MYSERVER] the default discovery settings are unsuitable for production use; at least one of [discovery.seed_hosts, discovery.seed_providers, cluster.initial_master_nodes] must be configured
[2019-07-31T10:15:35,993][WARN ][o.e.b.BootstrapChecks    ] [MYSERVER] Transport SSL must be enabled if security is enabled on a [basic] license. Please set [xpack.security.transport.ssl.enabled] to [true] or disable security by setting [xpack.security.enabled] to [f
alse]
[2019-07-31T10:15:36,002][INFO ][o.e.c.c.Coordinator      ] [MYSERVER] cluster UUID [kiuQbPz9RKmr-2Tm6_on-g]
[2019-07-31T10:15:36,051][INFO ][o.e.c.c.ClusterBootstrapService] [MYSERVER] no discovery configuration found, will perform best-effort cluster bootstrapping after [3s] unless existing master is discovered
[2019-07-31T10:15:36,189][INFO ][o.e.c.s.MasterService    ] [MYSERVER] elected-as-master ([1] nodes joined)[{MYSERVER}{LiN8XEXuSNmP9nZYtk6rnw}{Hky53ZPDTLun1gxsBZKmKQ}{127.0.0.1}{127.0.0.1:9300}{ml.machine_memory=17179398144, xpack.installed=true, ml.max_open_jobs
=20} elect leader, _BECOME_MASTER_TASK_, _FINISH_ELECTION_], term: 13, version: 49, reason: master node changed {previous [], current [{MYSERVER}{LiN8XEXuSNmP9nZYtk6rnw}{Hky53ZPDTLun1gxsBZKmKQ}{127.0.0.1}{127.0.0.1:9300}{ml.machine_memory=17179398144, xpack.installed
=true, ml.max_open_jobs=20}]}
[2019-07-31T10:15:36,236][INFO ][o.e.c.s.ClusterApplierService] [MYSERVER] master node changed {previous [], current [{MYSERVER}{LiN8XEXuSNmP9nZYtk6rnw}{Hky53ZPDTLun1gxsBZKmKQ}{127.0.0.1}{127.0.0.1:9300}{ml.machine_memory=17179398144, xpack.installed=true, ml.max
_open_jobs=20}]}, term: 13, version: 49, reason: Publication{term=13, version=49}
[2019-07-31T10:15:36,298][INFO ][o.e.h.AbstractHttpServerTransport] [MYSERVER] publish_address {127.0.0.1:9200}, bound_addresses {127.0.0.1:9200}, {[::1]:9200}
[2019-07-31T10:15:36,298][INFO ][o.e.n.Node               ] [MYSERVER] started
[2019-07-31T10:15:36,439][INFO ][o.e.l.LicenseService     ] [MYSERVER] license [9f873e1a-48fd-4fb0-9821-5fc4f0cc37df] mode [basic] - valid

I was able to solve the issue, it's confusing to me though, I'm running elasticsearch from an extracted zip file, so I have my config files in there, however in the jvm args I noticed that it wasn't looking at that location for the config file, it was looking for one that it had created itself in a different directory.