Elasticsearch -Azure Repository - stopped working suddenly

Azure snapshots suddenly started failing with Gateway error. It was working fine for longer time, but stopped with below error. Got this error on _cat snapshots.

"statusCode": 504,
"error": "Gateway Time-out",
"message": "Client request timeout"

Tried to access the storage account using curl/SAS from the master node explicitly and it do access without issues.

When I issue _verify again, it fails as below from the master node , and against cluster it gives gateway error as above.

............ERROR when I ssh into master and issue _verify explicitly against the node.....................
{"error":{"root_cause":[{"type":"repository_verification_exception","reason":"[......] path [snapshots] is not accessible on master node"}],"type":"repository_verification_exception","reason":"[....] path [snapshots] is not accessible on master node","caused_by":{"type":"i_o_exception","reason":"Can not write blob master.dat-temp","caused_by":{"type":"storage_exception","reason":"Operation could not be completed within the specified time."}}},"status":500}

Tried to see which key it is using to access Azure, but it is in keystore so not sure how to get the value. Tried to base64 decode on the Auth header but not sure if it is right approach as the encryption logic may be diff :slight_smile:

Any guidance would be helpful.

Not getting gatework timeout on _cat now, instead getting empty result. BUt still getting repository verification error. Not sure of the reason. Ensured that the storage account exists..

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.