Elasticsearch ca certificate problem

Hi guys;

I have a wazuh server with running filebeat and Elasticsearch. When i am trying to establish a connection from remote filebeat to my Elasticsearch i am getting "Exiting: error loading config file: yaml: line 139: did not find expected key" error. I tried to solve this problem with some answers from community but i couldnt get the ca_trusted_fingerprint and i do not now how to get it

Can anyone help me :slight_smile:

P.S: I tried below solution but as i said i could not get ca fingerprint.

When you start Elasticsearch for the first time it will log the value for ca_trusted_fingerprint .

If the auto-configuration process has already completed, you can follow those steps to get the CA fingerprint

and i tried this link but still no luck

And this is my Elasticsearch.yml file

output.elasticsearch.hosts: ["10.72.81.11:9200"]
username: "wazuh"
password: "password"
  # Protocol - either `http` (default) or `https`.
  protocol: "https"
ssl:
enabled: true
ca_trusted_fingerprint: ????

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.