Elasticsearch Cluster - Non-Master Node Doesn't Join the Intended Cluster


(Indra Suryanata) #1

I am a beginner on Elasticsearch.
I have Logstash/Elasticsearch/Kibana running in HP Cloud.
This is the master node.

I tried to have at least another node (also in HP Cloud) to set up an
Elasticsearch cluster.
However, I found the non-master node still doesn’t join the intended
cluster.

My setup is the following:
Master Node
elasticsearch 0.90.3
logstash 1.2.2
kibana 3.0.0milestone4
In /etc/elasticsearch/elasticsearch.yml:
cluster.name: ls_cluster
node.name: logstash1

Non-Master Node
elasticsearch 0.90.3
logstash 1.2.2
kibana 3.0.0milestone4
In /etc/elasticsearch/elasticsearch.yml:
cluster.name: ls_cluster
node.name: logstash2

I also tried changing the following on the non-master node, but it didn’t
make any difference.
node.master: false
node.data: true
transport.tcp.port: 9301
http.port: 9201

The same result with using elasticsearch 0.90.9 & logstash 1.3.3.

Any help is appreciated, thanks!

--
You received this message because you are subscribed to the Google Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an email to elasticsearch+unsubscribe@googlegroups.com.
To view this discussion on the web visit https://groups.google.com/d/msgid/elasticsearch/be40c6b9-4fe5-45ca-b19f-69eadb00a1ae%40googlegroups.com.
For more options, visit https://groups.google.com/groups/opt_out.


(Mark Walkom) #2

What is your zen discovery method?
http://www.elasticsearch.org/guide/en/elasticsearch/reference/current/modules-discovery-zen.html

Regards,
Mark Walkom

Infrastructure Engineer
Campaign Monitor
email: markw@campaignmonitor.com
web: www.campaignmonitor.com

On 1 February 2014 10:39, Indra Suryanata insury@gmail.com wrote:

I am a beginner on Elasticsearch.
I have Logstash/Elasticsearch/Kibana running in HP Cloud.
This is the master node.

I tried to have at least another node (also in HP Cloud) to set up an
Elasticsearch cluster.
However, I found the non-master node still doesn't join the intended
cluster.

My setup is the following:
Master Node
elasticsearch 0.90.3
logstash 1.2.2
kibana 3.0.0milestone4
In /etc/elasticsearch/elasticsearch.yml:
cluster.name: ls_cluster
node.name: logstash1

Non-Master Node
elasticsearch 0.90.3
logstash 1.2.2
kibana 3.0.0milestone4
In /etc/elasticsearch/elasticsearch.yml:
cluster.name: ls_cluster
node.name: logstash2

I also tried changing the following on the non-master node, but it didn't
make any difference.
node.master: false
node.data: true
transport.tcp.port: 9301
http.port: 9201

The same result with using elasticsearch 0.90.9 & logstash 1.3.3.

Any help is appreciated, thanks!

--
You received this message because you are subscribed to the Google Groups
"elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an
email to elasticsearch+unsubscribe@googlegroups.com.
To view this discussion on the web visit
https://groups.google.com/d/msgid/elasticsearch/be40c6b9-4fe5-45ca-b19f-69eadb00a1ae%40googlegroups.com
.
For more options, visit https://groups.google.com/groups/opt_out.

--
You received this message because you are subscribed to the Google Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an email to elasticsearch+unsubscribe@googlegroups.com.
To view this discussion on the web visit https://groups.google.com/d/msgid/elasticsearch/CAEM624ZbVR0YqFZbEfvyUV5P6SL%2BD8sMhSZWKNRnZxffuhXMag%40mail.gmail.com.
For more options, visit https://groups.google.com/groups/opt_out.


(Indra Suryanata) #3

Hi Mark,

I didn't set anything in the zen discovery method.
Should I set it to

network.host:

discovery.zen.ping.unicast.hosts:

in both elasticsearch.yml of the Master Node & Non-Master Node?

Thanks!

Regards,
Indra

On Friday, January 31, 2014 3:41:02 PM UTC-8, Mark Walkom wrote:

What is your zen discovery method?
http://www.elasticsearch.org/guide/en/elasticsearch/reference/current/modules-discovery-zen.html

Regards,
Mark Walkom

Infrastructure Engineer
Campaign Monitor
email: ma...@campaignmonitor.com <javascript:>
web: www.campaignmonitor.com

On 1 February 2014 10:39, Indra Suryanata <ins...@gmail.com <javascript:>>wrote:

I am a beginner on Elasticsearch.
I have Logstash/Elasticsearch/Kibana running in HP Cloud.
This is the master node.

I tried to have at least another node (also in HP Cloud) to set up an
Elasticsearch cluster.
However, I found the non-master node still doesn’t join the intended
cluster.

My setup is the following:
Master Node
elasticsearch 0.90.3
logstash 1.2.2
kibana 3.0.0milestone4
In /etc/elasticsearch/elasticsearch.yml:
cluster.name: ls_cluster
node.name: logstash1

Non-Master Node
elasticsearch 0.90.3
logstash 1.2.2
kibana 3.0.0milestone4
In /etc/elasticsearch/elasticsearch.yml:
cluster.name: ls_cluster
node.name: logstash2

I also tried changing the following on the non-master node, but it didn’t
make any difference.
node.master: false
node.data: true
transport.tcp.port: 9301
http.port: 9201

The same result with using elasticsearch 0.90.9 & logstash 1.3.3.

Any help is appreciated, thanks!

--
You received this message because you are subscribed to the Google Groups
"elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an
email to elasticsearc...@googlegroups.com <javascript:>.
To view this discussion on the web visit
https://groups.google.com/d/msgid/elasticsearch/be40c6b9-4fe5-45ca-b19f-69eadb00a1ae%40googlegroups.com
.
For more options, visit https://groups.google.com/groups/opt_out.

--
You received this message because you are subscribed to the Google Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an email to elasticsearch+unsubscribe@googlegroups.com.
To view this discussion on the web visit https://groups.google.com/d/msgid/elasticsearch/ccf83335-cc8e-4cef-b602-ffaf4f683c58%40googlegroups.com.
For more options, visit https://groups.google.com/groups/opt_out.


(Mark Walkom) #4

network.host is the IP that the node itself will listen on when advertising
the service, so if you set that to the master node IP then each node will
try and listen on that same IP. Which is not what you want.

You want to set;
discovery.zen.ping.unicast: $IP_OF_MASTER

Regards,
Mark Walkom

Infrastructure Engineer
Campaign Monitor
email: markw@campaignmonitor.com
web: www.campaignmonitor.com

On 1 February 2014 11:00, Indra Suryanata insury@gmail.com wrote:

Hi Mark,

I didn't set anything in the zen discovery method.
Should I set it to

network.host:

discovery.zen.ping.unicast.hosts:

in both elasticsearch.yml of the Master Node & Non-Master Node?

Thanks!

Regards,
Indra

On Friday, January 31, 2014 3:41:02 PM UTC-8, Mark Walkom wrote:

What is your zen discovery method? http://www.elasticsearch.org/guide/en/
elasticsearch/reference/current/modules-discovery-zen.html

Regards,
Mark Walkom

Infrastructure Engineer
Campaign Monitor
email: ma...@campaignmonitor.com
web: www.campaignmonitor.com

On 1 February 2014 10:39, Indra Suryanata ins...@gmail.com wrote:

I am a beginner on Elasticsearch.
I have Logstash/Elasticsearch/Kibana running in HP Cloud.
This is the master node.

I tried to have at least another node (also in HP Cloud) to set up an
Elasticsearch cluster.
However, I found the non-master node still doesn't join the intended
cluster.

My setup is the following:
Master Node
elasticsearch 0.90.3
logstash 1.2.2
kibana 3.0.0milestone4
In /etc/elasticsearch/elasticsearch.yml:
cluster.name: ls_cluster
node.name: logstash1

Non-Master Node
elasticsearch 0.90.3
logstash 1.2.2
kibana 3.0.0milestone4
In /etc/elasticsearch/elasticsearch.yml:
cluster.name: ls_cluster
node.name: logstash2

I also tried changing the following on the non-master node, but it
didn't make any difference.
node.master: false
node.data: true
transport.tcp.port: 9301
http.port: 9201

The same result with using elasticsearch 0.90.9 & logstash 1.3.3.

Any help is appreciated, thanks!

--
You received this message because you are subscribed to the Google
Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send
an email to elasticsearc...@googlegroups.com.
To view this discussion on the web visit https://groups.google.com/d/
msgid/elasticsearch/be40c6b9-4fe5-45ca-b19f-69eadb00a1ae%
40googlegroups.com.
For more options, visit https://groups.google.com/groups/opt_out.

--
You received this message because you are subscribed to the Google Groups
"elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an
email to elasticsearch+unsubscribe@googlegroups.com.
To view this discussion on the web visit
https://groups.google.com/d/msgid/elasticsearch/ccf83335-cc8e-4cef-b602-ffaf4f683c58%40googlegroups.com
.
For more options, visit https://groups.google.com/groups/opt_out.

--
You received this message because you are subscribed to the Google Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an email to elasticsearch+unsubscribe@googlegroups.com.
To view this discussion on the web visit https://groups.google.com/d/msgid/elasticsearch/CAEM624bqqWVp0vJKJ%2BVMiG5eOgR7dcuEOBgwrr3HOfS9CTjW3Q%40mail.gmail.com.
For more options, visit https://groups.google.com/groups/opt_out.


(Indra Suryanata) #5

Thanks Mark, it works! - Really appreciate your help.

As you suggested, I set
discovery.zen.ping.unicast.hosts: $IP_OF_MASTER
in elasticsearch.yml of the Non-Master Node.

Regards,
Indra

On Friday, January 31, 2014 4:08:19 PM UTC-8, Mark Walkom wrote:

network.host is the IP that the node itself will listen on when
advertising the service, so if you set that to the master node IP then each
node will try and listen on that same IP. Which is not what you want.

You want to set;
discovery.zen.ping.unicast: $IP_OF_MASTER

Regards,
Mark Walkom

Infrastructure Engineer
Campaign Monitor
email: ma...@campaignmonitor.com <javascript:>
web: www.campaignmonitor.com

On 1 February 2014 11:00, Indra Suryanata <ins...@gmail.com <javascript:>>wrote:

Hi Mark,

I didn't set anything in the zen discovery method.
Should I set it to

network.host:

discovery.zen.ping.unicast.hosts:

in both elasticsearch.yml of the Master Node & Non-Master Node?

Thanks!

Regards,
Indra

On Friday, January 31, 2014 3:41:02 PM UTC-8, Mark Walkom wrote:

What is your zen discovery method? http://www.
elasticsearch.org/guide/en/elasticsearch/reference/
current/modules-discovery-zen.html

Regards,
Mark Walkom

Infrastructure Engineer
Campaign Monitor
email: ma...@campaignmonitor.com
web: www.campaignmonitor.com

On 1 February 2014 10:39, Indra Suryanata ins...@gmail.com wrote:

I am a beginner on Elasticsearch.
I have Logstash/Elasticsearch/Kibana running in HP Cloud.
This is the master node.

I tried to have at least another node (also in HP Cloud) to set up an
Elasticsearch cluster.
However, I found the non-master node still doesn’t join the intended
cluster.

My setup is the following:
Master Node
elasticsearch 0.90.3
logstash 1.2.2
kibana 3.0.0milestone4
In /etc/elasticsearch/elasticsearch.yml:
cluster.name: ls_cluster
node.name: logstash1

Non-Master Node
elasticsearch 0.90.3
logstash 1.2.2
kibana 3.0.0milestone4
In /etc/elasticsearch/elasticsearch.yml:
cluster.name: ls_cluster
node.name: logstash2

I also tried changing the following on the non-master node, but it
didn’t make any difference.
node.master: false
node.data: true
transport.tcp.port: 9301
http.port: 9201

The same result with using elasticsearch 0.90.9 & logstash 1.3.3.

Any help is appreciated, thanks!

--
You received this message because you are subscribed to the Google
Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send
an email to elasticsearc...@googlegroups.com.
To view this discussion on the web visit https://groups.google.com/d/
msgid/elasticsearch/be40c6b9-4fe5-45ca-b19f-69eadb00a1ae%
40googlegroups.com.
For more options, visit https://groups.google.com/groups/opt_out.

--
You received this message because you are subscribed to the Google Groups
"elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an
email to elasticsearc...@googlegroups.com <javascript:>.
To view this discussion on the web visit
https://groups.google.com/d/msgid/elasticsearch/ccf83335-cc8e-4cef-b602-ffaf4f683c58%40googlegroups.com
.
For more options, visit https://groups.google.com/groups/opt_out.

--
You received this message because you are subscribed to the Google Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an email to elasticsearch+unsubscribe@googlegroups.com.
To view this discussion on the web visit https://groups.google.com/d/msgid/elasticsearch/4349d68a-72a5-49fa-ace5-2bc8ddc79e60%40googlegroups.com.
For more options, visit https://groups.google.com/groups/opt_out.


(system) #6