Elasticsearch config watcher problem

alerting

(zouxiang) #1

I add watcher to elasticsearch ,bui doesnt work

here is the error log:
org.elasticsearch.bootstrap.StartupException: java.lang.IllegalArgumentException: unknown setting [watcher.actions.email.service.account.work.smtp.password] please check that any required plugins are installed, or check the breaking changes documentation for removed settings
.....
Suppressed: java.lang.IllegalArgumentException: unknown setting [watcher.actions.email.service.account.work.smtp.starttls.enable] please check that any required plugins are installed, or check the breaking changes documentation for removed settings
......
Suppressed: java.lang.IllegalArgumentException: unknown setting [watcher.actions.email.service.account.work.email_defaults.from] please check that any required plugins are installed, or check the breaking changes documentation for removed settings

and config file
[zoux@zouxcentos7 elasticsearch]$ grep -v "#" config/elasticsearch.yml
network.host: 0.0.0.0
http.port: 9200
http.cors.enabled: true
http.cors.allow-origin: "*"
watcher.actions.email.service.account:
work:
profile: standard
email_defaults:
from: '1264503504@qq.com'
smtp:
auth: true
starttls.enable: true
host: smtp.qq.com
port: 465
user: 1264503504@qq.com
password: verysimple3


(Alexander Reelsen) #2

Which Elasticsearch version you are using? The watcher prefix for setting has been abandoned from 5.0 onwards.

See https://www.elastic.co/guide/en/elastic-stack-overview/6.5/actions-email.html#configuring-email