Watcher Email Configuration error


(krishna singh) #1

Hi,

I have configured watcher to Elasticsearch to get Alert & Notifications and I have setup Email configuration in yml file as shown below.

watcher.actions.email.service.account:
work:
profile: gmail
smtp:
auth: true
starttls.enable: true
host: krishna.kumar0608@gmail.com
port: 587
user: krishna.kumar0608@gmail.com
password: password

But I am getting error as,

./elasticsearch
{1.7.1}: Setup Failed ...

  • SettingsException[Failed to load settings from [file:/home/krishna/Downloads/elasticsearch-1.7.1/config/elasticsearch.yml]]
    IOException[Tabs are illegal in YAML. Did you mean to use whitespace character instead?]
    org.elasticsearch.common.settings.SettingsException: Failed to load settings from [file:/home/krishna/Downloads/elasticsearch-1.7.1/config/elasticsearch.yml]
    at org.elasticsearch.common.settings.ImmutableSettings$Builder.loadFromStream(ImmutableSettings.java:985)
    at org.elasticsearch.common.settings.ImmutableSettings$Builder.loadFromUrl(ImmutableSettings.java:969)
    at org.elasticsearch.node.internal.InternalSettingsPreparer.prepareSettings(InternalSettingsPreparer.java:110)
    at org.elasticsearch.bootstrap.Bootstrap.initialSettings(Bootstrap.java:144)
    at org.elasticsearch.bootstrap.Bootstrap.main(Bootstrap.java:215)
    at org.elasticsearch.bootstrap.Elasticsearch.main(Elasticsearch.java:32)
    Caused by: java.io.IOException: Tabs are illegal in YAML. Did you mean to use whitespace character instead?
    at org.elasticsearch.common.settings.loader.YamlSettingsLoader.load(YamlSettingsLoader.java:44)
    at org.elasticsearch.common.settings.ImmutableSettings$Builder.loadFromStream(ImmutableSettings.java:982)
    ... 5 more

root@krishna-Vostro-1015:/home/krishna/Downloads/elasticsearch-1.7.1/bin# ./elasticsearch
{1.7.1}: Setup Failed ...

  • SettingsException[Failed to load settings from [file:/home/krishna/Downloads/elasticsearch-1.7.1/config/elasticsearch.yml]]
    IOException[Tabs are illegal in YAML. Did you mean to use whitespace character instead?]
    org.elasticsearch.common.settings.SettingsException: Failed to load settings from [file:/home/krishna/Downloads/elasticsearch-1.7.1/config/elasticsearch.yml]
    at org.elasticsearch.common.settings.ImmutableSettings$Builder.loadFromStream(ImmutableSettings.java:985)
    at org.elasticsearch.common.settings.ImmutableSettings$Builder.loadFromUrl(ImmutableSettings.java:969)
    at org.elasticsearch.node.internal.InternalSettingsPreparer.prepareSettings(InternalSettingsPreparer.java:110)
    at org.elasticsearch.bootstrap.Bootstrap.initialSettings(Bootstrap.java:144)
    at org.elasticsearch.bootstrap.Bootstrap.main(Bootstrap.java:215)
    at org.elasticsearch.bootstrap.Elasticsearch.main(Elasticsearch.java:32)
    Caused by: java.io.IOException: Tabs are illegal in YAML. Did you mean to use whitespace character instead?
    at org.elasticsearch.common.settings.loader.YamlSettingsLoader.load(YamlSettingsLoader.java:44)
    at org.elasticsearch.common.settings.ImmutableSettings$Builder.loadFromStream(ImmutableSettings.java:982)
    ... 5 more

please help me out.


(Mark Walkom) #2

This is why, do you have tabs?


(krishna singh) #3

No,i dont think so..!!


(David Pilato) #4

But elasticsearch thinks you do. :stuck_out_tongue:

I'd trust elasticsearch and double check.


(system) #5