Elasticsearch.yml email configuration error


(vinayak) #1

Hi All,

My elastic search configuration for is like this only:

======================== Elasticsearch Configuration =========================

---------------------------------- Cluster -----------------------------------

Use a descriptive name for your cluster:

cluster.name: avekshaa

------------------------------------ Node ------------------------------------

Use a descriptive name for the node:

node.name: avekesnode1

path.data: D:\Elasticsearch\Data

Path to log files:

path.logs: D:\Elasticsearch\Logs

network.host: 0.0.0.0

Set a custom port for HTTP:

http.port: 9200

action.auto_create_index: .security,.monitoring*,.watches,.triggered_watches,.watcher-history*,.ml*
xpack.ml.enabled: true
xpack.watcher.enabled: true
xpack.security.enabled: true
xpack.monitoring.enabled: true

#--------------------------------------------------------
watcher.actions.email.service.account:
gmail_account:
profile: gmail
smtp:
auth: true
starttls.enable: true
host: smtp.gmail.com
port: 587
user: vinayak.choubey@avekshaa.com
password: ****************

#--------------------------elasticsearch.yml end here---------------------------------------------

I am getting error . pasting log file error part in it.Please provide me correct solutions.


[2017-08-14T16:01:45,632][INFO ][o.e.n.Node ] [avekesnode1] initializing ...
[2017-08-14T16:03:31,870][INFO ][o.e.e.NodeEnvironment ] [avekesnode1] using [1] data paths, mounts [[Other (D:)]], net usable_space [119.5gb], net total_space [215.5gb], spins? [unknown], types [NTFS]
[2017-08-14T16:03:31,871][INFO ][o.e.e.NodeEnvironment ] [avekesnode1] heap size [1.9gb], compressed ordinary object pointers [true]
[2017-08-14T16:03:32,754][INFO ][o.e.n.Node ] [avekesnode1] node name [avekesnode1], node ID [Czqt252vTICylcghAyMC9g]
[2017-08-14T16:03:32,755][INFO ][o.e.n.Node ] [avekesnode1] version[5.5.0], pid[4312], build[260387d/2017-06-30T23:16:05.735Z], OS[Windows 10/10.0/amd64], JVM[Oracle Corporation/Java HotSpot(TM) 64-Bit Server VM/1.8.0_112/25.112-b15]
[2017-08-14T16:03:32,757][INFO ][o.e.n.Node ] [avekesnode1] JVM arguments [-Xms2g, -Xmx2g, -XX:+UseConcMarkSweepGC, -XX:CMSInitiatingOccupancyFraction=75, -XX:+UseCMSInitiatingOccupancyOnly, -XX:+DisableExplicitGC, -XX:+AlwaysPreTouch, -Xss1m, -Djava.awt.headless=true, -Dfile.encoding=UTF-8, -Djna.nosys=true, -Djdk.io.permissionsUseCanonicalPath=true, -Dio.netty.noUnsafe=true, -Dio.netty.noKeySetOptimization=true, -Dio.netty.recycler.maxCapacityPerThread=0, -Dlog4j.shutdownHookEnabled=false, -Dlog4j2.disable.jmx=true, -Dlog4j.skipJansi=true, -XX:+HeapDumpOnOutOfMemoryError, -Delasticsearch, -Des.path.home=C:\Users\vinayak\Documents\ElasticSearch\elasticsearch-5.5.0]
[2017-08-14T16:03:36,037][WARN ][o.e.x.XPackPlugin ] the [action.auto_create_index] setting is configured to be restrictive [.security,.monitoring*,.watches,.triggered_watches,.watcher-history*,.ml*]. for the next 6 months daily history indices are allowed to be created, but please make sure that any future history indices after 6 months with the pattern [.watcher-history-YYYY.MM.dd] are allowed to be created
[2017-08-14T16:03:36,079][INFO ][o.e.p.PluginsService ] [avekesnode1] loaded module [aggs-matrix-stats]
[2017-08-14T16:03:36,080][INFO ][o.e.p.PluginsService ] [avekesnode1] loaded module [ingest-common]
[2017-08-14T16:03:36,082][INFO ][o.e.p.PluginsService ] [avekesnode1] loaded module [lang-expression]
[2017-08-14T16:03:36,085][INFO ][o.e.p.PluginsService ] [avekesnode1] loaded module [lang-groovy]
[2017-08-14T16:03:36,086][INFO ][o.e.p.PluginsService ] [avekesnode1] loaded module [lang-mustache]
[2017-08-14T16:03:36,088][INFO ][o.e.p.PluginsService ] [avekesnode1] loaded module [lang-painless]
[2017-08-14T16:03:36,089][INFO ][o.e.p.PluginsService ] [avekesnode1] loaded module [parent-join]
[2017-08-14T16:03:36,090][INFO ][o.e.p.PluginsService ] [avekesnode1] loaded module [percolator]
[2017-08-14T16:03:36,093][INFO ][o.e.p.PluginsService ] [avekesnode1] loaded module [reindex]
[2017-08-14T16:03:36,097][INFO ][o.e.p.PluginsService ] [avekesnode1] loaded module [transport-netty3]
[2017-08-14T16:03:36,098][INFO ][o.e.p.PluginsService ] [avekesnode1] loaded module [transport-netty4]
[2017-08-14T16:03:36,099][INFO ][o.e.p.PluginsService ] [avekesnode1] loaded plugin [x-pack]
[2017-08-14T16:03:38,961][ERROR][o.e.b.Bootstrap ] Exception
java.lang.IllegalArgumentException: unknown setting [watcher.actions.email.service.account.gmail_account.profile] please check that any required plugins are installed, or check the breaking changes documentation for removed settings
at org.elasticsearch.common.settings.AbstractScopedSettings.validate(AbstractScopedSettings.java:293) ~[elasticsearch-5.5.0.jar:5.5.0]
at org.elasticsearch.common.settings.AbstractScopedSettings.validate(AbstractScopedSettings.java:256) ~[elasticsearch-5.5.0.jar:5.5.0]
at org.elasticsearch.common.settings.SettingsModule.(SettingsModule.java:139) ~[elasticsearch-5.5.0.jar:5.5.0]
at org.elasticsearch.node.Node.(Node.java:343) ~[elasticsearch-5.5.0.jar:5.5.0]
at org.elasticsearch.node.Node.(Node.java:244) ~[elasticsearch-5.5.0.jar:5.5.0]
at org.elasticsearch.bootstrap.Bootstrap$5.(Bootstrap.java:232) ~[elasticsearch-5.5.0.jar:5.5.0]


(Colin Goodheart-Smithe) #2

watcher configuration of email accounts has changed since 2.4, please see https://www.elastic.co/guide/en/x-pack/current/actions-email.html#gmail for up to date documentation on how to configure email accounts in 5.5


(vinayak) #3

Thank you.it works.


(system) #4

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.