Elasticsearch could not connect

So I've seen several posts about this however I'm in the same boat since upgrading from 1.x to 2.3.1

I've set my elasticsearch.yml to be blank and use all the defaults and I still get an issue connecting.

with a config setup:

[2016-04-20 23:38:44,323][WARN ][transport.netty ] [Elasticsearch] exception caught on transport layer [[id: 0x1a04f52d, / => /]], closing connection

with a blank config:
[2016-04-20 23:38:44,323][WARN ][transport.netty ] [Bloodshed] exception caught on transport layer [[id: 0x18ad695a, / => /]], closing connection

I can curl localhost:9200
erogers@napalprdlog03:/etc/elasticsearch$ curl localhost:9200

"name" : "Elasticsearch-Log3",
"cluster_name" : "elasticsearch2",
"version" : {
"number" : "2.3.1",
"build_hash" : "bd980929010aef404e7cb0843e61d0665269fc39",
"build_timestamp" : "2016-04-04T12:25:05Z",
"build_snapshot" : false,
"lucene_version" : "5.5.0"
"tagline" : "You Know, for Search"
I cannot curl it's own internal ip address from the same box.

erogers@napalprdlog03:/etc/elasticsearch$ curl
curl: (7) Failed to connect to port 9200: Connection refused

the purpose of this box is for external points to transmit via TCP windows event logs and other such log files.

I've tried setting network.host everywhich way but loose and it still will not allow to connect.

ufw has been disabled

This might help: https://www.elastic.co/guide/en/elasticsearch/reference/current/modules-network.html. By default, it binds to and listens only on

Yes I've set that in just about every possible way I could think.

this is how it's currently set.

network.host: local

add network.bind_host:

and remove network.host

alternatively, set network.host: ["_local_",""] and remove network.publish_host. You can retain it also if you like but it is just a duplicate IMO.