Elasticsearch eats my heap when auto-expanding replicas

I start with a single node, with ~100 small indexes (number_of_shards=1,
auto_expand_replicas=0-1). Everything works fine.

I then start a second node on a different machine (ec2).

The first node now shows a lot of messages like:

2013-07-02 22:54:55,684 [INFO] cluster.metadata - [Crooked Man] updating
number_of_replicas to [1] for indices [foo]
2013-07-02 22:54:55,708 [INFO] cluster.metadata - [Crooked Man] [foo] auto
expanded replicas to [1]

...while slowing down to a crawl, because it's using up all available heap
space (1gb).

Anyone else notice this? Does elasticsearch really need 1gb+ per 100
indexes in a cluster?

I'm running elasticsearch 0.90.2 with the elasticsearch-cloud-aws 1.12.0

You received this message because you are subscribed to the Google Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an email to elasticsearch+unsubscribe@googlegroups.com.
For more options, visit https://groups.google.com/groups/opt_out.