Elasticsearch Engineering Observability - What do I do on the .YAML menu screen in the terminal?

It comes up with a menu (shown in the first picture). The lab doesn't tell you anything about this and then goes on to tell you to do more code (second picture). What do I do with the menu after I type: "nano filebeat.yml"?

Hi Brendan,

Nano is a text editor that you can use in a Linux terminal. It's not Elastic specific. There are guides on the internet, like this one for example, that explain how to use it.

If you're more comfortable with another text editor, like vi or emacs, feel free to use those.

In this case, you're being asked to make changes to the filebeat.yml file. Step 3 tells you exactly what changes you need to make.

Hope this helps!


How do I save the edits to the heartbeat.yml file after I edit it in the terminal?

I figured it out.... "CTRL O". Another question. I accidently forgot the "s" in "https" in the .YML. Heartbeat shows but it is down. How do I fix that? Can I just edit and will it save overtop? Do I have to do ./heartbeat setup -e again? Because after I saved the edited file, I get an error when I try to run that. Thank you.


Yes, when you save the file, it will overwrite the previous version. You do not need to run "setup" again, after editing - you can just restart Filebeat.

Can you share the error? It will help us troubleshoot the problem.

One common error with yml files is caused by their whitespace sensitivity. So when you see two spaces at the beginning of a line in an exercise, make sure those end up in the file.


What happened was I was using "CTRL O" to write to the file. What this was doing was creating a new file with a different name every time I did it. I'm now using "CRTL X" and it is working fine overwriting.

Now, I'm trying to add the tcp monitor. I'm adding it exactly the way the lab answer shows and it is down. I even tried adding in the certificate, user name, and password. It is still down.

TCP Error


YML is a whitespace sensitive format (unfortunately), so spaces are important. Take a close look at the lab exercises - some configuration lines start with two spaces. Make sure you put those spaces in your heartbeat.yml file too.

Another thing is that there seem to be some settings here (like the ssl settings and the username and password) that don't belong in a tcp monitor configuration. All you need to put in the file is what you see in the lab answer.


Thanks. Yeah, I just added in the ssl because I didn't know why it wasn't working. The issue turned out to be that I had typed "-type" instead of "- type". It was exactly that. I didn't add a space after "-". Thanks!

Two questions:

  1. After I run heartbeat with "./heartbeat &", how do you stop that process?

  2. I entered the Elastic.co Homepage monitoring exactly how it was shown in the lab and it didn't work. Also tried to add ssl lines and still doesn't work. The other 4 monitors before that one do work though.

Elastic 1
Elastic 2

Enter the following command to stop any running Heartbeat processes:

killall heartbeat

The elastic.co monitor only pings once every 10 minutes. Maybe you need to wait a bit longer to see those pings show up?


Thank you for the "kill" command. I had to kill the process, edit the .YML, then do "./heartbeat setup -e", then "./heartbeat -e". Now all 5 are showing. I know I shouldn't have to do the setup again, as I have "reload.enabled: true" for the monitor config settings in the YML. The most interesting thing is when I type "nano heatbeat", it opens with a bunch of gibberish. I have to type "nano heartbeat.yml" and then I can edit the yml file. I've checked the directory for heartbeat and all the files are as they should be......shoulder shrug......

When you type nano filebeat you're using the Nano text editor to open the Filebeat executable (the actual Heartbeat application). In a text editor, an executable like that looks like gibberish. The .yml extension is important - the configuration file is called filebeat.yml.

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.