Elasticsearch error of class not found


(Anikessh Jain) #1

Hi All.

I am a newbie to Elastic search and I am configuring Kibana with Logstash
and Redis and Elasticsearch in Centos 32 Bit and when i am trying to
start the service of elastic search i am getting the below error

WrapperSimpleApp Error: Unable

to locate the class org.elasticsearch.bootstrap.ElasticsearchF : java.lang.ClassNotFoundException: org.elasticsearch.bootstrap.ElasticsearchF

How to solve the above error ,i tried many steps but no use but of no help, have anybody face the same issue please help me.

--
You received this message because you are subscribed to the Google Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an email to elasticsearch+unsubscribe@googlegroups.com.
To view this discussion on the web visit https://groups.google.com/d/msgid/elasticsearch/bd7b47b5-46f1-4066-89a9-ba5c4929a25c%40googlegroups.com.
For more options, visit https://groups.google.com/d/optout.


(Anikessh Jain) #2

Can anybody help me it is a bit urgent .

On Thursday, March 20, 2014 3:09:56 PM UTC+5:30, Anikessh Jain wrote:

Hi All.

I am a newbie to Elastic search and I am configuring Kibana with Logstash
and Redis and Elasticsearch in Centos 32 Bit and when i am trying to
start the service of elastic search i am getting the below error

WrapperSimpleApp Error: Unable

to locate the class org.elasticsearch.bootstrap.ElasticsearchF : java.lang.ClassNotFoundException: org.elasticsearch.bootstrap.ElasticsearchF

How to solve the above error ,i tried many steps but no use but of no help, have anybody face the same issue please help me.

--
You received this message because you are subscribed to the Google Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an email to elasticsearch+unsubscribe@googlegroups.com.
To view this discussion on the web visit https://groups.google.com/d/msgid/elasticsearch/c2e6f892-9d61-4ecf-9624-b180842bac11%40googlegroups.com.
For more options, visit https://groups.google.com/d/optout.


(Anikessh Jain) #3

nobody there to help me , help me please i am in need

On Thursday, March 20, 2014 3:31:42 PM UTC+5:30, Anikessh Jain wrote:

Can anybody help me it is a bit urgent .

On Thursday, March 20, 2014 3:09:56 PM UTC+5:30, Anikessh Jain wrote:

Hi All.

I am a newbie to Elastic search and I am configuring Kibana with Logstash
and Redis and Elasticsearch in Centos 32 Bit and when i am trying to
start the service of elastic search i am getting the below error

WrapperSimpleApp Error: Unable

to locate the class org.elasticsearch.bootstrap.ElasticsearchF : java.lang.ClassNotFoundException: org.elasticsearch.bootstrap.ElasticsearchF

How to solve the above error ,i tried many steps but no use but of no help, have anybody face the same issue please help me.

--
You received this message because you are subscribed to the Google Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an email to elasticsearch+unsubscribe@googlegroups.com.
To view this discussion on the web visit https://groups.google.com/d/msgid/elasticsearch/6e075a41-21b4-46f9-a9b3-a9beae1210b4%40googlegroups.com.
For more options, visit https://groups.google.com/d/optout.


(David Pilato) #4

What did you download?

--
David :wink:
Twitter : @dadoonet / @elasticsearchfr / @scrutmydocs

Le 20 mars 2014 à 14:54, Anikessh Jain anikesshjain88@gmail.com a écrit :

nobody there to help me , help me please i am in need

On Thursday, March 20, 2014 3:31:42 PM UTC+5:30, Anikessh Jain wrote:
Can anybody help me it is a bit urgent .

On Thursday, March 20, 2014 3:09:56 PM UTC+5:30, Anikessh Jain wrote:
Hi All.

I am a newbie to Elastic search and I am configuring Kibana with Logstash and Redis and Elasticsearch in Centos 32 Bit and when i am trying to start the service of elastic search i am getting the below error

WrapperSimpleApp Error: Unable
to locate the class org.elasticsearch.bootstrap.ElasticsearchF : java.lang.ClassNotFoundException: org.elasticsearch.bootstrap.ElasticsearchF

How to solve the above error ,i tried many steps but no use but of no help, have anybody face the same issue please help me.

--
You received this message because you are subscribed to the Google Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an email to elasticsearch+unsubscribe@googlegroups.com.
To view this discussion on the web visit https://groups.google.com/d/msgid/elasticsearch/6e075a41-21b4-46f9-a9b3-a9beae1210b4%40googlegroups.com.
For more options, visit https://groups.google.com/d/optout.

--
You received this message because you are subscribed to the Google Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an email to elasticsearch+unsubscribe@googlegroups.com.
To view this discussion on the web visit https://groups.google.com/d/msgid/elasticsearch/63E9FEAC-ABB9-4127-AA9B-66FFF4F99338%40pilato.fr.
For more options, visit https://groups.google.com/d/optout.


(Anikessh Jain) #5

wget https://download.elasticsearch.org/elasticsearch/elasticsearch/elasticsearch-0.20.2.tar.gz
tar xvf elasticsearch-0.20.2.tar.gz

mv elasticsearch-0.20.2 elasticsearch

wget http://github.com/elasticsearch/elasticsearch-servicewrapper/archive/master.zip
unzip master
mv elasticsearch-servicewrapper-master/service/ elasticsearch/bin
rm -rf master
rm -rf elasticsearch-servicewrapper-master/

Configure ‘elasticsearch.conf’

set.default.ES_HOME=/usr/local/elasticsearch
set.default.ES_HEAP_SIZE=4096
wrapper.java.additional.10=-Des.max-open-files=true

wrapper.logfile.maxsize=5m
wrapper.logfile.maxfiles=5

Add ES home to root user’s ‘.bash_profile’

ElasticSearch

export ES_HOME=/usr/local/elasticsearch

Create elasticsearch user

useradd -d /home/elasticsearch -s /bin/sh elasticsearch
chown -R elasticsearch:elasticsearch $ES_HOME
chown -R elasticsearch:elasticsearch /mnt/storage/es-data

Edit elasticsearch user’s ‘.bash_profile’

.bash_profile

Get the aliases and functions

if [ -f ~/.bashrc ]; then
. ~/.bashrc
fi

User specific environment and startup programs

PATH=$PATH:$HOME/bin

export PATH

JAVA_HOME needs to be the latest 1.7 JDK on the system

JAVA_HOME=/usr/local/jdk7
export JAVA_HOME

#Add JAVA_HOME to the PATH
PATH=$JAVA_HOME/bin:$PATH

ElasticSearch

export ES_HOME=/usr/local/elasticsearch

unset USERNAME

Edit ‘/etc/security/limits.conf’ (optional as this will be set in the service script, too)

elasticsearch soft nofile 65535
elasticsearch hard nofile 65535

Verify the file descriptor limit

sudo -u elasticsearch -s ulimit -Sn

Install the service

bin/service/elasticsearch install

Edit ‘/etc/init.d/elasticsearch’

Java

JAVA_HOME=/usr/local/jdk7
export JAVA_HOME
PATH=$JAVA_HOME/bin:$PATH
RUN_AS_USER=elasticsearch
ULIMIT_N=65535

Run the service

bin/service/elasticsearch start
or
service elasticsearch start -> here the above error i am getting can you please help me

please help me what wrong i have done

On Thursday, March 20, 2014 8:10:22 PM UTC+5:30, David Pilato wrote:

What did you download?

--
David :wink:
Twitter : @dadoonet / @elasticsearchfr / @scrutmydocs

Le 20 mars 2014 à 14:54, Anikessh Jain <anikess...@gmail.com <javascript:>>
a écrit :

nobody there to help me , help me please i am in need

On Thursday, March 20, 2014 3:31:42 PM UTC+5:30, Anikessh Jain wrote:

Can anybody help me it is a bit urgent .

On Thursday, March 20, 2014 3:09:56 PM UTC+5:30, Anikessh Jain wrote:

Hi All.

I am a newbie to Elastic search and I am configuring Kibana with
Logstash and Redis and Elasticsearch in Centos 32 Bit and when i am
trying to start the service of elastic search i am getting the below error

WrapperSimpleApp Error: Unable

to locate the class org.elasticsearch.bootstrap.ElasticsearchF : java.lang.ClassNotFoundException: org.elasticsearch.bootstrap.ElasticsearchF

How to solve the above error ,i tried many steps but no use but of no help, have anybody face the same issue please help me.

--
You received this message because you are subscribed to the Google Groups
"elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an
email to elasticsearc...@googlegroups.com <javascript:>.
To view this discussion on the web visit
https://groups.google.com/d/msgid/elasticsearch/6e075a41-21b4-46f9-a9b3-a9beae1210b4%40googlegroups.comhttps://groups.google.com/d/msgid/elasticsearch/6e075a41-21b4-46f9-a9b3-a9beae1210b4%40googlegroups.com?utm_medium=email&utm_source=footer
.
For more options, visit https://groups.google.com/d/optout.

--
You received this message because you are subscribed to the Google Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an email to elasticsearch+unsubscribe@googlegroups.com.
To view this discussion on the web visit https://groups.google.com/d/msgid/elasticsearch/6d8b8875-5c20-41de-bb37-87c9c263a176%40googlegroups.com.
For more options, visit https://groups.google.com/d/optout.


(Anikessh Jain) #6

On Thursday, March 20, 2014 3:09:56 PM UTC+5:30, Anikessh Jain wrote:

Hi All.

I am a newbie to Elastic search and I am configuring Kibana with Logstash
and Redis and Elasticsearch in Centos 32 Bit and when i am trying to
start the service of elastic search i am getting the below error

WrapperSimpleApp Error: Unable

to locate the class org.elasticsearch.bootstrap.ElasticsearchF : java.lang.ClassNotFoundException: org.elasticsearch.bootstrap.ElasticsearchF

How to solve the above error ,i tried many steps but no use but of no help, have anybody face the same issue please help me.

--
You received this message because you are subscribed to the Google Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an email to elasticsearch+unsubscribe@googlegroups.com.
To view this discussion on the web visit https://groups.google.com/d/msgid/elasticsearch/a8275483-ac50-4f0a-a150-61481c2f8d94%40googlegroups.com.
For more options, visit https://groups.google.com/d/optout.


(Anikessh Jain) #7

please help on the above error

On Thursday, March 20, 2014 9:03:46 PM UTC+5:30, Anikessh Jain wrote:

wget https://download.elasticsearch.org/elasticsearch/elasticsearch/elasticsearch-0.20.2.tar.gz
tar xvf elasticsearch-0.20.2.tar.gz

mv elasticsearch-0.20.2 elasticsearch

wget http://github.com/elasticsearch/elasticsearch-servicewrapper/archive/master.zip
unzip master
mv elasticsearch-servicewrapper-master/service/ elasticsearch/bin
rm -rf master
rm -rf elasticsearch-servicewrapper-master/

Configure ‘elasticsearch.conf’

set.default.ES_HOME=/usr/local/elasticsearch
set.default.ES_HEAP_SIZE=4096
wrapper.java.additional.10=-Des.max-open-files=true

wrapper.logfile.maxsize=5m
wrapper.logfile.maxfiles=5

Add ES home to root user’s ‘.bash_profile’

ElasticSearch

export ES_HOME=/usr/local/elasticsearch

Create elasticsearch user

useradd -d /home/elasticsearch -s /bin/sh elasticsearch
chown -R elasticsearch:elasticsearch $ES_HOME
chown -R elasticsearch:elasticsearch /mnt/storage/es-data

Edit elasticsearch user’s ‘.bash_profile’

.bash_profile

Get the aliases and functions

if [ -f ~/.bashrc ]; then
. ~/.bashrc
fi

User specific environment and startup programs

PATH=$PATH:$HOME/bin

export PATH

JAVA_HOME needs to be the latest 1.7 JDK on the system

JAVA_HOME=/usr/local/jdk7
export JAVA_HOME

#Add JAVA_HOME to the PATH
PATH=$JAVA_HOME/bin:$PATH

ElasticSearch

export ES_HOME=/usr/local/elasticsearch

unset USERNAME

Edit ‘/etc/security/limits.conf’ (optional as this will be set in the service script, too)

elasticsearch soft nofile 65535
elasticsearch hard nofile 65535

Verify the file descriptor limit

sudo -u elasticsearch -s ulimit -Sn

Install the service

bin/service/elasticsearch install

Edit ‘/etc/init.d/elasticsearch’

Java

JAVA_HOME=/usr/local/jdk7
export JAVA_HOME
PATH=$JAVA_HOME/bin:$PATH
RUN_AS_USER=elasticsearch
ULIMIT_N=65535

Run the service

bin/service/elasticsearch start
or
service elasticsearch start -> here the above error i am getting can you please help me

please help me what wrong i have done

On Thursday, March 20, 2014 8:10:22 PM UTC+5:30, David Pilato wrote:

What did you download?

--
David :wink:
Twitter : @dadoonet / @elasticsearchfr / @scrutmydocs

Le 20 mars 2014 à 14:54, Anikessh Jain anikess...@gmail.com a écrit :

nobody there to help me , help me please i am in need

On Thursday, March 20, 2014 3:31:42 PM UTC+5:30, Anikessh Jain wrote:

Can anybody help me it is a bit urgent .

On Thursday, March 20, 2014 3:09:56 PM UTC+5:30, Anikessh Jain wrote:

Hi All.

I am a newbie to Elastic search and I am configuring Kibana with
Logstash and Redis and Elasticsearch in Centos 32 Bit and when i am
trying to start the service of elastic search i am getting the below error

WrapperSimpleApp Error: Unable

to locate the class org.elasticsearch.bootstrap.ElasticsearchF : java.lang.ClassNotFoundException: org.elasticsearch.bootstrap.ElasticsearchF

How to solve the above error ,i tried many steps but no use but of no help, have anybody face the same issue please help me.

--
You received this message because you are subscribed to the Google Groups
"elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an
email to elasticsearc...@googlegroups.com.
To view this discussion on the web visit
https://groups.google.com/d/msgid/elasticsearch/6e075a41-21b4-46f9-a9b3-a9beae1210b4%40googlegroups.comhttps://groups.google.com/d/msgid/elasticsearch/6e075a41-21b4-46f9-a9b3-a9beae1210b4%40googlegroups.com?utm_medium=email&utm_source=footer
.
For more options, visit https://groups.google.com/d/optout.

--
You received this message because you are subscribed to the Google Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an email to elasticsearch+unsubscribe@googlegroups.com.
To view this discussion on the web visit https://groups.google.com/d/msgid/elasticsearch/221d4092-88ec-405d-a9b1-4cae1ce1d3cf%40googlegroups.com.
For more options, visit https://groups.google.com/d/optout.


(David Pilato) #8

First download a recent version. If you are starting with elasticsearch, you don't need to start with a so old version.
1.0.1 is fine.

Then read the documentation here: http://www.elasticsearch.org/guide/en/elasticsearch/reference/current/setup.html

No need to install so many pieces.

Unzip and launch. That's all.

--
David Pilato | Technical Advocate | Elasticsearch.com
@dadoonet | @elasticsearchfr

Le 20 mars 2014 à 17:06:12, Anikessh Jain (anikesshjain88@gmail.com) a écrit:

please help on the above error

On Thursday, March 20, 2014 9:03:46 PM UTC+5:30, Anikessh Jain wrote:

wget https://download.elasticsearch.org/elasticsearch/elasticsearch/elasticsearch-0.20.2.tar.gz
tar xvf elasticsearch-0.20.2.tar.gz

mv elasticsearch-0.20.2 elasticsearch

wget http://github.com/elasticsearch/elasticsearch-servicewrapper/archive/master.zip
unzip master
mv elasticsearch-servicewrapper-master/service/ elasticsearch/bin
rm -rf master
rm -rf elasticsearch-servicewrapper-master/

Configure ‘elasticsearch.conf’

set.default.ES_HOME=/usr/local/elasticsearch
set.default.ES_HEAP_SIZE=4096
wrapper.java.additional.10=-Des.max-open-files=true

wrapper.logfile.maxsize=5m
wrapper.logfile.maxfiles=5

Add ES home to root user’s ‘.bash_profile’

ElasticSearch

export ES_HOME=/usr/local/elasticsearch

Create elasticsearch user

useradd -d /home/elasticsearch -s /bin/sh elasticsearch
chown -R elasticsearch:elasticsearch $ES_HOME
chown -R elasticsearch:elasticsearch /mnt/storage/es-data

Edit elasticsearch user’s ‘.bash_profile’

.bash_profile

Get the aliases and functions

if [ -f ~/.bashrc ]; then
. ~/.bashrc
fi

User specific environment and startup programs

PATH=$PATH:$HOME/bin

export PATH

JAVA_HOME needs to be the latest 1.7 JDK on the system

JAVA_HOME=/usr/local/jdk7
export JAVA_HOME

#Add JAVA_HOME to the PATH
PATH=$JAVA_HOME/bin:$PATH

ElasticSearch

export ES_HOME=/usr/local/elasticsearch

unset USERNAME

Edit ‘/etc/security/limits.conf’ (optional as this will be set in the service script, too)

elasticsearch soft nofile 65535
elasticsearch hard nofile 65535

Verify the file descriptor limit

sudo -u elasticsearch -s ulimit -Sn

Install the service

bin/service/elasticsearch install

Edit ‘/etc/init.d/elasticsearch’

Java

JAVA_HOME=/usr/local/jdk7
export JAVA_HOME
PATH=$JAVA_HOME/bin:$PATH
RUN_AS_USER=elasticsearch
ULIMIT_N=65535

Run the service

bin/service/elasticsearch start
or
service elasticsearch start -> here the above error i am getting can you please help me

please help me what wrong i have done
On Thursday, March 20, 2014 8:10:22 PM UTC+5:30, David Pilato wrote:
What did you download?

--
David :wink:
Twitter : @dadoonet / @elasticsearchfr / @scrutmydocs

Le 20 mars 2014 à 14:54, Anikessh Jain anikess...@gmail.com a écrit :

nobody there to help me , help me please i am in need

On Thursday, March 20, 2014 3:31:42 PM UTC+5:30, Anikessh Jain wrote:
Can anybody help me it is a bit urgent .

On Thursday, March 20, 2014 3:09:56 PM UTC+5:30, Anikessh Jain wrote:
Hi All.

I am a newbie to Elastic search and I am configuring Kibana with Logstash and Redis and Elasticsearch in Centos 32 Bit and when i am trying to start the service of elastic search i am getting the below error

WrapperSimpleApp Error: Unable

to locate the class org.elasticsearch.bootstrap.ElasticsearchF : java.lang.ClassNotFoundException: org.elasticsearch.bootstrap.ElasticsearchF

How to solve the above error ,i tried many steps but no use but of no help, have anybody face the same issue please help me.

You received this message because you are subscribed to the Google Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an email to elasticsearc...@googlegroups.com.
To view this discussion on the web visit https://groups.google.com/d/msgid/elasticsearch/6e075a41-21b4-46f9-a9b3-a9beae1210b4%40googlegroups.com.
For more options, visit https://groups.google.com/d/optout.

You received this message because you are subscribed to the Google Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an email to elasticsearch+unsubscribe@googlegroups.com.
To view this discussion on the web visit https://groups.google.com/d/msgid/elasticsearch/221d4092-88ec-405d-a9b1-4cae1ce1d3cf%40googlegroups.com.
For more options, visit https://groups.google.com/d/optout.

--
You received this message because you are subscribed to the Google Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an email to elasticsearch+unsubscribe@googlegroups.com.
To view this discussion on the web visit https://groups.google.com/d/msgid/elasticsearch/etPan.532b1a51.333ab105.c9bd%40MacBook-Air-de-David.local.
For more options, visit https://groups.google.com/d/optout.


(Anikessh Jain) #9

Hi David,

But why do people download and install it through
elasticsearch-servicewrapper ,does the leatest version supports it all bcoz
i want to install kibana with logstash and redis with elasticsearch and i
am a little bit confused will it work bcoz i have wasted my whole day on on
error.please guide me what to do as i dont know what to do and doing it for
first time

On Thursday, March 20, 2014 10:11:52 PM UTC+5:30, David Pilato wrote:

First download a recent version. If you are starting with elasticsearch,
you don't need to start with a so old version.
1.0.1 is fine.

Then read the documentation here:
http://www.elasticsearch.org/guide/en/elasticsearch/reference/current/setup.html

No need to install so many pieces.

Unzip and launch. That's all.

--
David Pilato | Technical Advocate | Elasticsearch.com
@dadoonet https://twitter.com/dadoonet | @elasticsearchfrhttps://twitter.com/elasticsearchfr

Le 20 mars 2014 à 17:06:12, Anikessh Jain (anikess...@gmail.com<javascript:>)
a écrit:

please help on the above error

On Thursday, March 20, 2014 9:03:46 PM UTC+5:30, Anikessh Jain wrote:

wget https://download.elasticsearch.org/elasticsearch/elasticsearch/elasticsearch-0.20.2.tar.gz
tar xvf elasticsearch-0.20.2.tar.gz

mv elasticsearch-0.20.2 elasticsearch

wget http://github.com/elasticsearch/elasticsearch-servicewrapper/archive/master.zip
unzip master
mv elasticsearch-servicewrapper-master/service/ elasticsearch/bin
rm -rf master
rm -rf elasticsearch-servicewrapper-master/

Configure ‘elasticsearch.conf’

set.default.ES_HOME=/usr/local/elasticsearch
set.default.ES_HEAP_SIZE=4096
wrapper.java.additional.10=-Des.max-open-files=true

wrapper.logfile.maxsize=5m
wrapper.logfile.maxfiles=5

Add ES home to root user’s ‘.bash_profile’

ElasticSearch

export ES_HOME=/usr/local/elasticsearch

Create elasticsearch user

useradd -d /home/elasticsearch -s /bin/sh elasticsearch
chown -R elasticsearch:elasticsearch $ES_HOME
chown -R elasticsearch:elasticsearch /mnt/storage/es-data

Edit elasticsearch user’s ‘.bash_profile’

.bash_profile

Get the aliases and functions

if [ -f ~/.bashrc ]; then
. ~/.bashrc
fi

User specific environment and startup programs

PATH=$PATH:$HOME/bin

export PATH

JAVA_HOME needs to be the latest 1.7 JDK on the system

JAVA_HOME=/usr/local/jdk7
export JAVA_HOME

#Add JAVA_HOME to the PATH
PATH=$JAVA_HOME/bin:$PATH

ElasticSearch

export ES_HOME=/usr/local/elasticsearch

unset USERNAME

Edit ‘/etc/security/limits.conf’ (optional as this will be set in the service script, too)

elasticsearch soft nofile 65535
elasticsearch hard nofile 65535

Verify the file descriptor limit

sudo -u elasticsearch -s ulimit -Sn

Install the service

bin/service/elasticsearch install

Edit ‘/etc/init.d/elasticsearch’

Java

JAVA_HOME=/usr/local/jdk7
export JAVA_HOME
PATH=$JAVA_HOME/bin:$PATH
RUN_AS_USER=elasticsearch
ULIMIT_N=65535

Run the service

bin/service/elasticsearch start
or
service elasticsearch start -> here the above error i am getting can you please help me

please help me what wrong i have done  

On Thursday, March 20, 2014 8:10:22 PM UTC+5:30, David Pilato wrote:

What did you download?

--
David :wink:
Twitter : @dadoonet / @elasticsearchfr / @scrutmydocs

Le 20 mars 2014 à 14:54, Anikessh Jain anikess...@gmail.com a écrit :

nobody there to help me , help me please i am in need

On Thursday, March 20, 2014 3:31:42 PM UTC+5:30, Anikessh Jain wrote:

Can anybody help me it is a bit urgent .

On Thursday, March 20, 2014 3:09:56 PM UTC+5:30, Anikessh Jain wrote:

Hi All.

I am a newbie to Elastic search and I am configuring Kibana with
Logstash and Redis and Elasticsearch in Centos 32 Bit and when i am
trying to start the service of elastic search i am getting the below error

WrapperSimpleApp Error: Unable

to locate the class org.elasticsearch.bootstrap.ElasticsearchF : java.lang.ClassNotFoundException: org.elasticsearch.bootstrap.ElasticsearchF

How to solve the above error ,i tried many steps but no use but of no help, have anybody face the same issue please help me.

--
You received this message because you are subscribed to the Google
Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send
an email to elasticsearc...@googlegroups.com.
To view this discussion on the web visit
https://groups.google.com/d/msgid/elasticsearch/6e075a41-21b4-46f9-a9b3-a9beae1210b4%40googlegroups.comhttps://groups.google.com/d/msgid/elasticsearch/6e075a41-21b4-46f9-a9b3-a9beae1210b4%40googlegroups.com?utm_medium=email&utm_source=footer
.
For more options, visit https://groups.google.com/d/optout.

--
You received this message because you are subscribed to the Google Groups
"elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an
email to elasticsearc...@googlegroups.com <javascript:>.
To view this discussion on the web visit
https://groups.google.com/d/msgid/elasticsearch/221d4092-88ec-405d-a9b1-4cae1ce1d3cf%40googlegroups.comhttps://groups.google.com/d/msgid/elasticsearch/221d4092-88ec-405d-a9b1-4cae1ce1d3cf%40googlegroups.com?utm_medium=email&utm_source=footer
.
For more options, visit https://groups.google.com/d/optout.

--
You received this message because you are subscribed to the Google Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an email to elasticsearch+unsubscribe@googlegroups.com.
To view this discussion on the web visit https://groups.google.com/d/msgid/elasticsearch/7519f960-95a4-459e-b8bc-bc73dd0130fd%40googlegroups.com.
For more options, visit https://groups.google.com/d/optout.


(David Pilato) #10

I don't know.

So let me help you for elasticsearch:

wget https://download.elasticsearch.org/elasticsearch/elasticsearch/elasticsearch-1.0.1.tar.gz
tar xzf elasticsearch-1.0.1.tar.gz
./elasticsearch-1.0.1/bin/elasticsearch

And that's all!
This is basically what is written here: http://www.elasticsearch.org/guide/en/elasticsearch/reference/current/setup.html#setup-installation

--
David Pilato | Technical Advocate | Elasticsearch.com
@dadoonet | @elasticsearchfr

Le 20 mars 2014 à 17:49:49, Anikessh Jain (anikesshjain88@gmail.com) a écrit:

Hi David,

But why do people download and install it through elasticsearch-servicewrapper ,does the leatest version supports it all bcoz i want to install kibana with logstash and redis with elasticsearch and i am a little bit confused will it work bcoz i have wasted my whole day on on error.please guide me what to do as i dont know what to do and doing it for first time

On Thursday, March 20, 2014 10:11:52 PM UTC+5:30, David Pilato wrote:
First download a recent version. If you are starting with elasticsearch, you don't need to start with a so old version.
1.0.1 is fine.

Then read the documentation here: http://www.elasticsearch.org/guide/en/elasticsearch/reference/current/setup.html

No need to install so many pieces.

Unzip and launch. That's all.

--
David Pilato | Technical Advocate | Elasticsearch.com
@dadoonet | @elasticsearchfr

Le 20 mars 2014 à 17:06:12, Anikessh Jain (anikess...@gmail.com) a écrit:

please help on the above error

On Thursday, March 20, 2014 9:03:46 PM UTC+5:30, Anikessh Jain wrote:

wget https://download.elasticsearch.org/elasticsearch/elasticsearch/elasticsearch-0.20.2.tar.gz
tar xvf elasticsearch-0.20.2.tar.gz

mv elasticsearch-0.20.2 elasticsearch

wget http://github.com/elasticsearch/elasticsearch-servicewrapper/archive/master.zip
unzip master
mv elasticsearch-servicewrapper-master/service/ elasticsearch/bin
rm -rf master
rm -rf elasticsearch-servicewrapper-master/

Configure ‘elasticsearch.conf’

set.default.ES_HOME=/usr/local/elasticsearch
set.default.ES_HEAP_SIZE=4096
wrapper.java.additional.10=-Des.max-open-files=true

wrapper.logfile.maxsize=5m
wrapper.logfile.maxfiles=5

Add ES home to root user’s ‘.bash_profile’

ElasticSearch

export ES_HOME=/usr/local/elasticsearch

Create elasticsearch user

useradd -d /home/elasticsearch -s /bin/sh elasticsearch
chown -R elasticsearch:elasticsearch $ES_HOME
chown -R elasticsearch:elasticsearch /mnt/storage/es-data

Edit elasticsearch user’s ‘.bash_profile’

.bash_profile

Get the aliases and functions

if [ -f ~/.bashrc ]; then
. ~/.bashrc
fi

User specific environment and startup programs

PATH=$PATH:$HOME/bin

export PATH

JAVA_HOME needs to be the latest 1.7 JDK on the system

JAVA_HOME=/usr/local/jdk7
export JAVA_HOME

#Add JAVA_HOME to the PATH
PATH=$JAVA_HOME/bin:$PATH

ElasticSearch

export ES_HOME=/usr/local/elasticsearch

unset USERNAME

Edit ‘/etc/security/limits.conf’ (optional as this will be set in the service script, too)

elasticsearch soft nofile 65535
elasticsearch hard nofile 65535

Verify the file descriptor limit

sudo -u elasticsearch -s ulimit -Sn

Install the service

bin/service/elasticsearch install

Edit ‘/etc/init.d/elasticsearch’

Java

JAVA_HOME=/usr/local/jdk7
export JAVA_HOME
PATH=$JAVA_HOME/bin:$PATH
RUN_AS_USER=elasticsearch
ULIMIT_N=65535

Run the service

bin/service/elasticsearch start
or
service elasticsearch start -> here the above error i am getting can you please help me

please help me what wrong i have done
On Thursday, March 20, 2014 8:10:22 PM UTC+5:30, David Pilato wrote:
What did you download?

--
David :wink:
Twitter : @dadoonet / @elasticsearchfr / @scrutmydocs

Le 20 mars 2014 à 14:54, Anikessh Jain anikess...@gmail.com a écrit :

nobody there to help me , help me please i am in need

On Thursday, March 20, 2014 3:31:42 PM UTC+5:30, Anikessh Jain wrote:
Can anybody help me it is a bit urgent .

On Thursday, March 20, 2014 3:09:56 PM UTC+5:30, Anikessh Jain wrote:
Hi All.

I am a newbie to Elastic search and I am configuring Kibana with Logstash and Redis and Elasticsearch in Centos 32 Bit and when i am trying to start the service of elastic search i am getting the below error

WrapperSimpleApp Error: Unable

to locate the class org.elasticsearch.bootstrap.ElasticsearchF : java.lang.ClassNotFoundException: org.elasticsearch.bootstrap.ElasticsearchF

How to solve the above error ,i tried many steps but no use but of no help, have anybody face the same issue please help me.

You received this message because you are subscribed to the Google Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an email to elasticsearc...@googlegroups.com.
To view this discussion on the web visit https://groups.google.com/d/msgid/elasticsearch/6e075a41-21b4-46f9-a9b3-a9beae1210b4%40googlegroups.com.
For more options, visit https://groups.google.com/d/optout.

You received this message because you are subscribed to the Google Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an email to elasticsearc...@googlegroups.com.
To view this discussion on the web visit https://groups.google.com/d/msgid/elasticsearch/221d4092-88ec-405d-a9b1-4cae1ce1d3cf%40googlegroups.com.
For more options, visit https://groups.google.com/d/optout.

You received this message because you are subscribed to the Google Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an email to elasticsearch+unsubscribe@googlegroups.com.
To view this discussion on the web visit https://groups.google.com/d/msgid/elasticsearch/7519f960-95a4-459e-b8bc-bc73dd0130fd%40googlegroups.com.
For more options, visit https://groups.google.com/d/optout.

--
You received this message because you are subscribed to the Google Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an email to elasticsearch+unsubscribe@googlegroups.com.
To view this discussion on the web visit https://groups.google.com/d/msgid/elasticsearch/etPan.532b1eb3.6763845e.c9bd%40MacBook-Air-de-David.local.
For more options, visit https://groups.google.com/d/optout.


(Anikessh Jain) #11

thnks for the info

how to run the service on ipv4 bcoz when i am starting ti is starting on
ipv6 instead on ipv4 ,how do i change that

On Thursday, March 20, 2014 10:30:35 PM UTC+5:30, David Pilato wrote:

I don't know.

So let me help you for elasticsearch:

wget
https://download.elasticsearch.org/elasticsearch/elasticsearch/elasticsearch-1.0.1.tar.gz
tar xzf elasticsearch-1.0.1.tar.gz
./elasticsearch-1.0.1/bin/elasticsearch

And that's all!
This is basically what is written here:
http://www.elasticsearch.org/guide/en/elasticsearch/reference/current/setup.html#setup-installation

--
David Pilato | Technical Advocate | Elasticsearch.com
@dadoonet https://twitter.com/dadoonet | @elasticsearchfrhttps://twitter.com/elasticsearchfr

Le 20 mars 2014 à 17:49:49, Anikessh Jain (anikess...@gmail.com<javascript:>)
a écrit:

Hi David,

But why do people download and install it through
elasticsearch-servicewrapper ,does the leatest version supports it all bcoz
i want to install kibana with logstash and redis with elasticsearch and i
am a little bit confused will it work bcoz i have wasted my whole day on on
error.please guide me what to do as i dont know what to do and doing it for
first time

On Thursday, March 20, 2014 10:11:52 PM UTC+5:30, David Pilato wrote:

First download a recent version. If you are starting with
elasticsearch, you don't need to start with a so old version.
1.0.1 is fine.

Then read the documentation here:
http://www.elasticsearch.org/guide/en/elasticsearch/reference/current/setup.html

No need to install so many pieces.

Unzip and launch. That's all.

 -- 

David Pilato | Technical Advocate | Elasticsearch.com
@dadoonet https://twitter.com/dadoonet | @elasticsearchfrhttps://twitter.com/elasticsearchfr

Le 20 mars 2014 à 17:06:12, Anikessh Jain (anikess...@gmail.com) a écrit:

please help on the above error

On Thursday, March 20, 2014 9:03:46 PM UTC+5:30, Anikessh Jain wrote:

wget https://download.elasticsearch.org/elasticsearch/elasticsearch/elasticsearch-0.20.2.tar.gz
tar xvf elasticsearch-0.20.2.tar.gz

mv elasticsearch-0.20.2 elasticsearch

wget http://github.com/elasticsearch/elasticsearch-servicewrapper/archive/master.zip
unzip master
mv elasticsearch-servicewrapper-master/service/ elasticsearch/bin
rm -rf master
rm -rf elasticsearch-servicewrapper-master/

Configure ‘elasticsearch.conf’

set.default.ES_HOME=/usr/local/elasticsearch
set.default.ES_HEAP_SIZE=4096
wrapper.java.additional.10=-Des.max-open-files=true

wrapper.logfile.maxsize=5m
wrapper.logfile.maxfiles=5

Add ES home to root user’s ‘.bash_profile’

ElasticSearch

export ES_HOME=/usr/local/elasticsearch

Create elasticsearch user

useradd -d /home/elasticsearch -s /bin/sh elasticsearch
chown -R elasticsearch:elasticsearch $ES_HOME
chown -R elasticsearch:elasticsearch /mnt/storage/es-data

Edit elasticsearch user’s ‘.bash_profile’

.bash_profile

Get the aliases and functions

if [ -f ~/.bashrc ]; then
. ~/.bashrc
fi

User specific environment and startup programs

PATH=$PATH:$HOME/bin

export PATH

JAVA_HOME needs to be the latest 1.7 JDK on the system

JAVA_HOME=/usr/local/jdk7
export JAVA_HOME

#Add JAVA_HOME to the PATH
PATH=$JAVA_HOME/bin:$PATH

ElasticSearch

export ES_HOME=/usr/local/elasticsearch

unset USERNAME

Edit ‘/etc/security/limits.conf’ (optional as this will be set in the service script, too)

elasticsearch soft nofile 65535
elasticsearch hard nofile 65535

Verify the file descriptor limit

sudo -u elasticsearch -s ulimit -Sn

Install the service

bin/service/elasticsearch install

Edit ‘/etc/init.d/elasticsearch’

Java

JAVA_HOME=/usr/local/jdk7
export JAVA_HOME
PATH=$JAVA_HOME/bin:$PATH
RUN_AS_USER=elasticsearch
ULIMIT_N=65535

Run the service

bin/service/elasticsearch start
or
service elasticsearch start -> here the above error i am getting can you please help me

please help me what wrong i have done   

On Thursday, March 20, 2014 8:10:22 PM UTC+5:30, David Pilato wrote:

What did you download?

--
David :wink:
Twitter : @dadoonet / @elasticsearchfr / @scrutmydocs

Le 20 mars 2014 à 14:54, Anikessh Jain anikess...@gmail.com a écrit :

nobody there to help me , help me please i am in need

On Thursday, March 20, 2014 3:31:42 PM UTC+5:30, Anikessh Jain wrote:

Can anybody help me it is a bit urgent .

On Thursday, March 20, 2014 3:09:56 PM UTC+5:30, Anikessh Jain wrote:

Hi All.

I am a newbie to Elastic search and I am configuring Kibana with
Logstash and Redis and Elasticsearch in Centos 32 Bit and when i am
trying to start the service of elastic search i am getting the below error

WrapperSimpleApp Error: Unable

to locate the class org.elasticsearch.bootstrap.ElasticsearchF : java.lang.ClassNotFoundException: org.elasticsearch.bootstrap.ElasticsearchF

How to solve the above error ,i tried many steps but no use but of no help, have anybody face the same issue please help me.

--
You received this message because you are subscribed to the Google
Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send
an email to elasticsearc...@googlegroups.com.
To view this discussion on the web visit
https://groups.google.com/d/msgid/elasticsearch/6e075a41-21b4-46f9-a9b3-a9beae1210b4%40googlegroups.comhttps://groups.google.com/d/msgid/elasticsearch/6e075a41-21b4-46f9-a9b3-a9beae1210b4%40googlegroups.com?utm_medium=email&utm_source=footer
.
For more options, visit https://groups.google.com/d/optout.

--
You received this message because you are subscribed to the Google Groups
"elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an
email to elasticsearc...@googlegroups.com.
To view this discussion on the web visit
https://groups.google.com/d/msgid/elasticsearch/221d4092-88ec-405d-a9b1-4cae1ce1d3cf%40googlegroups.comhttps://groups.google.com/d/msgid/elasticsearch/221d4092-88ec-405d-a9b1-4cae1ce1d3cf%40googlegroups.com?utm_medium=email&utm_source=footer
.
For more options, visit https://groups.google.com/d/optout.

--
You received this message because you are subscribed to the Google Groups
"elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an
email to elasticsearc...@googlegroups.com <javascript:>.
To view this discussion on the web visit
https://groups.google.com/d/msgid/elasticsearch/7519f960-95a4-459e-b8bc-bc73dd0130fd%40googlegroups.comhttps://groups.google.com/d/msgid/elasticsearch/7519f960-95a4-459e-b8bc-bc73dd0130fd%40googlegroups.com?utm_medium=email&utm_source=footer
.
For more options, visit https://groups.google.com/d/optout.

--
You received this message because you are subscribed to the Google Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an email to elasticsearch+unsubscribe@googlegroups.com.
To view this discussion on the web visit https://groups.google.com/d/msgid/elasticsearch/ee2db8f2-6c77-41f5-9596-c0aa836b7d85%40googlegroups.com.
For more options, visit https://groups.google.com/d/optout.


(David Pilato) #12

On the same page I gave you, you have a chapter "configuration".
I think you should at least read it.

Also on the guide, there is a search bar. Very useful to search for some information. Try with "network".

I'm sure you will find information you are looking for.

--
David :wink:
Twitter : @dadoonet / @elasticsearchfr / @scrutmydocs

Le 20 mars 2014 à 18:26, Anikessh Jain anikesshjain88@gmail.com a écrit :

thnks for the info

how to run the service on ipv4 bcoz when i am starting ti is starting on ipv6 instead on ipv4 ,how do i change that

On Thursday, March 20, 2014 10:30:35 PM UTC+5:30, David Pilato wrote:
I don't know.

So let me help you for elasticsearch:

wget https://download.elasticsearch.org/elasticsearch/elasticsearch/elasticsearch-1.0.1.tar.gz
tar xzf elasticsearch-1.0.1.tar.gz
./elasticsearch-1.0.1/bin/elasticsearch

And that's all!
This is basically what is written here: http://www.elasticsearch.org/guide/en/elasticsearch/reference/current/setup.html#setup-installation

--
David Pilato | Technical Advocate | Elasticsearch.com
@dadoonet | @elasticsearchfr

Le 20 mars 2014 à 17:49:49, Anikessh Jain (anikess...@gmail.com) a écrit:

Hi David,

But why do people download and install it through elasticsearch-servicewrapper ,does the leatest version supports it all bcoz i want to install kibana with logstash and redis with elasticsearch and i am a little bit confused will it work bcoz i have wasted my whole day on on error.please guide me what to do as i dont know what to do and doing it for first time

On Thursday, March 20, 2014 10:11:52 PM UTC+5:30, David Pilato wrote:
First download a recent version. If you are starting with elasticsearch, you don't need to start with a so old version.
1.0.1 is fine.

Then read the documentation here: http://www.elasticsearch.org/guide/en/elasticsearch/reference/current/setup.html

No need to install so many pieces.

Unzip and launch. That's all.

--
David Pilato | Technical Advocate | Elasticsearch.com
@dadoonet | @elasticsearchfr

Le 20 mars 2014 à 17:06:12, Anikessh Jain (anikess...@gmail.com) a écrit:

please help on the above error

On Thursday, March 20, 2014 9:03:46 PM UTC+5:30, Anikessh Jain wrote:

wget https://download.elasticsearch.org/elasticsearch/elasticsearch/elasticsearch-0.20.2.tar.gz
tar xvf elasticsearch-0.20.2.tar.gz

mv elasticsearch-0.20.2 elasticsearch

wget http://github.com/elasticsearch/elasticsearch-servicewrapper/archive/master.zip
unzip master
mv elasticsearch-servicewrapper-master/service/ elasticsearch/bin
rm -rf master
rm -rf elasticsearch-servicewrapper-master/

Configure ‘elasticsearch.conf’

set.default.ES_HOME=/usr/local/elasticsearch
set.default.ES_HEAP_SIZE=4096
wrapper.java.additional.10=-Des.max-open-files=true

wrapper.logfile.maxsize=5m
wrapper.logfile.maxfiles=5

Add ES home to root user’s ‘.bash_profile’

ElasticSearch

export ES_HOME=/usr/local/elasticsearch

Create elasticsearch user

useradd -d /home/elasticsearch -s /bin/sh elasticsearch
chown -R elasticsearch:elasticsearch $ES_HOME
chown -R elasticsearch:elasticsearch /mnt/storage/es-data

Edit elasticsearch user’s ‘.bash_profile’

.bash_profile

Get the aliases and functions

if [ -f ~/.bashrc ]; then
. ~/.bashrc
fi

User specific environment and startup programs

PATH=$PATH:$HOME/bin

export PATH

JAVA_HOME needs to be the latest 1.7 JDK on the system

JAVA_HOME=/usr/local/jdk7
export JAVA_HOME

#Add JAVA_HOME to the PATH
PATH=$JAVA_HOME/bin:$PATH

ElasticSearch

export ES_HOME=/usr/local/elasticsearch

unset USERNAME

Edit ‘/etc/security/limits.conf’ (optional as this will be set in the service script, too)

elasticsearch soft nofile 65535
elasticsearch hard nofile 65535

Verify the file descriptor limit

sudo -u elasticsearch -s ulimit -Sn

Install the service

bin/service/elasticsearch install

Edit ‘/etc/init.d/elasticsearch’

Java

JAVA_HOME=/usr/local/jdk7
export JAVA_HOME
PATH=$JAVA_HOME/bin:$PATH
RUN_AS_USER=elasticsearch
ULIMIT_N=65535

Run the service
bin/service/elasticsearch start
or
service elasticsearch start -> here the above error i am getting can you please help me
please help me what wrong i have done
On Thursday, March 20, 2014 8:10:22 PM UTC+5:30, David Pilato wrote:
What did you download?

--
David :wink:
Twitter : @dadoonet / @elasticsearchfr / @scrutmydocs

Le 20 mars 2014 à 14:54, Anikessh Jain anikess...@gmail.com a écrit :

nobody there to help me , help me please i am in need

On Thursday, March 20, 2014 3:31:42 PM UTC+5:30, Anikessh Jain wrote:
Can anybody help me it is a bit urgent .

On Thursday, March 20, 2014 3:09:56 PM UTC+5:30, Anikessh Jain wrote:
Hi All.

I am a newbie to Elastic search and I am configuring Kibana with Logstash and Redis and Elasticsearch in Centos 32 Bit and when i am trying to start the service of elastic search i am getting the below error

WrapperSimpleApp Error: Unable
to locate the class org.elasticsearch.bootstrap.ElasticsearchF : java.lang.ClassNotFoundException: org.elasticsearch.bootstrap.ElasticsearchF

How to solve the above error ,i tried many steps but no use but of no help, have anybody face the same issue please help me.
--
You received this message because you are subscribed to the Google Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an email to elasticsearc...@googlegroups.com.
To view this discussion on the web visit https://groups.google.com/d/msgid/elasticsearch/6e075a41-21b4-46f9-a9b3-a9beae1210b4%40googlegroups.com.
For more options, visit https://groups.google.com/d/optout.
--
You received this message because you are subscribed to the Google Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an email to elasticsearc...@googlegroups.com.
To view this discussion on the web visit https://groups.google.com/d/msgid/elasticsearch/221d4092-88ec-405d-a9b1-4cae1ce1d3cf%40googlegroups.com.
For more options, visit https://groups.google.com/d/optout.
--
You received this message because you are subscribed to the Google Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an email to elasticsearc...@googlegroups.com.
To view this discussion on the web visit https://groups.google.com/d/msgid/elasticsearch/7519f960-95a4-459e-b8bc-bc73dd0130fd%40googlegroups.com.
For more options, visit https://groups.google.com/d/optout.

--
You received this message because you are subscribed to the Google Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an email to elasticsearch+unsubscribe@googlegroups.com.
To view this discussion on the web visit https://groups.google.com/d/msgid/elasticsearch/ee2db8f2-6c77-41f5-9596-c0aa836b7d85%40googlegroups.com.
For more options, visit https://groups.google.com/d/optout.

--
You received this message because you are subscribed to the Google Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an email to elasticsearch+unsubscribe@googlegroups.com.
To view this discussion on the web visit https://groups.google.com/d/msgid/elasticsearch/03CA74FA-FD9E-412B-B41D-38A35F70E75C%40pilato.fr.
For more options, visit https://groups.google.com/d/optout.


(Ivan Brusic) #13

Include -Djava.net.preferIPv4Stack=true to your JAVA_OPTS environment
variable before starting Elasticsearch. Also read up on the network page
that David referred to:
http://www.elasticsearch.org/guide/en/elasticsearch/reference/current/modules-network.html

If you want a control wrapper around Elasticsearch, you might be better off
installing via rpm/yum and not use the service wrapper.

Cheers,

Ivan

On Thu, Mar 20, 2014 at 10:26 AM, Anikessh Jain anikesshjain88@gmail.comwrote:

thnks for the info

how to run the service on ipv4 bcoz when i am starting ti is starting on
ipv6 instead on ipv4 ,how do i change that

On Thursday, March 20, 2014 10:30:35 PM UTC+5:30, David Pilato wrote:

I don't know.

So let me help you for elasticsearch:

wget https://download.elasticsearch.org/elasticsearch/elasticsearch/
elasticsearch-1.0.1.tar.gz
tar xzf elasticsearch-1.0.1.tar.gz
./elasticsearch-1.0.1/bin/elasticsearch

And that's all!
This is basically what is written here: http://www.
elasticsearch.org/guide/en/elasticsearch/reference/
current/setup.html#setup-installation

--
David Pilato | Technical Advocate | Elasticsearch.com
@dadoonet https://twitter.com/dadoonet | @elasticsearchfrhttps://twitter.com/elasticsearchfr

Le 20 mars 2014 à 17:49:49, Anikessh Jain (anikess...@gmail.com) a écrit:

Hi David,

But why do people download and install it through
elasticsearch-servicewrapper ,does the leatest version supports it all bcoz
i want to install kibana with logstash and redis with elasticsearch and i
am a little bit confused will it work bcoz i have wasted my whole day on on
error.please guide me what to do as i dont know what to do and doing it for
first time

On Thursday, March 20, 2014 10:11:52 PM UTC+5:30, David Pilato wrote:

First download a recent version. If you are starting with
elasticsearch, you don't need to start with a so old version.
1.0.1 is fine.

Then read the documentation here: http://www.
elasticsearch.org/guide/en/elasticsearch/reference/current/setup.html

No need to install so many pieces.

Unzip and launch. That's all.

 --

David Pilato | Technical Advocate | Elasticsearch.com
@dadoonet https://twitter.com/dadoonet | @elasticsearchfrhttps://twitter.com/elasticsearchfr

Le 20 mars 2014 à 17:06:12, Anikessh Jain (anikess...@gmail.com) a
écrit:

please help on the above error

On Thursday, March 20, 2014 9:03:46 PM UTC+5:30, Anikessh Jain wrote:

wget https://download.elasticsearch.org/elasticsearch/elasticsearch/elasticsearch-0.20.2.tar.gz
tar xvf elasticsearch-0.20.2.tar.gz

mv elasticsearch-0.20.2 elasticsearch

wget http://github.com/elasticsearch/elasticsearch-servicewrapper/archive/master.zip
unzip master
mv elasticsearch-servicewrapper-master/service/ elasticsearch/bin
rm -rf master
rm -rf elasticsearch-servicewrapper-master/

Configure 'elasticsearch.conf'

set.default.ES_HOME=/usr/local/elasticsearch
set.default.ES_HEAP_SIZE=4096
wrapper.java.additional.10=-Des.max-open-files=true

wrapper.logfile.maxsize=5m
wrapper.logfile.maxfiles=5

Add ES home to root user's '.bash_profile'

ElasticSearch

export ES_HOME=/usr/local/elasticsearch

Create elasticsearch user

useradd -d /home/elasticsearch -s /bin/sh elasticsearch
chown -R elasticsearch:elasticsearch $ES_HOME
chown -R elasticsearch:elasticsearch /mnt/storage/es-data

Edit elasticsearch user's '.bash_profile'

.bash_profile

Get the aliases and functions

if [ -f ~/.bashrc ]; then
. ~/.bashrc
fi

User specific environment and startup programs

PATH=$PATH:$HOME/bin

export PATH

JAVA_HOME needs to be the latest 1.7 JDK on the system

JAVA_HOME=/usr/local/jdk7
export JAVA_HOME

#Add JAVA_HOME to the PATH
PATH=$JAVA_HOME/bin:$PATH

ElasticSearch

export ES_HOME=/usr/local/elasticsearch

unset USERNAME

Edit '/etc/security/limits.conf' (optional as this will be set in the service script, too)

elasticsearch soft nofile 65535
elasticsearch hard nofile 65535

Verify the file descriptor limit

sudo -u elasticsearch -s ulimit -Sn

Install the service

bin/service/elasticsearch install

Edit '/etc/init.d/elasticsearch'

Java

JAVA_HOME=/usr/local/jdk7
export JAVA_HOME
PATH=$JAVA_HOME/bin:$PATH
RUN_AS_USER=elasticsearch
ULIMIT_N=65535

Run the service

bin/service/elasticsearch start
or
service elasticsearch start -> here the above error i am getting can you please help me

please help me what wrong i have done

On Thursday, March 20, 2014 8:10:22 PM UTC+5:30, David Pilato
wrote:

What did you download?

--
David :wink:
Twitter : @dadoonet / @elasticsearchfr / @scrutmydocs

Le 20 mars 2014 à 14:54, Anikessh Jain anikess...@gmail.com a
écrit :

nobody there to help me , help me please i am in need

On Thursday, March 20, 2014 3:31:42 PM UTC+5:30, Anikessh Jain wrote:

Can anybody help me it is a bit urgent .

On Thursday, March 20, 2014 3:09:56 PM UTC+5:30, Anikessh Jain wrote:

Hi All.

I am a newbie to Elastic search and I am configuring Kibana with
Logstash and Redis and Elasticsearch in Centos 32 Bit and when i am
trying to start the service of elastic search i am getting the below error

WrapperSimpleApp Error: Unable

to locate the class org.elasticsearch.bootstrap.ElasticsearchF : java.lang.ClassNotFoundException: org.elasticsearch.bootstrap.ElasticsearchF

How to solve the above error ,i tried many steps but no use but of no help, have anybody face the same issue please help me.

--
You received this message because you are subscribed to the Google
Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send
an email to elasticsearc...@googlegroups.com.
To view this discussion on the web visit https://groups.google.com/d/
msgid/elasticsearch/6e075a41-21b4-46f9-a9b3-a9beae1210b4%
40googlegroups.comhttps://groups.google.com/d/msgid/elasticsearch/6e075a41-21b4-46f9-a9b3-a9beae1210b4%40googlegroups.com?utm_medium=email&utm_source=footer
.
For more options, visit https://groups.google.com/d/optout.

--
You received this message because you are subscribed to the Google
Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send
an email to elasticsearc...@googlegroups.com.
To view this discussion on the web visit https://groups.google.com/d/
msgid/elasticsearch/221d4092-88ec-405d-a9b1-4cae1ce1d3cf%
40googlegroups.comhttps://groups.google.com/d/msgid/elasticsearch/221d4092-88ec-405d-a9b1-4cae1ce1d3cf%40googlegroups.com?utm_medium=email&utm_source=footer
.
For more options, visit https://groups.google.com/d/optout.

--
You received this message because you are subscribed to the Google Groups
"elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an
email to elasticsearc...@googlegroups.com.
To view this discussion on the web visit https://groups.google.com/d/
msgid/elasticsearch/7519f960-95a4-459e-b8bc-bc73dd0130fd%
40googlegroups.comhttps://groups.google.com/d/msgid/elasticsearch/7519f960-95a4-459e-b8bc-bc73dd0130fd%40googlegroups.com?utm_medium=email&utm_source=footer
.
For more options, visit https://groups.google.com/d/optout.

--
You received this message because you are subscribed to the Google Groups
"elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an
email to elasticsearch+unsubscribe@googlegroups.com.
To view this discussion on the web visit
https://groups.google.com/d/msgid/elasticsearch/ee2db8f2-6c77-41f5-9596-c0aa836b7d85%40googlegroups.comhttps://groups.google.com/d/msgid/elasticsearch/ee2db8f2-6c77-41f5-9596-c0aa836b7d85%40googlegroups.com?utm_medium=email&utm_source=footer
.

For more options, visit https://groups.google.com/d/optout.

--
You received this message because you are subscribed to the Google Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an email to elasticsearch+unsubscribe@googlegroups.com.
To view this discussion on the web visit https://groups.google.com/d/msgid/elasticsearch/CALY%3DcQB0S6mf0ebBUdr7gkk6j_6TELvMkO9us0zMts3NBfA4-g%40mail.gmail.com.
For more options, visit https://groups.google.com/d/optout.


(system) #14