Elasticsearch fails to install with Header V4 RSA/SHA1 signature: BAD, key ID d88e42b4


(Ivan Kovalev) #1

I am in restricted environment and cannot do rpm --import https://packages.elastic.co/GPG-KEY-elasticsearch . Therefore I downloaded elasticsearch-2.3.0.rpm from website to install on RedHat 2.6.18-407.el5 #1 SMP Fri Oct 16 12:04:40 EDT 2015 x86_64 x86_64 x86_64 GNU/Linux. I am getting this error: "error: elasticsearch-2.3.0-1: Header V4 RSA/SHA1 signature: BAD, key ID d88e42b4" After that RPM is reported as installed, but this is not true, package is not there. I was using --nogpgcheck and tested yum install or yum localinstall or rpm -ivh .


(Mark Walkom) #2

Why not download the signature as well and then just import from a file?


(Ivan Kovalev) #3

How do I download signature?


(Mark Walkom) #4

wget https://packages.elastic.co/GPG-KEY-elasticsearch.


(Ivan Kovalev) #5

I did
rpm --import ./GPG-KEY-elasticsearch
yum install ./elasticsearch-2.3.0.rpm
The same result:
error: rpmts_HdrFromFdno: Header V4 RSA/SHA1 signature: BAD, key ID d88e42b4
Problem opening package elasticsearch-2.3.0.rpm
And if I do --nogpgcheck, it reports the same error and does not install.
Am I doing something wrong?


(Ivan Kovalev) #6

Checking public keys:
rpm -qa gpg-pubkey* 
gpg-pubkey-d88e42b4-52371eca
gpg-pubkey-37017186-45761324
[root@webwhgn3l ~]# rpm -qa gpg-pubkey* --qf "%{name}-%{version}-%{release}-%{summary}\n"
gpg-pubkey-d88e42b4-52371eca-gpg(Elasticsearch (Elasticsearch Signing Key) dev_ops@elasticsearch.org) 
gpg-pubkey-37017186-45761324-gpg(Red Hat, Inc. (release key) security@redhat.com)

So, the key from Elastic is there. At the same time:
rpm -qi gpg-pubkey-d88e42b4-52371eca-gpg
package gpg-pubkey-d88e42b4-52371eca-gpg is not installed

And /etc/pki/rpm-gpg/ directory has completely different keys.

Sorry, I am confused and do not understand how it is that I can see Elasic key installed and not installed at the same time.


(Ivan Kovalev) #7

Latest question was resolved: " rpm -qi gpg-pubkey-d88e42b4-52371eca" instead of "rpm -qi gpg-pubkey-d88e42b4-52371eca-gpg" shows that Elastic key is in fact installed. That did not help me with package installation though.


(maro) #8

Hi

Not sure if you are still having this issue. for references.

I used wget to downaload the package

then I run

  1. rpm --delsign filebeat-5.1.1-i686.rpm
  2. yum localinstall --nogpgcheck filebeat-5.1.1-i686.rpm

(system) #9