Elasticsearch force parallel collector by default

Im getting below error while adding nodes to cluster. Im using Elasticsearch 7.10.2 . I was not getting this error in 7.4.2

[1] bootstrap checks failed
[1]: JVM is using the serial collector but should not be for the best performance; either it's the default for the VM [OpenJDK 64-Bit Server VM] or -XX:+UseSerialGC was explicitly specified

After reading this Use serial collector check | Elasticsearch Guide [7.13] | Elastic, I got the issue. But this issue is occurring only in docker environment(may be due to OS). So Im thinking to enable parallel collector by default in elasticsearch jvm.options by adding


This seems working. But this fix seems reasonable?

What docker container are you using?

We are embedding elasticsearch into our product container

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.