Elasticsearch gives Read timed out. (read timeout=10)) on sql queries


We have some queries that are executed using SQL and they sometimes produce a read timeout reach. Is there a way to globally increase the timeout value? We are running elasticsearch version 7.7.1.

Hello @zozo6015 ,
Are you asking how to set a "server side" timeout, rather than using the client's request_timeout (assuming you're using the REST API)? Or is changing this client setting somehow inconvenient for your use case?

I was assuming that it is a server side timeout and it doesn't seam to be a request.timeout since that is by default 90s and we did not configured anything on serverside to make it 10s.

There seems to be an issue with the timeout settings, currently only page_timeout is taken into account (also for first request) -- just in case you were trying to set these parameters.

Server-side there is a global search timeout, but that should be disabled by default.

Edit: adding error_trace=true URI parameter might give you some hints about where is the timeout occurring, if the above server setting is indeed left disabled.

1 Like

thanks will look into it.

It seam the issue was fixed by adding &timeout=60 to the request url on the client side.

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.