Elasticsearch index settings locked due to unsupported setting


We are trying to upgrade our elasticsearch cluster from version 6.1 to version 6.8. While upgrading, we noticed that the index settings seem to be locked. Any command to change any index setting results in:

  "error": {
    "root_cause": [
        "type": "remote_transport_exception",
        "reason": "[host][ip:port][indices:admin/settings/update]"
    "type": "illegal_argument_exception",
    "reason": "unknown setting [index.queries.cache.everything] please check that any required plugins are installed, or check the breaking changes documentation for removed settings"
  "status": 400

This cluster has only one index and this index seems to have an unsupported setting.
Is there any way to get past this blocked setting?

While searching I found these two options:

  1. Restoring from snapshot and using the "ignore_index_settings" option.
  2. Reindexing to remove the setting.

This index gets a lot of live traffic and either of these operations will result in downtime, and that is something i am trying to avoid.

Any suggestions on how I can remove this setting without having to reindex or restore from snapshot? Any help is appreciated.


This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.