ElasticSearch Mapping - Need to stop indexing/analyzing a field

Hi Everyone,

I needed some help please.
Each document json has a many fields. One particular field called
"hotlinks" comprises of many internal dynamic object fields.

Doc1:
{
hotlinks : { 112222:{....} , 333333: {.....} , 545555: {.....} }
}

Doc2:
{
hotlinks : { 67756:{....} , 756767: {.....} , 1111111: {.....} }
}

Each document has a hotlinks fields. The hotlinks field comprises of varied
inner hotlink objects. Each key is a java unique id and has objects that
contain data(inner fields)
Now every time i add a new inner hotlink to a document, the ES mapping get
updated. This slows down the system.
Since the inner json objects of "hotlinks" are variable, i do 'not' need
any indexing on this field.

In the mapping configuration for this index/type, how do i specify that i
do not need indexing on the hotlinks fields. I am struggling with the
syntax.

Please help. Really appreciate it.

Thanks,
Karan

--
You received this message because you are subscribed to the Google Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an email to elasticsearch+unsubscribe@googlegroups.com.
For more options, visit https://groups.google.com/groups/opt_out.

Hi Karan,

You need to set enable=false on the holinks object using the mapping
( http://www.elasticsearch.org/guide/reference/mapping/object-type/ )

{
"YOURTYPE": {
"properties": {
"hotlinks": {
"type": "object",
"enabled": false
}
}
}
}

Cheers,
Boaz

On Sunday, August 11, 2013 8:43:54 PM UTC+2, karan wrote:

Hi Everyone,

I needed some help please.
Each document json has a many fields. One particular field called
"hotlinks" comprises of many internal dynamic object fields.

Doc1:
{
hotlinks : { 112222:{....} , 333333: {.....} , 545555: {.....} }
}

Doc2:
{
hotlinks : { 67756:{....} , 756767: {.....} , 1111111: {.....} }
}

Each document has a hotlinks fields. The hotlinks field comprises of
varied inner hotlink objects. Each key is a java unique id and has objects
that contain data(inner fields)
Now every time i add a new inner hotlink to a document, the ES mapping get
updated. This slows down the system.
Since the inner json objects of "hotlinks" are variable, i do 'not' need
any indexing on this field.

In the mapping configuration for this index/type, how do i specify that i
do not need indexing on the hotlinks fields. I am struggling with the
syntax.

Please help. Really appreciate it.

Thanks,
Karan

--
You received this message because you are subscribed to the Google Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an email to elasticsearch+unsubscribe@googlegroups.com.
For more options, visit https://groups.google.com/groups/opt_out.

Hi Boaz,

Thank you so much. This is exactly what i needed.
Really appreciate your help.

Thanks,
Karan

On 12 August 2013 11:42, Boaz Leskes b.leskes@gmail.com wrote:

Hi Karan,

You need to set enable=false on the holinks object using the mapping (
http://www.elasticsearch.org/guide/reference/mapping/object-type/ )

{
"YOURTYPE": {
"properties": {
"hotlinks": {
"type": "object",
"enabled": false
}
}
}
}

Cheers,
Boaz

On Sunday, August 11, 2013 8:43:54 PM UTC+2, karan wrote:

Hi Everyone,

I needed some help please.
Each document json has a many fields. One particular field called
"hotlinks" comprises of many internal dynamic object fields.

Doc1:
{
hotlinks : { 112222:{....} , 333333: {.....} , 545555: {.....} }
}

Doc2:
{
hotlinks : { 67756:{....} , 756767: {.....} , 1111111: {.....} }
}

Each document has a hotlinks fields. The hotlinks field comprises of
varied inner hotlink objects. Each key is a java unique id and has objects
that contain data(inner fields)
Now every time i add a new inner hotlink to a document, the ES mapping
get updated. This slows down the system.
Since the inner json objects of "hotlinks" are variable, i do 'not' need
any indexing on this field.

In the mapping configuration for this index/type, how do i specify that i
do not need indexing on the hotlinks fields. I am struggling with the
syntax.

Please help. Really appreciate it.

Thanks,
Karan

--
You received this message because you are subscribed to the Google Groups
"elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an
email to elasticsearch+unsubscribe@googlegroups.com.
For more options, visit https://groups.google.com/groups/opt_out.

--
You received this message because you are subscribed to the Google Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an email to elasticsearch+unsubscribe@googlegroups.com.
For more options, visit https://groups.google.com/groups/opt_out.