Elasticsearch-mongodb river error

Hi All,

I am running elasticsearch 0.18.7 and mongodb 1.8.3 and I have installed
mongodb-river plugins,

elasticsearch-river-mongodb-1.0.0-SNAPSHOT
mongo-java-driver-2.5.3
elasticsearch-mapper-attachments-1.0.0
tika-app-0.10

The ES server starts fine and when I try to index the person collection
with following command, I get the below given error (filter is null.)
infinitely.

[2013-02-28 13:29:02,102][INFO ][cluster.metadata ] [Kl'rt]
[_river] creating index, cause [auto(index api)], shards [1]/[1], mappings
[]

[2013-02-28 13:29:02,249][INFO ][cluster.metadata ] [Kl'rt]
[_river] update_mapping [mongodb] (dynamic)

[2013-02-28 13:29:02,290][INFO ][river.mongodb ] [Kl'rt]
[mongodb][mongodb] river name [org.elasticsearch.river.RiverName@35f80e40]
monitoring namespace [profile.person]

[2013-02-28 13:29:02,290][INFO ][river.mongodb ] [Kl'rt]
[mongodb][mongodb] starting mongodb stream: host [localhost], port [27017],
gridfs [false], filter [null], db [profile], indexing to
[mongoindex]/[person]

[2013-02-28 13:29:02,325][INFO ][cluster.metadata ] [Kl'rt]
[mongoindex] creating index, cause [api], shards [5]/[1], mappings []

[2013-02-28 13:29:02,480][INFO ][river.mongodb ] [Kl'rt]
[mongodb][mongodb] Start indexer thread.

[2013-02-28 13:29:02,482][INFO ][river.mongodb ] [Kl'rt]
[mongodb][mongodb] Start tailer thread.

[2013-02-28 13:29:02,592][INFO ][river.mongodb ] [Kl'rt]
[mongodb][mongodb] filter is null.

[2013-02-28 13:29:02,599][INFO ][cluster.metadata ] [Kl'rt]
[_river] update_mapping [mongodb] (dynamic)

[2013-02-28 13:29:07,618][INFO ][river.mongodb ] [Kl'rt]
[mongodb][mongodb] filter is null.

[2013-02-28 13:29:12,621][INFO ][river.mongodb ] [Kl'rt]
[mongodb][mongodb] filter is null.

[2013-02-28 13:29:17,623][INFO ][river.mongodb ] [Kl'rt]
[mongodb][mongodb] filter is null.

Kindly advice and please let me know what i am doing wrong.

Thanks in advance.

--
You received this message because you are subscribed to the Google Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an email to elasticsearch+unsubscribe@googlegroups.com.
For more options, visit https://groups.google.com/groups/opt_out.

comments:
Your plugins are very old. How did you install them?
Your ES version is also quite old. Consider moving to 0.20
You did not provide how you create the river (curl command). Hard to tell what's happen.

--
David :wink:
Twitter : @dadoonet / @elasticsearchfr / @scrutmydocs

Le 28 févr. 2013 à 06:48, Sara fuel4mind@gmail.com a écrit :

Hi All,

I am running elasticsearch 0.18.7 and mongodb 1.8.3 and I have installed mongodb-river plugins,

elasticsearch-river-mongodb-1.0.0-SNAPSHOT
mongo-java-driver-2.5.3
elasticsearch-mapper-attachments-1.0.0
tika-app-0.10

The ES server starts fine and when I try to index the person collection with following command, I get the below given error (filter is null.) infinitely.

[2013-02-28 13:29:02,102][INFO ][cluster.metadata ] [Kl'rt] [_river] creating index, cause [auto(index api)], shards [1]/[1], mappings []

[2013-02-28 13:29:02,249][INFO ][cluster.metadata ] [Kl'rt] [_river] update_mapping [mongodb] (dynamic)

[2013-02-28 13:29:02,290][INFO ][river.mongodb ] [Kl'rt] [mongodb][mongodb] river name [org.elasticsearch.river.RiverName@35f80e40] monitoring namespace [profile.person]

[2013-02-28 13:29:02,290][INFO ][river.mongodb ] [Kl'rt] [mongodb][mongodb] starting mongodb stream: host [localhost], port [27017], gridfs [false], filter [null], db [profile], indexing to [mongoindex]/[person]

[2013-02-28 13:29:02,325][INFO ][cluster.metadata ] [Kl'rt] [mongoindex] creating index, cause [api], shards [5]/[1], mappings []

[2013-02-28 13:29:02,480][INFO ][river.mongodb ] [Kl'rt] [mongodb][mongodb] Start indexer thread.

[2013-02-28 13:29:02,482][INFO ][river.mongodb ] [Kl'rt] [mongodb][mongodb] Start tailer thread.

[2013-02-28 13:29:02,592][INFO ][river.mongodb ] [Kl'rt] [mongodb][mongodb] filter is null.

[2013-02-28 13:29:02,599][INFO ][cluster.metadata ] [Kl'rt] [_river] update_mapping [mongodb] (dynamic)

[2013-02-28 13:29:07,618][INFO ][river.mongodb ] [Kl'rt] [mongodb][mongodb] filter is null.

[2013-02-28 13:29:12,621][INFO ][river.mongodb ] [Kl'rt] [mongodb][mongodb] filter is null.

[2013-02-28 13:29:17,623][INFO ][river.mongodb ] [Kl'rt] [mongodb][mongodb] filter is null.

Kindly advice and please let me know what i am doing wrong.

Thanks in advance.

--
You received this message because you are subscribed to the Google Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an email to elasticsearch+unsubscribe@googlegroups.com.
For more options, visit https://groups.google.com/groups/opt_out.

--
You received this message because you are subscribed to the Google Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an email to elasticsearch+unsubscribe@googlegroups.com.
For more options, visit https://groups.google.com/groups/opt_out.

Forget the last comment. I just saw your last mail

--
David :wink:
Twitter : @dadoonet / @elasticsearchfr / @scrutmydocs

Le 28 févr. 2013 à 07:27, David Pilato david@pilato.fr a écrit :

comments:
Your plugins are very old. How did you install them?
Your ES version is also quite old. Consider moving to 0.20
You did not provide how you create the river (curl command). Hard to tell what's happen.

--
David :wink:
Twitter : @dadoonet / @elasticsearchfr / @scrutmydocs

Le 28 févr. 2013 à 06:48, Sara fuel4mind@gmail.com a écrit :

Hi All,

I am running elasticsearch 0.18.7 and mongodb 1.8.3 and I have installed mongodb-river plugins,

elasticsearch-river-mongodb-1.0.0-SNAPSHOT
mongo-java-driver-2.5.3
elasticsearch-mapper-attachments-1.0.0
tika-app-0.10

The ES server starts fine and when I try to index the person collection with following command, I get the below given error (filter is null.) infinitely.

[2013-02-28 13:29:02,102][INFO ][cluster.metadata ] [Kl'rt] [_river] creating index, cause [auto(index api)], shards [1]/[1], mappings []

[2013-02-28 13:29:02,249][INFO ][cluster.metadata ] [Kl'rt] [_river] update_mapping [mongodb] (dynamic)

[2013-02-28 13:29:02,290][INFO ][river.mongodb ] [Kl'rt] [mongodb][mongodb] river name [org.elasticsearch.river.RiverName@35f80e40] monitoring namespace [profile.person]

[2013-02-28 13:29:02,290][INFO ][river.mongodb ] [Kl'rt] [mongodb][mongodb] starting mongodb stream: host [localhost], port [27017], gridfs [false], filter [null], db [profile], indexing to [mongoindex]/[person]

[2013-02-28 13:29:02,325][INFO ][cluster.metadata ] [Kl'rt] [mongoindex] creating index, cause [api], shards [5]/[1], mappings []

[2013-02-28 13:29:02,480][INFO ][river.mongodb ] [Kl'rt] [mongodb][mongodb] Start indexer thread.

[2013-02-28 13:29:02,482][INFO ][river.mongodb ] [Kl'rt] [mongodb][mongodb] Start tailer thread.

[2013-02-28 13:29:02,592][INFO ][river.mongodb ] [Kl'rt] [mongodb][mongodb] filter is null.

[2013-02-28 13:29:02,599][INFO ][cluster.metadata ] [Kl'rt] [_river] update_mapping [mongodb] (dynamic)

[2013-02-28 13:29:07,618][INFO ][river.mongodb ] [Kl'rt] [mongodb][mongodb] filter is null.

[2013-02-28 13:29:12,621][INFO ][river.mongodb ] [Kl'rt] [mongodb][mongodb] filter is null.

[2013-02-28 13:29:17,623][INFO ][river.mongodb ] [Kl'rt] [mongodb][mongodb] filter is null.

Kindly advice and please let me know what i am doing wrong.

Thanks in advance.

--
You received this message because you are subscribed to the Google Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an email to elasticsearch+unsubscribe@googlegroups.com.
For more options, visit https://groups.google.com/groups/opt_out.

--
You received this message because you are subscribed to the Google Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an email to elasticsearch+unsubscribe@googlegroups.com.
For more options, visit https://groups.google.com/groups/opt_out.

--
You received this message because you are subscribed to the Google Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an email to elasticsearch+unsubscribe@googlegroups.com.
For more options, visit https://groups.google.com/groups/opt_out.

Hi David, Thanks for your reply.

Your plugins are very old. How did you install them? Your ES version is
also quite old. Consider moving to 0.20

Yes, we are using old version of es because of the grails plugin we are
using at the moment which supports only 0.18.7 unfortunately.

On Thursday, February 28, 2013 2:27:48 PM UTC+8, David Pilato wrote:

Forget the last comment. I just saw your last mail

--
David :wink:
Twitter : @dadoonet / @elasticsearchfr / @scrutmydocs

Le 28 févr. 2013 à 07:27, David Pilato <da...@pilato.fr <javascript:>> a
écrit :

comments:
Your plugins are very old. How did you install them?
Your ES version is also quite old. Consider moving to 0.20
You did not provide how you create the river (curl command). Hard to tell
what's happen.

--
David :wink:
Twitter : @dadoonet / @elasticsearchfr / @scrutmydocs

Le 28 févr. 2013 à 06:48, Sara <fuel...@gmail.com <javascript:>> a écrit :

Hi All,

I am running elasticsearch 0.18.7 and mongodb 1.8.3 and I have installed
mongodb-river plugins,

elasticsearch-river-mongodb-1.0.0-SNAPSHOT
mongo-java-driver-2.5.3
elasticsearch-mapper-attachments-1.0.0
tika-app-0.10

The ES server starts fine and when I try to index the person collection
with following command, I get the below given error (filter is null.)
infinitely.

[2013-02-28 13:29:02,102][INFO ][cluster.metadata ] [Kl'rt]
[_river] creating index, cause [auto(index api)], shards [1]/[1], mappings
[]

[2013-02-28 13:29:02,249][INFO ][cluster.metadata ] [Kl'rt]
[_river] update_mapping [mongodb] (dynamic)

[2013-02-28 13:29:02,290][INFO ][river.mongodb ] [Kl'rt]
[mongodb][mongodb] river name [org.elasticsearch.river.RiverName@35f80e40]
monitoring namespace [profile.person]

[2013-02-28 13:29:02,290][INFO ][river.mongodb ] [Kl'rt]
[mongodb][mongodb] starting mongodb stream: host [localhost], port [27017],
gridfs [false], filter [null], db [profile], indexing to
[mongoindex]/[person]

[2013-02-28 13:29:02,325][INFO ][cluster.metadata ] [Kl'rt]
[mongoindex] creating index, cause [api], shards [5]/[1], mappings []

[2013-02-28 13:29:02,480][INFO ][river.mongodb ] [Kl'rt]
[mongodb][mongodb] Start indexer thread.

[2013-02-28 13:29:02,482][INFO ][river.mongodb ] [Kl'rt]
[mongodb][mongodb] Start tailer thread.

[2013-02-28 13:29:02,592][INFO ][river.mongodb ] [Kl'rt]
[mongodb][mongodb] filter is null.

[2013-02-28 13:29:02,599][INFO ][cluster.metadata ] [Kl'rt]
[_river] update_mapping [mongodb] (dynamic)

[2013-02-28 13:29:07,618][INFO ][river.mongodb ] [Kl'rt]
[mongodb][mongodb] filter is null.

[2013-02-28 13:29:12,621][INFO ][river.mongodb ] [Kl'rt]
[mongodb][mongodb] filter is null.

[2013-02-28 13:29:17,623][INFO ][river.mongodb ] [Kl'rt]
[mongodb][mongodb] filter is null.

Kindly advice and please let me know what i am doing wrong.

Thanks in advance.

--
You received this message because you are subscribed to the Google Groups
"elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an
email to elasticsearc...@googlegroups.com <javascript:>.
For more options, visit https://groups.google.com/groups/opt_out.

--
You received this message because you are subscribed to the Google Groups
"elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an
email to elasticsearc...@googlegroups.com <javascript:>.
For more options, visit https://groups.google.com/groups/opt_out.

--
You received this message because you are subscribed to the Google Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an email to elasticsearch+unsubscribe@googlegroups.com.
For more options, visit https://groups.google.com/groups/opt_out.

Probably you are already aware of it, the grails plugin is available
for ES 0.20

Jörg

Am 28.02.13 07:43, schrieb Sara:

Yes, we are using old version of es because of the grails plugin we
are using at the moment which supports only 0.18.7 unfortunately.

--
You received this message because you are subscribed to the Google Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an email to elasticsearch+unsubscribe@googlegroups.com.
For more options, visit https://groups.google.com/groups/opt_out.

Yes it is but it uses hibernate and doesn't work with mongodb. I will
better take this plugin and make it work with mongodb removing its
hibernate dependencies.

Thanks.

On Thursday, February 28, 2013 4:27:05 PM UTC+8, Jörg Prante wrote:

Probably you are already aware of it, the grails plugin is available
for ES 0.20

https://github.com/mstein/elasticsearch-grails-plugin

Jörg

Am 28.02.13 07:43, schrieb Sara:

Yes, we are using old version of es because of the grails plugin we
are using at the moment which supports only 0.18.7 unfortunately.

--
You received this message because you are subscribed to the Google Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an email to elasticsearch+unsubscribe@googlegroups.com.
For more options, visit https://groups.google.com/groups/opt_out.