Elasticsearch not receving Packetbeat after x-pack upgrade

I've pointed the elastic search output as follows:

hosts: ["Address:9200"]
username: "elastic"
password: "The Genereated Password"

set xpack monitoring to:

xpack.monitoring.enabled: true

I'm running the latest version of all components.

Hi @imparker,

Could you please share your Packetbeat logs? We should be able to see something there if there is an issue

Best regards

Hi @exekias

How do I view packetbeat logs? If it helps, packetbeat is installed on a windows 2016 server. Thank you.

They should be around C:\ProgramData\metricbeat\Logs

Best regards

Here's the link to the logs. I sent it here as I can't send the file through discuss itself.

Hi @imparker,

I can see this in the logs:

2018-04-19T08:23:33.120-0500	ERROR	pipeline/output.go:74	Failed to connect: Get dial tcp connectex: No connection could be made because the target machine actively refused it.

After enabling X-Pack security all endpoints are upgraded to use SSL, so you should update your elasticsearch output settings to use HTTPS. Have a look to https://www.elastic.co/guide/en/beats/packetbeat/6.2/securing-beats.html for more details.

Best regards

Thank you.

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.