Elasticsearch Problems and Best Distro for Production Deployments

Hey there everyone,

I wanted to write to get some feedback from the community on what people feel is the best Linux distro to utilize for a production deployment of elasticsearch/logstash/kibana. It seems that since the release of version 5.0 I have had nothing but problems getting things up and running on various environments.

Currently it seems that my issues have been related to java permissions when installing x-pack or similar.
I have tried fresh installs of the following distros with no succes:

Ubuntu 14.04.4 desktop
Ubuntu 16.04.1-server-amd64
Ubuntu 16.10-server-amd64
Debian 7.6

Installing x-pack in elasticsearch would often fail with a large number of permission errors regardless of if I attempted using a local copy of x-pack or the auto downloading capability of elasticsearch-plugin.

In terms of Java and the version, I have been installing openJDK-8-jdk (but have tried with version 9 also).

Prior to version 5 I had no issues setting up multimode clusters and gettings things to run in a stable fashion... sooooo I'm hoping that maybe the community could suggest a Linux distro that is known to work out of the box with a subset of packages installed, etc.

My hope is to get a version of 5.2.1 up and running to the point where it can be utilized in a production environment.

Any input on this topic would be greatly appreciated as the frustration level is starting to drive me mad! :slight_smile:

Regardless, thanks in advance for your time on this question..



Sorry for the troubles that you're having. Would you mind sharing console or log messages demonstrating the problem that you're running into?

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.