Elasticsearch REST API Authorization

OK, so I tried using the Elastic.Client.Elasticsearch library to get an index template, but it had some JSON serialization issues that was causing an exception. Next up, I tried using just a regular REST call.

I have create a RestSharp client like so:

var client = new RestClient("https://v8-test.elastic-cloud.com:9243")

ServicePointManager.Expect100Continue = true;
ServicePointManager.SecurityProtocol = SecurityProtocolType.Tls12;

var request = new RestRequest("/_index_template/*", Method.GET)
  OnBeforeDeserialization = rest => { rest.ContentType = "application/json"; }
request.AddHeader("Content-Type", "application/json");
request.AddHeader("authorization", "ApiKey Base64ApiKey");

var response = client.Execute(request);

I am getting a 401 authorization exception for this one. The API Key is one created in Elastic Cloud but it looks like I am not able to use that, and it needs additional authorization. I thought I can create another API Key in Kibana and feed that in via es-secondary-authorization header, but that doesn't work. What kind of authorization do I need to get a template via the Elastic Search API?

The 401 error indicates that the server is unable to authenticate your request. This could be due to an incorrect API key or incorrect usage of the API key.

When using an API key for authentication in Elasticsearch, you should include it in the Authorization header of your HTTP request. The format should be as follows:

Authorization: ApiKey <base64_encoded_credentials>

The <base64_encoded_credentials> part is a Base64-encoded string that is formed by concatenating the API key id and API key secret with a colon (:), like id:secret.

Here's how you can modify your code:

var apiKey = "id:secret"; // replace with your actual id and secret
var encodedApiKey = Convert.ToBase64String(Encoding.UTF8.GetBytes(apiKey));
request.AddHeader("Authorization", "ApiKey " + encodedApiKey);

Please replace "id:secret" with your actual API key id and secret. If you're still facing issues, please ensure that the API key has the necessary permissions to get the index template.

OpsGPT.io helped with part of this answer!

1 Like

@Opster_support OK, your answer wasn't exactly what I was looking for, but it gave me a clue about what was wrong.

When I was creating the encoding for the API Key, I was using the Encoding.ASCII.GetBytes() method, and you suggested using Encoding.UTF8.GetBytes() That works.

In summary, you can use the basic authentication which would be the following:

var auth = Convert.ToBase64String(Encoding.UTF8.GetBytes("username:password"));
request.AddHeader("authorization", "Basic " + auth);

or the method you suggested for using the API Key method. Thank you, I will mark your answer as the solution here as it was good enough to get me on a right track. Thank you!

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.