Elasticsearch service not running after downgrade from 7.16.2 to old version 6.4.2

Hi Everyone,

We were trying to upgrade our Elasticsearch from the 6.4.2 version to 7.16.2 due to log4j vulnerability but after the upgrade directly from 6.4.2 to 7.16.2 the Elasticsearch service was not running so we tried to downgrade to 6.4.2 by uninstalling the 7.16.2 and install the 6.4.2 but the Elasticsearch service is still not running.

Could you please help here?


You can not downgrade.
If you have followed the recommandations, you probably have backups (snapshots) so you could:

  • Restore the cluster in 6.4.2
  • Upgrade to 6.8.23 which contains the security fixes you need

Otherwise, you need to fix the actual problem you have with 7.16. For this, you could start by sharing your logs.

Please read this about how to format your logs.

Hi David,

Thanks for checking on this. So what you suggest now needs to be performed as we already uninstalled 7.16.2 and installed 6.4.2 where the Elasticsearch service is not executing. Could you please help to restore the cluster in 6.4.2?

Where are stored your snapshots?
Where Elasticsearch is running? On premise?

In different Drives on the VM machine. Yes, it is on-prem.

So reinstall a 6.4.2 cluster. Add again the repositories and use the restore endpoint.

I did reinstall the 6.4.2 Elasticsearch but due to the Elasticsearch service is not running not sure how to move ahead. Could you please let me know how I can "Add again the repositories and use the restore endpoint".

Why Elasticsearch is not running again?
Are you using the same data dir as previously? If so, your data dir has probably been upgraded to 7.16. That's why it can't start.

But check the logs.

Yes, we are using the same data directory only.

So that won't work. You need to completely reinstall Elasticsearch. Which means an empty data dir before you start.
Note that will remove all existing data.

So we will get the data back from the restoration?

What is your concern? What does "get the data back from the restoration" mean? If you created snapshot correctly, surely you will be able to restore the snapshot to the whole-new 6.4.2 cluster.

Thanks for the details.

I am trying to uninstall Elasticsearch 6.4.2 but it is not uninstalled. It shows the getting information popup only but didn't uninstall at all.


@ dadoonet Any suggestion on this as 6.4.2 Elasticsearch is not un-installing and I did delete the service as well but no luck.

I have no idea. I think I did not touch windows for 10 years :wink:

May be some manual removal is needed? Like going in the registry to remove the service and then remove the existing installation dir?

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.