Elasticsearch service not starting

Elasticsearch service not starting , we can see below in Elasticsearch-STG logs

low disk watermark [85%] exceeded on free: 37.4gb[14.9%], replicas will not be assigned to this node

That would not prevent the node from starting. Please share the full logs from startup.

let me explain our scenario. we are trying to take snapshot of elasticsearch using below

PUT _snapshot/my_backup
"type": "fs",
"settings": {
"location": "\server\Backups"

we are getting this error message

"type" : "repository_exception",
"reason" : "[my_backup] location [//server/Backups] doesn't match any of the locations specified by path.repo because this setting is empty"

so we add the path.repo in the elasticsearch.yml

after adding path.repo, the service does not start.

however, after undo the changes in the elasticsearch.yml, the service is starting.

please let us know why

I assume you have not added path.repo correctly. Please show the config as well as the logs resulting from starting with this config.

bootstrap.memory_lock: false

    cluster.name: Elasticsearch-STG
    http.port: 9200
    node.data: true
    node.ingest: true
    node.master: true
    node.max_local_storage_nodes: 1
    node.name: XYZABCVMYCLG201
    path.data: D:\elasticsearch_data\data
    path.logs: D:\elasticsearch_data\logs
    transport.tcp.port: 9300
    xpack.license.self_generated.type: basic
    xpack.security.enabled: false
    path.repo : ["\XYZABCVMYCLG201\Backups"]

Please find below the logs:

[2023-07-09T12:52:59,586][WARN ][o.e.r.f.FsRepository ] [XYZABCVMYCLG201] The specified location [//XYZABCVMYCLG201/Backups] should start with a repository path specified by the path.repo setting, but the path.repo setting was not set on this node
[2023-07-09T12:52:59,586][WARN ][o.e.r.RepositoriesService] [XYZABCVMYCLG201] failed to create repository [fs][my_backup]
org.elasticsearch.repositories.RepositoryException: [my_backup] location [//XYZABCVMYCLG201/Backups] doesn't match any of the locations specified by path.repo because this setting is empty

There seem to be a discrepancy between use of forward slashes and backslashes. Make sure it is consistent and that the directory is mounted. I am not a Windows user so am not sure what does and does not work on Windows.

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.