Elasticsearch service times out, although cluster appears to be working properly

I am facing an issue where systemd doesn't appear to realize that Elasticsearch has started successfully after updating to 6.8.0. The cluster shows green, the application can write to it and there are no errors in the logfile, but systemd kills it after TimeoutStartSec is exceeded. I've tried increading TimeoutStartSec, without success.

Welcome to our community! :smiley:

Can you post the systemd output and the Elasticsearch log from startup?

Systemd output:

● elasticsearch.service - Elasticsearch
   Loaded: loaded (/etc/systemd/system/elasticsearch.service; enabled; vendor preset: enabled)
   Active: failed (Result: timeout) since Mon 2020-11-23 18:36:30 EST; 18s ago
     Docs: https://www.elastic.co
  Process: 11871 ExecStart=/usr/share/elasticsearch/bin/elasticsearch -p ${PID_DIR}/elasticsearch.pid --quiet (code=exited, status=143)
 Main PID: 11871 (code=exited, status=143)

Nov 23 18:34:58 damnation systemd[1]: Starting Elasticsearch...
Nov 23 18:34:58 damnation elasticsearch[11871]: warning: Falling back to java on path. This behavior is deprecated. Specify JAVA_HOME
Nov 23 18:36:28 damnation systemd[1]: elasticsearch.service: Start operation timed out. Terminating.
Nov 23 18:36:30 damnation systemd[1]: Failed to start Elasticsearch.
Nov 23 18:36:30 damnation systemd[1]: elasticsearch.service: Unit entered failed state.
Nov 23 18:36:30 damnation systemd[1]: elasticsearch.service: Failed with result 'timeout'.

Elasticsearch log doesn't fit so its here.

I set TimeoutStartSec=infinity and its currently running fine, other than systemd not realizing it.

You can see from the Elasticsearch log that it doesn't become available till 18:35:53, when things turn green.

Have you tried restarting it again to see if it times out, or does it do it every time?

It times out every time. I’ve tried setting TimeoutStartSec as high as 1000. ES starts up long before systemd times out, but it always ends up timing out.

What OS and what version?

Ubuntu 16.04 and ES 6.8.0.

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.