Elastisearch timeout on service start after yum update from 7.3 to 7.4

I installed a brand new single node dev cluster of ES 7.3 earlier this week from the yum repository and ran a yum update to update the stack to 7.4

When i try to run service elasticsearch start i get a timeout, but no errors in the ES logs are anything that could point to a specific issue with the service.

status output:

     elasticsearch.service - Elasticsearch
       Loaded: loaded (/usr/lib/systemd/system/elasticsearch.service; enabled; vendor preset: disabled)
       Active: failed (Result: timeout) since Tue 2019-10-01 14:52:50 CDT; 19min ago
         Docs: http://www.elastic.co
  Process: 12494 ExecStart=/usr/share/elasticsearch/bin/elasticsearch -p ${PID_DIR}/elasticsearch.pid --quiet (code=exited, status=143)
 Main PID: 12494 (code=exited, status=143)
Oct 01 14:51:19 localhost.localdomain systemd[1]: Starting Elasticsearch...
Oct 01 14:51:51 localhost.localdomain elasticsearch[12494]: OpenJDK 64-Bit Server VM warning: Option UseConcMarkSweepGC was deprecated in version 9.0 and will likely be removed in a future release.
Oct 01 14:52:49 localhost.localdomain systemd[1]: elasticsearch.service start operation timed out. Terminating.
Oct 01 14:52:50 localhost.localdomain systemd[1]: Failed to start Elasticsearch.
Oct 01 14:52:50 localhost.localdomain systemd[1]: Unit elasticsearch.service entered failed state.
Oct 01 14:52:50 localhost.localdomain systemd[1]: elasticsearch.service failed.

I get the feeling systemd itself is terminating the startup process. but i don<t have any startup logs in elasticsearch.log either (litteraly nothing coming up!)

Anyine could have an idea of what's going on? i<m used to work with logs and error messages, but i don't have anything to figure that one out.

1 Like

I am having exactly same issue after yum update

I guess its memory related, stopped kibana & logstash, and then started elasticsearch, and it did start without any issues

1 Like

I gave it a try but still no result.

My VM has 12g RAM, Xms and Xmx options are set to 5g and my only index storage apce is less than 1mb so it shouldn't be an issue i believe...

Maybe i could change the service configuration for the timeout delay, and give it a good 10 minutes just to see what happens.

followed instructions regarding setting the service timeout from here and set the TimeoutStartSec=900 and it worked.

2 Likes

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.

Filed this issue to address