Elasticsearch Service won't startup on reboot


We are running our elastic servers on Ubuntu 16.x servers. The services have been enabled. The version of elastic 7.2. Entire path has been included in the .service file and it was installed as a tar file. The symbolic link to start the service is correct/has the proper path because the service file can be found. However, on reboot when checking the status this is the message it shows

● elasticsearch.service
Loaded: not-found (Reason: No such file or directory)
Active: inactive (dead)

When trying to start the service this error comes up.

Failed to start elasticsearch.service: Unit elasticsearch.service not found.

The only way to fix it is to do a daemon-reload, however, on previous test servers this is not needed as the service is able to start on server reboot, by itself.

The logs for elasticsearch show nothing and neither does the journalctl -u elasticsearch

Where did you get the service file from?

The service file came from a debian package. Same OSS version. The idea was to also have it set up as a service/enable it in case the server reboots. It has worked before. But for some reason now it won't. It is 7.2 version.

You'd be better off using the DEB installer if you can.

Have you checked your system level logs to see if it shows anything?

Well I tried using the DEB before but it wasn't working properly and we also settled on being able to keep everything in a custom location. We've already installed and even included OpenDistro for this and because of a very tight timeline we don't have anymore time to change it. We've checked the system level logs, however, there doesn't seem any extra information on this. We've checked the daemon.log file and other logs found within /var/log/all/ but not sure what more this could be.

We were able to fix it. It seems for some reason the location of the service file was causing issues. So we moved it in to the /lib/systemd/system directory. Reenabled from there and did a daemon reload.

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.