Elasticsearch-service-x64 service terminated due to timeout


(Xudong You) #1

We installed ES on windows VM and run ES as auto-start windows service.

Recently, one of our VM restarted after windows auto update, and the ES service on the VM failed to start up due to timeout issue.

Following is the log we got:

A timeout was reached (30000 milliseconds) while waiting for the Elasticsearch 1.7.1 (elasticsearch-service-x64) service to connect.

The Elasticsearch 1.7.1 (elasticsearch-service-x64) service failed to start due to the following error: The service did not respond to the start or control request in a timely fashion.

Any suggestion on how to avoid such issue?


(Xudong You) #2

To clarify, the ES service started successfully after we manually started the ES windows service, and the service could be started successfully after we manually update those VMs.

So sound like it is an incidental issue.

But would like to avoid such kind issue with a solid solution.

Some options from my mind now:

  1. Disable the auto windows update
  2. Increase the windows service timeout value

Any suggestions?


(Xudong You) #3

re-visit this topic.
Can anyone from Elastic help answer the questions?
And is it possible to increase the timeout value for the ElasticSearch windows service? I know I can increase the timeout value for ALL windows service by changing the registry, but I would like a small granular approach.


(system) #4