Elasticsearch snapshot backup in another server is not happening

We are able to backup the snapshot in the same server but we are unable to backup it in other destination server.

We have changed the below settings in elasticsearch.yml file.

path.repo: ["/XSNW10S863S.pharma.aventis.com/Snapshots"]

But still the backup is not happening.
Please help us.

Thanks in advance!!!

can anyone help us on this, as we are unable to proceed further.

Also we tried to include network share path but still backup is not happening.

As per below screenshot, we have provided the config file & network path.

Thanks in advance !!!

can anyone please help us on the above topic ???

What is the error message? What are the logs?

No logs instead , elk service is not running.

If it does not produce any logs at startup it can be due to a malformed yml file.

Otherwise, share the Startup logs pleasE.

I suspect you need to put quotation marks around the path so path.repo is an array of strings (as the examples in the comments).

i have tried the below command but elk service is getting failed to start.

path.repo: ["\X:"]

please find the below yml file, let me know if anything is wrong on this repo side.

 # ----------------------------------- Paths ------------------------------------
 #
 # Path to directory where to store the data (separate multiple locations by comma):
 #
 #path.data: /path/to/data
 #path.repo: ["/mount/backups", "/mount/longterm_backups"]
 path.repo: [ \\\X:\\]
 #
 # Path to log files:
 #
  path.logs: D:\Logs\Elk
 #
 # ----------------------------------- Memory -----------------------------------
 #
 # Lock the memory on startup:

Also i have share the elk logs below for your trace,

 [2020-03-22T11:56:41,198][ERROR][o.e.b.Bootstrap          ] Exception
 java.lang.IllegalStateException: Unable to access 'path.repo' (X:\)
 	at org.elasticsearch.bootstrap.Security.addPath(Security.java:397) ~[elasticsearch-5.3.1.jar:5.3.1]
 	at org.elasticsearch.bootstrap.Security.addFilePermissions(Security.java:280) ~[elasticsearch-5.3.1.jar:5.3.1]
 	at org.elasticsearch.bootstrap.Security.createPermissions(Security.java:208) ~[elasticsearch-5.3.1.jar:5.3.1]
 	at org.elasticsearch.bootstrap.Security.configure(Security.java:114) ~[elasticsearch-5.3.1.jar:5.3.1]
 	at org.elasticsearch.bootstrap.Bootstrap.setup(Bootstrap.java:237) ~[elasticsearch-5.3.1.jar:5.3.1]
 	at org.elasticsearch.bootstrap.Bootstrap.init(Bootstrap.java:360) [elasticsearch-5.3.1.jar:5.3.1]
 	at org.elasticsearch.bootstrap.Elasticsearch.init(Elasticsearch.java:123) [elasticsearch-5.3.1.jar:5.3.1]
 	at org.elasticsearch.bootstrap.Elasticsearch.execute(Elasticsearch.java:114) [elasticsearch-5.3.1.jar:5.3.1]
 	at org.elasticsearch.cli.EnvironmentAwareCommand.execute(EnvironmentAwareCommand.java:58) [elasticsearch-5.3.1.jar:5.3.1]
 	at org.elasticsearch.cli.Command.mainWithoutErrorHandling(Command.java:122) [elasticsearch-5.3.1.jar:5.3.1]
 	at org.elasticsearch.cli.Command.main(Command.java:88) [elasticsearch-5.3.1.jar:5.3.1]
 	at org.elasticsearch.bootstrap.Elasticsearch.main(Elasticsearch.java:91) [elasticsearch-5.3.1.jar:5.3.1]
 	at org.elasticsearch.bootstrap.Elasticsearch.main(Elasticsearch.java:84) [elasticsearch-5.3.1.jar:5.3.1]
 Caused by: java.nio.file.FileSystemException: X:\: Unable to determine if root directory exists
 	at java.nio.file.Files.createDirectories(Files.java:756) ~[?:1.8.0_131]
 	at org.elasticsearch.bootstrap.Security.ensureDirectoryExists(Security.java:439) ~[elasticsearch-5.3.1.jar:5.3.1]
 	at org.elasticsearch.bootstrap.Security.addPath(Security.java:395) ~[elasticsearch-5.3.1.jar:5.3.1]
 	... 12 more

Please help on this...
Thanks in advance !!!

pls help us.

As you are using backslashes in the path it is possible these are interpreted as escape characters. If you compare the path logged to the one in the configuration you can see this might be the case. In order to get two backslashes you may therefore need to escape them, resulting in two pairs of backslashes (4).

1 Like

Please format your code, logs or configuration files using </> icon as explained in this guide and not the citation button. It will make your post more readable.

Or use markdown style like:

```
CODE
```

This is the icon to use if you are not using markdown format:

There's a live preview panel for exactly this reasons.

Lots of people read these forums, and many of them will simply skip over a post that is difficult to read, because it's just too large an investment of their time to try and follow a wall of badly formatted text.
If your goal is to get an answer to your questions, it's in your interest to make it as easy to read and understand as possible.
Please update your post.

Read this and specifically the "Also be patient" part.

It's fine to answer on your own thread after 2 or 3 days (not including weekends) if you don't have an answer.

We tried this but still the same error.

Thanks for your concern.
I have updated the post.

I don't think it's exactly the elasticsearch.yml file as I can see that indentation for path.logs: D:\Logs\Elk is incorrect and probably that would fail your node from starting.

Also this is probably wrong:

path.repo: [ \\\X:\\]

Try something like:

path.repo: [ "\\\\X:\\" ]

or

path.repo: [ "/X:/" ]
1 Like