Elasticsearch snapshot IN_PROGRESS for a long time. The delete snapshot API is also not working

I have a Elasticsearch cluster with following configuration.

Elasticsearch version : 5.1.1
Number of Nodes : 10

A daily snapshot process is running in the Cluster. In which the last snapshot was created few days ago and it's status is still IN_PROGRESS . I tried to delete the pending snapshot via api but it fails.

Also I have performed a cluster rolling restart, created a new repository and tried with taking new snapshot but its giving snapshot in progress exception.

I have listed the tasks in cluster and only found the snapshot delete task with "cancellable" : false.

Please help me to solve this. Thanks in advance.

There were bugs in older Elasticsearch versions such as yours where snapshots could get stuck. A full cluster restart will solve the problem. So will upgrading to a recent version of ES (e.g. 6.8 or 7.4)

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.