Elasticsearch snapshot settings on statefulset (stack)

After setting up the stack, unable to activate the path.repo for snapshotting
the setup is based on the elasticsearch statefulset setup

cant find where to insert:
path.repo: ["/mnt/backup"]

error i'm getting:
curl -XPUT "http://localhost:9200/_snapshot/backup_repo" -H 'Content-Type: application/json' -d'{ "type": "fs", "settings": { "location": "/mnt/backup", "compress": true }}'
{"error":{"root_cause":[{"type":"repository_exception","reason":"[backup_repo] location [/mnt/backup] doesn't match any of the locations specified by path.repo because this setting is empty"}],"type":"repository_exception","reason":"[backup_repo] failed to create repository","caused_by":{"type":"repository_exception","reason":"[backup_repo] location [/mnt/backup] doesn't match any of the locations specified by path.repo because this setting is empty"}},"status":500}%

Here is the documentation on how to register a filesystem (fs) repository.

You will need to set the path.repo in the elasticsearch.yml of every master and data node in your cluster, then you will need to mount the same shared area in every master and data node in your cluster.

You also need to do a restart of every node to enable a fs repository.

the Elasticsearch is installed by Helm, using statefulset config,
for this installation theres no elasticsearch yaml file,

cant find where the to apply the values fro snapshot
following this document,

though it has a section of snapshot - not clear how to do this.